[tvOS] vu+TV App (AppleTV) Support Thread

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Ich hab auch das Problem, das die App nach dem letzten Update, kurz nach dem Start sich selbst beendet.
      Iphone x ,
      Die App entfernen und erneut installieren hilft nicht.


      Nachtrag, habe gerade noch mal die App entfernt und neu Installiert, jetzt gehts.

      The post was edited 1 time, last by Helmut 15 ().

    • Seltsam. Ich hoffe, dass ihr die Option aktiviert habt, Crashlogs mit den Entwicklern zu teilen. Dann sollte ich CrashLogs bekommen, die ich analysieren kann. Vielleicht finde ich den Fehler.

      Ist noch iOS 12?
    • Ich wollte die Antwort von gerade eben editieren - ging aber nicht, da war ich wohl zu spät dran...

      Man findet die Einstellung "Mit App-Entwicklern teilen" in "Einstellungen" -> "Datenschutz" -> "Analyse" (iOS, wird bei tvOS aber nicht anders sein).

      Ich werde mal heute Abend in Xcode nachschauen, ob es Crash-Logs gibt...
    • ich habe es gesehen.
      Ich bin schon daran, eine Lösung zu finden.
      Es scheint, dass Services von der Box gemeldet werden, die eigentlich "hidden" sind. Woher auch immer diese kommen. Da habe ich den Filter verbessert. Zudem wurde beim "reinigen" des PIconFilenames ein Wert falsch verwendet. Das könnte die Ursache sein.

      Ich werde spätestens morgen eine neue Version via TestFlight bauen. Ich kann das Problem bei mir nicht rekonstruieren, bräuchte also Beta-Tester dafür. Die bisherigen Tester waren entweder nicht verfügbar (Urlaubszeit) oder hatten das Problem ebenfalls nicht.

      Zudem arbeite ich an dem Problem mit den Unterverzeichnissen... mal schauen, ob ich da eine gute Lösung finde. Mein jetziger Ansatz ist vielversprechend...
    • @Praktiker Hier mal meine Idee. Wenn die App rekursiv durch die Verzeichnisse geht, dann wird jetzt auch eine Referenz auf das darüberliegende Verzeichnis gemerkt. So kann die App sich wieder hoch hangeln, bis sie bei den Locations angelangt ist, die von der Box gemeldet werden.
      Dann habe ich eine entsprechende Sortierung der "Locations" eingebaut, so dass dafür eine brauchbare Zuordnung entsteht.

      Auf einem aTV hätte ich noch genügend Platz, den angezeigten Namen aus den übergeordneten Verzeichnissen zusammen zu bauen, beim iPhone habe ich den nicht. Daher blende ich die "leeren" Serien Namen und Season Nummern nicht aus sondern rücke Ebene für Ebene den Titel ein (hier noch mit einem "> " dargestellt, mal sehen was ich dann final dafür nutzen werde.

      Das ganze sieht dann so aus (wobei ich nur 2 Serien angelegt habt mit ein paar Seasons und zwei Filmchen die irgendwo anders noch rumlagen):

      Simulator Screen Shot - iPhone 8 Plus - 2019-08-01 at 14.13.20.png
      Das ist auf jeden Fall übersichtlicher und man kann die Season-Verzeichnisse den Serien zuordnen. Was hältst du davon?
    • Hallo jabbela,

      dass sieht doch erstmal gut aus. Wenn die Sortierung so funktioniert dass erst der Serienname und dann die Season kommt sollte man damit gut arbeiten können.
      Werde das Update testen wenn verfügbar.
      Klasse Support deinerseits.
      Grüße aus dem Pott
      Praktiker
    • Ein aktuellerer Screenshot für iOS:
      Simulator Screen Shot - iPhone 8 Plus - 2019-08-01 at 15.31.37.png

      Bei den Verzeichnissen, die keine Aufnahmen enthalten, habe ich die Einrückung entfernt, den Bullet entfernt und man kann das auch nicht mehr auswählen - macht ja keinen Sinn...

      Jetzt muss ich mich mal dran setzen, und das ganze noch für tvOS nachbasteln.

      The post was edited 1 time, last by jabbela ().

    • So, die neuen Versionen (tvOS: 1.5.2 Build 106, iOS: 1.2.1 Build 21) sind bei Apple für TestFlight eingereicht. Mal sehen wann der Review fertig ist, dann könnt ihr wieder testen...

      Wichtig: Die Sache mit den Verzeichnissen, die Serienrekorder anlegt und ob alle Services und ihre PIcons geladen werden - das dürfte in Zusammenang mit manchen OpenWebIF Versionen zum Crash geführt haben.

      Einer der Betroffenen hat mir berichtet, dass das Problem behoben war, nachdem er eine neuen Version seiner Distri auf seinem STB installiert hatte.
    • New

      Habe auf meinem Apple TV 4k die 1.5.1 laufen, Server ist meine Uno 4k se. Bin sehr zufrieden und kann von keinen Problemen berichten, nutze es allerdings 'nur' für live-tv. Ein epg wäre noch schön, mit Timer etc., habe aber schon gelesen, dass es etwas knifflig ist, also alles okay.
      Vielen Dank für deine tolle Arbeit.
    • New

      Zu früh gelobt :D habe heute mal die Tonausgabe über AirPlay Versuch und der Ton ruckelt unglaublich. Bei Prime und Netflix keine Probleme, liegt also an der App :(
    • New

      @Menne Die Wiedergabe der Streams wird via VLCKit durchgeführt. Ich glaube die haben da schon nachgebessert, aber das muss ich erst einmal testen. Aber insgesamt muss ich warten, bis VideoLAN das Problem behebt.

      Ansonsten - mit dem letzen TestFlight sehe ich im AppSote Portal einige Crashes, aber ich bekomme keine CrashLogs in Xcode. Bitte die Weitergabe von CrashLogs an Entwickler zulassen. Sonst habe ich es schwer, die Ursache einzukreisen.
    • New

      @jabbela also liegt es an VLC? Mit Crashlogs meinst du debug logging oder wo finde ich die Einstellung?

      Habs in den Einstellungen vom Apple TV gefunden. Waren aktiviert.

      The post was edited 2 times, last by hgdo ().