[tvOS] vu+TV App (AppleTV) Support Thread

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Oh je... da war jetzt viel los hier... Sorry, dass ich mich so spät erst wieder melde.

      Ich steckte bei einem sau-doofen Fehler mitder Topshelf fest - bei manchen wir einfach der Titel nicht angezeigt. Da muss man erst Mal drauf kommen, dass es ein Fehler in tvOS ist, der nur bei langen Titeln auftritt... Jetzt ist auch nochder Bugreporter von Apple kaputt...
      Also wer das Problem bei Topshelf hat: sorry - aber das Problem muss Apple fixen.

      Ansonsten - wie erwähnt, es kommt nicht nur auf die Bandbreite sondern auch auf die Latenz an. Das Problem ist ja nicht, dass die 6 MBit/s durch das Netzwerk müssen - sie müssen vorher verschlüsselt werden müssen, meist mit rotierenden Session-Keys etc. Da kann deine Box flott sein, dein iPhone auch, wenn der Router sich da verschluckt dann ruckelt es. Ich habe sogar das Problem, dass manchmal in meinem Fritz-Mesh WLAN einfach mal ein paar Sekunden keineDaten kommen - und dann geht stockt es - und kurz darauf läuft es wieder ganz normal.

      Ich wäre grundsätzlich vorsichtig, Streams über DynDNS zu öffnen - da der Login als Teil der URL übertragen wird - und damit nicht sicher ist. Ich möchte das noch ändern - dass die Credentials nicht direkt übertragen werden, sondern erst wenn der Server danach fragt... macht es schon ein wenig sicherer - und dann kann ich auch noch Mal mit Streaming via HTTPS versuchen, aber die Zertifikate auf den STBs sind nicht vertrauenswürdig, weil Vu+ die selbst signiert. Das mag iOS/tvOS nicht.

      Ansonsten geht es auch bald los, das die via "Catalyst" mal versuche, die App für macOS zu bauen. Das ist jetzt mit Xcode 11 verfügbar, seit gestern die WWDC eröffnet wurde...
    • Sorry - was für ein schlechtes Deutsch - sorry für die vielen Fehler.

      zu den PIcons: einfacher Test - öffne OWIF im Browser, wähle eines der PIcons auf und öffne genau dieses PIcon in einem neuen Tab - dann schau dir die URL an. Wenn die URL am Ende den Namen des Senders hat (wie auch immer kodiert), dann kann die App diese nicht finden - wenn es wie die "Service-Referenz" aussieht (nur die ":" mit "_" ersetzt) dann klappt es mit der App. Es gibt ca. 5 verschiedene Varianten, wie OWIF den Sendern die PIcons zuordnet, das kann OWIF auch, weil es auf der Box läuft und direkten Zugriff auf das Dateisystem hat. Meine App müsste alle Varianten (wie sie aussehen kann man ja im Source von OWIF anschauen) ausprobieren und dafür für jede Variante eine Anfrage an die Box stellen. Das mag der limitierte Webserver auf der Box nicht so gern und ist auch in der App sehr aufwändig.

      Daher habe ich mit den Entwicklern von OWIF Kontakt aufgenommen und sie haben einen der Anfragen um eine Option ergänzt, mit der ich die URL der PIcon-Datei bekomme - alle die OWIF findet oder default.png, wenn das nicht gefunden wird. Das ist seit OWIF 1.4.2 implementiert - zur Zeit scheint aber noch Version 1.2.8 im VTi enthalten zu sein. Bei anderen Images wurde die Anpassung in OWIF und meiner App bereits erfolgreich getestet.

      Wenn also PIcons in OWIF angezeigt werden, aber nicht in der App - dann führt bitte obigen Test durch. Es sollte dann helfen, ein anderes PIcon-Set zu installieren oder man muss eben warten, bis VTi das enthaltene OWIF aktualisiert - ihr könnt ja bei dem VTi-Team nachfragen, wann das passiert bzw. warum das nicht bereits passiert ist.

      In der aktuellen Beta nutze ich ein selbst-gebautes VLCKit, das mir erlaubt, auch einfache Klick auf der Siri-Remote zu erhalten - so dass man nicht mehr Doppel-Clicken muss um die EPG-Info anzuzeigen. Es ist jetzt auch endlich wieder die Play/Pause-Taste wiederbelebt - bei LiveTV wird gemutet, Aufnahmen werden angehalten. Sonst kann man den Video-Aspect Ration im Top-Menu einstellen - auch wenn tvOS und VLCKit nicht ganz so korrekt zusammenarbeiten.

      Ich habe mir gestern auch mal macOS 10.15 und Xcode 11 installiert und wollte einfach mal eine Version mit Catalyst (intern UIKitForMac) bauen, klappt aber noch nicht, weil die verwendeten Frameworks (VLCKit und FTPClient) noch nicht für macOS vorliegen - daran muss man noch arbeiten - bzw. ich muss daran arbeiten. Aber es sind ja noch ein paar Monate hin, bis macOS 10.15 "Catalina" erscheint.

      Schlimmer ist, dass ich fürchte, ich muss mein App in Swift umschreiben bzw. neu schreiben...
    • Hi - ich nutze meine Box nicht außerhalb meines Netzwerkes. Ich brauche keinen Remote-Zugriff, wenn ich nicht daheim bin, dann habe ich besseres zu tun, als TV zu schauen ;) Ansonsten habe ich eine FritzBox.

      Bezüglich macOS Version: es fehlt wir erwähnt die Version von MobileFTPKit und MobileVLCKit gebaut für "UIKitForMac". Das VLCKit für macOS geht da nicht. Da muss Videolan also ein wenig Zeit investieren. Aber ich habe mal eine Version gebastelt, die weder VLCKit noch FTP benutzt - klar, man kann damit noch keine Streams anschauen, ist also recht nutzlos... aber ein Anfang, wenn man bedenkt, dass ich da grad mal 4 Stunden investiert habe und die meiste Zeit musste ich wegen Zertifikaten etc. kämpfen. Anbei ein erster Screenshot...
      Bildschirmfoto 2019-06-06 um 15.52.40.png
    • Hallo,

      könnte hier bitte jemand eine kurze Aufnahem von einem 4K HDR Kanal hochladen?

      Hintergrund ist, dass HDR in der vuplusTV App leider nicht funktioniert und der Entwickler diese Aufnahme benötigen würde.

      Ich habe folgendes getestet:
      - vu+ Uno 4K direkt am TV angeschlossen und auf 4K HDR Kanal geschaltet (z.B. TravelXP 4K): TV erkennt HDR Signal und gibt dieses wieder (schaltet um auf HDR)
      - HDR Material mit diversn Apps wie Netflix, Amazon Video, Infuse, etc. auf Apple TV 4K wiedergegeben: TV erkennt HDR Signal und gibt dieses wieder (schaltet um auf HDR)
      - Mit vuplusTV am Apple TV 4K auf einen 4K HDR Sender geschaltet: TV erkennt kein HDR Signal und gibt das Bild somit viel zu dunkel wieder.

      Ich kann leider momentan selbst keine Aufnahme erstellen, da ich diese Box zur Zeit nicht lokal habe und dort keinen Speicher für Aufnahmen habe.
    • Hallo!
      Danke für das Update bzgl der Picons! Ich dachte schon ich wäre bescheuert.
      Ich habe noch eine Frage:

      Seit längerer Zeit kommt es beim Sender ARD zu konstanten Rucklern. Quasi friert das Bild alle 5 Sekunden kurz ein.
      Dies betrifft allerdings nur ARD. Mich persönlich stört es nicht so sehr, aber bei zwei weiteren Bekannten von mir, tritt dieses Problem auch auf und die schauen i.d.R viel ARD.
      Ist dieses Problem bekannt bzw, hat da jemand einen Fix für?


      Benutzt werden Dreamboxen

      Habe schon die Boxen neu geimaged, vuplus auf dem ATV neu installiert, usw.

      Tritt seit dem letzten Update so verstärkt auf

      Liebe Grüße
    • @ice2man: könnte es sein, dass Sky da was an der Verschlüsselung gedreht hat? Wenn die Wiedergabe noch beim schwarzen Bild abbricht, dann klappt der Zugriff auf den Stream nicht. Die App probiert es ein paar Mal, dann geht sie wieder zur Übersicht zurück.

      Sky im Live-TV geht? Nur Aufnahmen nicht? Kannst du mir mal eine kurze Aufnahme schicken (wie per PM)?

      @Flexx93: prüfe nach, ob das DeInterlacing für ARD HD deaktiviert ist. Als Standard nimmt VLCKit leider auch bei Progressive-Streams den Blend Deinterlacer - obwohl das keinen Sinn macht. Das sollte aber für andere Kanäle mit Progressive-Streams auch zutreffen. Ist das Deinterlacing für ARD HD einmal deaktivert, dann sollte die App sich das merken (der Deinterlacer wird für jeden Kanal gemerkt).
    • Hallo,
      Ich bin nun stolzer Besitzer eine Vu Duo 4K und habe einen aTv im Schlafzimmer. Über die App läuft es soweit auch nur es Stockert recht haufig. Kann man hier noch was einstellen oder an der Box verbessern so das es weniger Stockert ?
      Oder gibt es schon eine andere/ vielleicht auch bessere App ?

      Danke
    • @ali3n7
      Hab sie nun via Devolo angeschlossen. Über wlan war ganz schlimm.
      Sind eigentlich alle ich hab gestern gedacht das sat 1 nicht so schlimm ist wie rtl, aber wurde dann doch was schlimmer.
      Handy App werde ich heute mal schauen und ich beobachte des mal im devolo Cockpit wie die stärke ist.

      Danke
    • Rocker wrote:

      Kann man hier noch was einstellen oder an der Box verbessern so das es weniger Stockert ?
      Oder gibt es schon eine andere/ vielleicht auch bessere App ?
      Find es recht (un)lustig den Entwicklern gegenüber, ihre Arbeit schlecht zu machen.
      Nur weil manche nicht in der Lage sind, ein vernünftig laufendes Heimnerzwerk aufzubauen. ;rolleyes:
      - - - Beitrag wurde mit Deppentalk erstellt. - - -
    • [tvOS] vu+TV App (AppleTV) Support Thread

      WLAN geht bei mir nur mit richtig guter Verbindung, die ich mittlerweile überall im Haus habe.
      Mit Devolo hat das bei mir nie funktioniert, der Durchsatz war immer viel zu schlecht, überall
      Hab überall neue LAN Kabel gezogen, mit WLAN/ LAN Bridges, Repeater, etc. und Ruhe. Läuft absolut perfekt. Einen guten Receiver mit Fullband, aktuell 4 ATV4K, zahlreiche iOS Geräte. Null Probleme.


      Gesendet von iPhone mit Tapatalk
    • Ich danke für eure Unterstützung ;)
      Derzeit ist mein Arbeitszimmer eine Baustelle (alter Boden raus, Wände streichen, neuer Boden... jetzt fehlen noch die Möbel). Daher geht es grad nur schleppend weiter. Zudem waren wir ein paar Tage auf dem FITS (sibfest.ro)...

      Das Problem bei den Netzwerken ist, dass es dabei nicht nur auf die Bandbreite ankommt, sondern auf auch die Latenz. Zudem ist alles außer Ethernet einfach nicht stabil - beide Werte schwanken einfach unkontrollierbar. Da kann es schon reichen, dass ein DECT-Telefon mit rein funkt, sich jemand ein Essen in der Mikrowelle warm macht - es genügt teilweise schon, wenn ein USB-Adapter in der Nähe in Betrieb ist...

      Sonst - ja es geht nur langsam wieter, aber wenn das Arbeitszimmer fertig ist, wird es auch mit der App weitergehen... Die aktuellen Betas laufen noch...
    • Hallo zusammen,

      ich bin seit ein paar Tagen glücklicher Besitzer eines ATV4. Als Receiver dient mir eine VU+ Duo 2 welche direkt bei im Netzwerkschrank steht und per Kabel direkt an den Switch ( 1000Mbit angeschlossen ist ). Das ATV4 steht im Wohnzimmer und ist ebenfalls fest per LAN an den Switch angeschlossen. Die VU+ TV App läuft soweit auch ohne Probleme allerdings habe ich den Eindruck ( meine Freundin ebenfalls ) dass das Bild nicht flüssig läuft. Schwierig zu beschreiben, aber das Bild läuft anders als würde ich per Sat Receiver schauen, gefühlt etwas zu langsam. ( Am Iphone 7 ebenfalls mit VU+ TV App kann ich dieses Phänomen nicht feststellen ). Woran könnte das liegen? Auf dem ATV läuft die Aktuellste TVOS Version, den Trick mit 1080P / 50HZ und 1080P / 60HZ umstellen habe ich schon probiert. Auf der VU läuft aktuell VTI 13.0.9,

      Liegt das evtl am rendern oder ist eine Einstellung falsch? Die APP greift auf Streaming Port 8001 und Openwebif Port 80 zu. Das Phänomen tritt sowohl bei HD als auch SD.

      Frage wäre jetzt kann ich das umstellen / prüfen ohne TV? Sonst müsste ich alles in der Garage abbauen und ins Wohnzimmer verfrachten da ja da der TV steht.

      Grüße,
      Daniel
    • [tvOS] vu+TV App (AppleTV) Support Thread

      Ich empfehle die in den Apple TV Einstellungen die Bildwiederholfrequenz auf 50Hz zu stellen, statt 60 Hz.

      Des weiteren in den Settings der vuplustv-App für jeden HD-Sender, welcher mit 25 Hz Bildwiederholfrequenz sendet den Deinterlacer auf Bob stellen.

      Dann nix ruckeln.


      Gesendet von iPhone mit Tapatalk
      99% aller Fehler sind Bedienungsfehler!
      Geht nicht-Gibt`s nicht!
    • optimal, das hat Besserung gebracht alles läuft flüssig ;) Vielen Dank. Kann man der App das fest einstellen das ich nicht nach jedem Senderumschalten wieder per Hand auf BOB stellen muss? Und mir ist noch etwas aufgefallen, mein TV zeigt nicht den kompletten Bildbereich an... Unten rechts ist ja normal die Uhr, da kann ich nur die Stunden sehen, der rest ist abgeschnitten. Am Tv habe ich mal geschaut, da ist das Bild mittig kalibriert....