[tvOS] vu+TV App (AppleTV) Support Thread

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Moin!

      Ich möchte mich auch mal einhängen und fragen, warum bei mir eines der Bouquets mit (0) angezeigt wird?

      Ich habe vier Bouquets, Normale Sender, Sport, UHD und Kidz.
      Der erstere wird mit o sendern angezeigt, die anderen korrekt.

      Auf anderen Streaminggeräten (eine VU+Zero und ein FireTV Stick mit DreamPlayer Pro) funktioniert es problemlos.


      Danke!
    • Erst mal sorry, dass ich solange nicht mehr hier kommentiert habe.
      Bei Apple plagt ein kleiner bug mit der remote app auf der Apple Watch und in VLCKit habe ich auch noch einem Bug hinterher gejagt.
      Wegen der fehlenden, leeren oder unvollständigen Bouquets...
      Ich habe ein kleines Python Skript gebaut. Wenn ihr am Computer Python 2.7 installiert habt, könntet ihr das nutzen. Es war dafür gedacht, Probleme bei der Wiedergab eines Streams bei Videolan analysieren zu lassen, wobei die Box keine Platte hat. Also konnte keine Aufnahme gemacht werden.
      Das Python Skript muss von der Kommandozeile gestartet werden also unter Windows in der cmd.exe, bei Mac und Linux in der bash. Man muss da einige Parameter angeben (IP, Port, Username, Passwort, etc.) dann werden von der Box die Bouquets mit ihren Sendern geladen und angezeigt. Man kann auch den nAmen eines Sender angeben, dann wird der Stream auf die Platte gedumpt.
      In eurem Fall sollte das Skript zumindest die Sender anzeigen.

      Unter Windows konnte ich das noch nicht probieren, dort ist es ungetestet.

      Ansonsten brauche ich das JSON, das mir die API liefert, dann kann ich da nachsehen. Vielleicht stimmt was mit den Service-Referenzen nicht. Das kann ich so nicht sagen.

      Die kommenden Tage wird es wieder ruhiger bei mir, Urlaub über Ostern... da möchte ich wieder ein wenig Zeit in die App investieren...

      TestFlight ist derzeit beendet. Du kannst die Version aus dem Store nehmen, diese entspricht der letzten Version von TestFlight. Neue TestßVersionen kommen demnächst.

      The post was edited 1 time, last by jabbela ().

    • [tvOS] vu+TV App (AppleTV) Support Thread

      Moin!
      Nein, Bouquet heißt "Normale Sender".
      Da drin sind 28 Sender von Das Erste bis Sky.

      Mit remotechannelstreamconverter auf der anderen VU funktioniert es.

      Grüße


      Gesendet von iPhone mit Tapatalk
    • @ChocoRolls und geantwortet...
      Scheint dass die Antwort von der Box im JSON in der Referenz nach jedem Doppelpunkt ein Leerzeichen anfügt, welches dort nicht hingehört. Da wundert es mich allerdings, dass es auf dem iPhone läuft. tvOS und iOS werden im Backend aus dem gleichen Source kompiliert.

      @Itzak DIe App verwendet folgende URLs für die Abfrage von Bouquets und Sendern:

      /api/about (Info laden)
      /api/bouquets (Liste der Bouquets laden)
      /api/getservices?sRef=1:7:1:0:0:0:0:0:0:0:FROM BOUQUET "userbouquet.favourites.tv" ORDER BY bouquet (Sender in Bouquet „user bouquet.favorites.tv“ laden - der String muss für deine Box-Config angepasst werden.
      /api/epgnownext?bRef=1:7:1:0:0:0:0:0:0:0:FROM BOUQUET "userbouquet.favourites.tv" ORDER BY bouquet (EPG-Info analog zum vorherigen Aufruf)

      /api/getlocations (für die Aufnahme-Verzeichnisse)
      /api/movielist (Aufnahmen im Default-Verzeichnis)

      Vor /api/ musst du im Browser noch http://<meineip>:<meinport> davor eingeben. Als Ergebnis solltest du eine Antwort im JSON-Format erhalten. Schicke mir diese bitte per PN zu - dann kann ich diese analysieren. Probiere bitte auch einmal die "langsame" API, die verwendet XML anstelle von JSON.
    • jabbela wrote:

      @ChocoRolls und geantwortet...
      Scheint dass die Antwort von der Box im JSON in der Referenz nach jedem Doppelpunkt ein Leerzeichen anfügt, welches dort nicht hingehört. Da wundert es mich allerdings, dass es auf dem iPhone läuft. tvOS und iOS werden im Backend aus dem gleichen Source kompiliert.
      Hihi,

      das prüfe ich nachher nochmal. Ich habe die Antwort zur besseren Lesbarkeit automatisch formatieren lassen. Kann sein, dass die Leerzeichen dadurch kommen. Wenn ich heute Abend wieder Zugriff auf die Box habe, kann ich den raw output vom json.dumps nochmal schicken.

      Ich hatte ja auch noch die Entwickler Debug Logs im AppleTV aktiviert. Hast du da evtl was bekommen, mit dem mehr anzufangen ist?
    • Hallo. Mir werden keine Sender Logos angezeigt. Jemand eine Idee woran das liegen kann und wie ich das beheben kann. Der piconmanager ist installiert und ich haben auch ein Sender Logo Paket geladen.
    • Hi, ja das Thema kam schon öfter. Das geht nur wenn ein bestimmtes Update auf der Box installiert wird. Habe des Öfteren nach diesem Update gefragt, aber niemand konnte mir sagen wo man es laden kann... man soll warten bis es automatisch kommt. Das passiert aber nicht, da andere es ja schon seit Monaten drauf haben.

      The post was edited 1 time, last by hgdo: unnötiges Komplettzitat entfernt ().

    • [tvOS] vu+TV App (AppleTV) Support Thread

      Hä? Alle Updates werden über die Updatefunktion geladen. Blau grün blau grün.

      Den richtigen Speicherort ausgewählt, wo der PiconManager die Dateien ablegt (gleich dem, wo der Skin sie her nimmt)?




      Gesendet von iPhone mit Tapatalk
    • Hey mario,

      du brauchst eine Version von OpenWebIF, die die Bereitstellung der Picons unterstützt. Welches genaue Minor Release das ist, kann ich nicht sagen. in OpenATV 6.3 ist es drin.
    • Ich habe gerade durch Zufall etwas entdeckt. Ich bin mal in das Buque ip TV gegangen und dort waren tatsächlich drei Sender Logos zu sehen. Das bedeutet es ist theoretisch möglich!
      Bei den gleichen Sendern im normal Programm wird nicht ein einziges Logo angezeigt. Wie kann das sein? Es ist ja ein Paket was ich heruntergeladen hab. Wenn müsste doch dann für einen Sender immer das Logo angezeigt werden, egal ob ip oder normales tv Programm ‍♂️?
    • [tvOS] vu+TV App (AppleTV) Support Thread

      Das mit dem OpenWebIf brauchst du nur wenn du die Picons nach Name auf der Box hast. Wenn du sie nach Sender ID hast sollte das einfach gehen. Ich hab immer das aktuelle VTi drauf, geht seit Anfang an problemlos


      Gesendet von iPhone mit Tapatalk
    • Hallo zusammen!
      Nachdem ich einige Tage im Urlaub war und davor vieles zu erledigen hatte, blieb mir heute am "Tag der Arbeit" die Zeit mich mal wieder der App zu widmen.
      Ab OpenWebIF Version 1.2.5 ist die von mir bei den Entwicklern von OWIF angefragte Erweiterung drin, dass beim Laden der Service-Infos auch der Name des PICons übermittelt wird. Bei älteren Versionen, kommt diese Info nicht. Dann muss die App "raten" wie die PIcons heißen. Dazu wird die "by Reference" Methode benutzt.
      Ich würde auch andere Namensgebungen versuchen, im Source-Code von OWIF kann man ja die diversen Möglichkeiten herauslesen und all diese Varianten ausprobieren. Das Problem ist, dass ich jeden Versuch via Web-Abruf von der Box asynchron ausführen muss. Angenommen man hat 100 Sender, die vierte der Namensvarianten wird benutzt - dann muss ich 400 Anfragen an die Box schicken, die Antworten auswerten bis ich alle PIcons habe. Da alles asynchron läuft ergibt das zum einen eine recht komplexe State-Machine - zum anderen ist damit der Twisted-Server auf der Box schnell am Rande seiner Möglichkeiten. Ich hatte es mit meinen Anfragen bei Experimenten (andere Baustelle) schon geschafft, meine Solo2 komplett zu blockieren. Der Stream lief noch, aber die Box hat nicht mehr auf die Fernbedienung reagiert. Daher muss man mit Abfragen sparsam sein.
      Die einzige Lösung wäre, wenn ich direkt auf das Dateisystem zugreifen könnte - aber das kann ich nicht und will ich nicht. Aber OWIF kann das - und dazu konnte ich die Entwickler überreden - weil es auch die Anzahl der Anfragen an den OWIF Server reduziert. Da läuft eben kein Apache Server mit massig Ressourcen für seine Arbeit.

      Ich habe aber ein paar kleine Wünsche umgesetzt, zum Beispiel, dass die Bouquet-Titel farblich hinterlegt sind, wenn sie ausgewählt sind - sonst konnte man das schlecht erkennen. Ich habe auch neben den Deinterlacern noch drei Buttons ins odere HUD eingefügt, mit dem man das Video-Seitenverhältnis manuell ändern kann. Allerdings klappt das noch nicht so perfekt. Ein Bug-Report bei Videolan ist da noch offen. Das Problem ist: man schaut sich eine alte TV-Serie an, die in 4:3 ausgestrahlt wird, was klappt. Kommt dann eine Format-Änderung zu 16:9 (Werbeblock, anderer Film), dann wird die Darstellung nicht angepasst. Passiert regelmäßig zum Beispiel bei Tele5 am Vorabend bei StarTrek-Serien.
      Die Option habe ich aber hinzugefügt, weil ein User aus Asien das Problem hat, dass sein Provider Streams schickt, die immer als 4:3 angegeben sind, obwohl sie 16:9 wären - so kann er das manuell anpassen.

      Sonst gibt es ein neueres VLCKit und das Debug-Log enthält jetzt auch Meldungen von VLCKit, gut wenn es Probleme bei der Wiedergabe von Streams gibt.Ein paar kleinere Bugfixes sind auch drin. Im aktuellen Build 98 von Version 1.5.1 für tvOS ist auch manuell noch ein intensives Logging drin, um die Probleme von @ChocoRollsin den Griff zu kriegen - das ist sehr seltsam, da es auf iOS läuft, nur auf tvOS nicht - der größte Teil des Codes ist aber identisch. Anders konnten wir noch keine Ursache für sein Problem entdecken.

      Die Version ist grad bei Apple im Review (1.Beta einer neuen Version braucht immer ein wenig länger), dann geht sie an die Tester raus. Ein paar Tester habe ich entfernt, die zuletzt Version 1.1 über TestFlight getestet haben...
    • Vielen Dank für deinen Einsatz und deine Antwort. Da es bei mir ja wie beschrieben theoretisch möglich ist die Logos angezeigt zu bekommen, wäre es super wenn du kurz beschreiben könntest wie genau die logos beschriftet sein müssen und wo sie in welchem Ordner sein sollten.

      Danke
    • Der Ordner wird von OWIF automatisch auf die URL <box>/picon/ übertragen. Du kannst auch das Verzeichnis im Browser so aufrufen.
      Sie müssen "by Reference" benannt sein. Die Referenz ist ein längerer String wie zum Beispiel "1:0:19:283D:3FB:1:C00000:0:0:0:" für Das Erste HD via Astra. Für den PIcon-Namen werden die ":" durch "_" ersetzt und das letzte ":" weg gelassen. Als Endung wird ".png" verwendet.

      Wie erwähnt - mit OWIF 1.2.5 hat das ein Ende, weil ich die Namen der PIcons von OWIF bekomme.
    • Es hatte mich jemand angeschrieben wegen TestFlight - leider landete die Nachricht im Spam und war weg, bevor ich erkennen konnte von wem es kam... sorry. Bitte noch einmal probieren ;)
    • Hallo jabbela,

      erstmal eine Tolle App!!! Hut ab ich freue mich immer wenn Ich sie auf meinem AppleTV nutze.
      Nun zu meinem Problem:

      Ich habe eine Solo4K im gleichen Netz und TV geht auch sehr gut, jedoch bei den Aufnahmen stürzt die APP sofort ab, wenn es Unterordner gibt
      und dort z.B. die Serien seperat gespeichert werden.

      Kennst Du das verhalten?

      Ich habe aktuell 3 Lesezeichen und nur eine geht....

      Gerne schicke ich auch Logs, wenn Du mir sagst welche und wo sie sind.

      Merci
    • Das die App abstürzt kenne ich nicht.
      Nur das Problem, dass manche Unterverzeichnisse nicht in der App erscheinen - wenn sie nämlich nicht vi OWIF oder der Box selbst angelegt wurden sondern zB per FTP. Ich bin gerade dabei dafür eine Lösung zu finden: werden Unterordner gefunden, die noch nicht in den Locations drin stehen, werden diese "offiziell" eingetragen - ich weiß aber noch nicht was passiert, wenn der Ordner wieder gelöscht wird - da muss ich noch experimentieren...