[tvOS] vu+TV App (AppleTV) Support Thread

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • @laric: refactoring complete - testing can start. Well, it makes not much sense to do the radio playback on a blank black screen, just showing the PIcon. But it is a start.

      Also - es geht los mit Version 1.3 via TestFlight.

      Ich habe die Abfragen für die Bouquets und Services umgebaut. Anstatt erst eine Liste der Bouquets abzufragen, dann jeweils die Services innerhalb des Bouquets rufe ich jetzt "getallservices" auf - damit bekomme ich alle Bouquets mit allen Services mit einer einzigen Abfrage. Nebenbei kann ich so auch die Radio-Services abfragen. Der "Radio"-Tab ist damit bislang das sichtbare neue Feature. Das eine oder andere Feature wird aber noch dazu kommen.
      Kandidaten sind derzeit noch:
      - Sleep-Timer (Wiedergabe nach 3 Stunden beenden)
      - Anzeige der aktuellen Uhrzeit

      Das große Full-EPG Projekt wird aber vermutlich noch ein wenig warten müssen.

      Nun heißt es aber erst einmal darauf zu warten, dass Apple die beta-App Prüfung durchführt...

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von jabbela ()

    • Sleeptimer kommt mir im Schlafzimmer sehr gelegen ;)

      Bei mir stimmt die EPG Sachen übrigens nicht. Ich muss die App immer erst richtig schließen (mit wischen), dass die aktuellen EPG Infos geladen werden. Sonst stehen immer die vom letzten mal öffen drin.
    • Hm, muss ich mich wohl doch mit dem Redmine befassen... *grummel*

      Habe den Link aus einer Deiner ersten Mails dazu geklickt -> Redmine
      Danach oben rechts erstmal registriert und diese Registrierung dann auch bestätigt.
      Klicke ich nun wieder (mit meinem Login) auf den Link Redmine so kommt dies:

      403 - Sie sind nicht berechtigt, auf diese Seite zuzugreifen.

      Was mache ich falsch? Oder muss ich erst separat freigeschalten werden?
      Freundliche Grüße


      Daniel
    • Eigentlich sollte das nicht so sein. Ich habe dich aber eben der Gruppe vuplusTV Tester hinzugefügt, damit sollte das auf jeden Fall jetzt gehen.
      Eventuell muss ich an den Einstellungen für das Projekt noch etwas ändern und es öffentlich machen.
    • How do I get access to the beta versions so I can start testing? And the guy I am helping will be happy to have it on a black screen as he pulls out the sound to his stereo :) He used to do this with his old SlingBox and was really missing his radio stations after I switched him to a VU+ Duo/Apple TV combo
    • Hi,

      thanks for testing so far and... yes... there is a bug with radio bouquets.
      It uses te same variable in the preference file like tv bouquets for saving, which bouquet is opened. So when your 2nd tv bouquet is opened (expanded) in bouquet view but you only have one radio bouquet, this will potentially crash. I will fix this in the next build.
      Till then, go to the tv bouquets view and open the first bouquet, then you should be able to switch to the radio view.

      Anyway, make sure to have crash log sharing enabled, so I can see the crash in Xcode, just in case it has a different cause.

      Sorry... but it is a beta and i found the issue myself after submitting the build to review. I did not prepare a new build to avoid additional delays with the review.
      Also I strongly recommend to use the redmine server for bug reports. It is easier to track issues and requests there.
    • Hallo jabbela,

      ich habe soeben auf 1.2 upgedatet, da die APP nach einem Neustart von ATV immer auf eine falsche IP gezeogt hat und gar nichts mehr ging.
      Jetzt klappt das auch wieder vielen Dank.

      Nun habe ich aber ein anderes Problem. Wenn ich "Audio-Pass-Through" auf off lasse (wie in der alten Version) höre ich gar keinen Ton mehr, nur den Klick Ton. Sobald ich "Audio-Pass-Through" aktiviere geht der Ton aber beim umschalten oder "swip down" kommt ein Knacksender Ton.


      Habe schon ein paar ähnliche Beträge darüber hier gelesen. Gerne biete ich mich auch als Tester an wenn es Dir hilft.


      Bin sehr erfreut über deine APP. Thumps UP!!!!


      Merci

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Bierbauch82 () aus folgendem Grund: Falsche Version

    • build 38 (Version 1.3) ist via TestFlight verfügbar.

      Wegen dem Audio-Problem... das liegt daran, dass VLCKit mit tvOS kollidiert. Wenn du die Navigation-Sounds deaktivierst sollte es besser sein. Aber da muss ich noch einiges machen, insbesondere wegen Multi-Channel Audio, aber mir fehlt (noch) das Equipment (Dolby-Receiver mit HDMI-Eingang) um das testen zu können. Die letzten Versuche waren ja leider nicht erfolgreich.

      Dass bei deaktiviertem Audio-Passthrough kein Ton mehr ankommt, sollte aber nicht der Fall sein. Bei mir klappt es.

      Wegen beta test, bitte registriere dich auf dem Redmine server und schicke mir per pm deine AppleID, dann kann ich dich bei Apple eintragen. Du wirst dann per Mail über neue builds informiert und kannst diese dann mit TestFlight installieren.
    • Hallo Jabbela,


      ich würde sehr gerne am Betatest teilnehmen. Als intensiver Nutzer der Radio Kanäle die bei den Klassik Sendern mehr und mehr 5.1 Musik senden kann ich es kaum erwarten Radio über die Apple TV zu hören.


      Die App habe ich erst heute entdeckt und bin von der aktuellen Version im Apple Store schon sehr begeistert. Ich verwende sie mit einer Dreambox dm500hd.
      Eine Frage traue ich mich hier zu stellen da ich über die Suche noch nicht fündig wurde. Was muss ich machen dass die Sender Logos in den Listen erscheinen?


      Danke und Gruß
      Christoph
    • hallo @Christoph-dm500hd,

      um am beta teilzunehmen, brauche ich deine appleid per PM. Zudem solltest du einen account auf meinem redmine server einrichten, wegen bug reports etc. Man muss nur ein wenig geduld mit dem redmine (link ist weiter oben) haben, der läuft derzeit auf einem alten RasPi.

      Radio-Implementierung ist derzeit noch nicht perfekt, weil bei Wiedergabe noch ein leerer Screen (nur das PIcon in dermitte) angezeigt wird, ist der Anfang. Wichtig war, den Code-Unterbau so zu überarbeiten, dass ich die Radio-Sender überhaupt abfragen kann.

      Mit den Sender-Logos oder PIcons, die musst du auf deiner Box installieren. Dann sollten die angezeigt werden, die du auch im OpenWebIF siehst. Naja, und die PIcons werden auf das AppleTV geladen, da muss dann ein wenig freier Speicher verfügbar sein.
    • Hallo Jabbela,

      vielen Dank für die schnelle Reaktion+
      den Redmine account habe ich mit dem gleichen Nutzernamen angelegt. PM folgt.

      Die Picons sind auf meiner dreambox im Verzeichnis usr/share/enigma2/picon und werden vom Gemini HD skin problemlos angezeigt. In der VUplus app fehlen sie.
      Müssen die Picons in einem anderen Verzeichnis liegen?

      Danke und Gruß
      Christoph
    • Die Testeinladung müsste gerade bei dir eingetroffen sein.

      Das mit den PIcons sollte eigentlich kein Problem sein.
      Lass dir die Bild-Datei mal im Browser anzeigen. Da müsste dann ein Pfad wie http://<IPderBox>/picon/<xxx>.png

      Das <xxx> entsteht aus der Service-Referenz indem man die ":" durch "_" ersetzt.

      Wenn das bei deiner Box so passt, dann könnte es zwei Ursachen haben:
      1. es ist nicht mehr genug Platz im Flash-Speicher deines AppleTV, dann kann die Datei nicht in der App Cache gespeichert werden
      2. Das EPG-Parsing wird wegen XML-Fehler abgebrochen, was manchmal entsteht, weil manche Sender ihre EPG-Infos mit Zeichen füllen, die im XML nicht erlaubt sind. Bei BibelTV habe ich zum Beispiel das Zeichen 0x05 entdeckt, ein Steuerzeichen, das in XML nicht erlaubt ist. Wahrscheinlich schreiben die das mit Word ;) OpenWebIF filtert die nicht raus, also muss ich das machen (neu in Version 1.3) und das ist noch nicht vollständig.

      Versuche mal auf deinem AppleTV Platz zu schaffen, wenn der Speicher knapp ist. Wenn es dann nicht geht, dann wird es ein XML Fehler im EPG sein.
      Dann müsste ich an das XML heran kommen oder in 1.3 eine "Debug" Funktion einbauen, die den Parserfehler anzeigt oder die fehlerhafte XML-Datei zuschickt/hochlädt.
    • Build 39 ist raus.

      • ich habe den Filter für illegale XML-Zeichen verbessert (BibelTV nimmt wohl Word um ihre EPG-Infos zu schreiben, das Ergebnis enthält auf jeden Fall Zeichen, die in XML nicht zulässig sind und dadurch wurde das Parsen der EPGInfo abgebrochen)
      • EPG-Refresh Schedule gefixt, der wurde versehentlich gelöscht, wenn man sich einen Stream angesehen hat.
      • Schriftgröße für die Uhr vergrößert
      • das TopShelf ignoriert jetzt EPG-Daten, die es nicht braucht, das spart Arbeitsspeicher
      • optionales Debug Logging


      Mehr Info auf meinem Redmine Server.

      Viel Spaß!!