[tvOS] vu+TV App (AppleTV) Support Thread

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Testergebnisse

      So, hier nun meine ersten Testergebnisse:

      Konfiguration:
      - Denkbar einfach

      Bedienung:
      -Simple und schlank gehalten

      Stabilität/Performance:
      - App beendet sich manchmal ohne erkennbaren Grund und springt auf den Home-Screen zurück. Dabei merkt das aber meine VU+ (anders ist da ja manchmal bei den Streamingapps auf den iPads, die wenn Sie abbrechen aus irgendeinem Grund noch einen Tuner auf der VU+ belegen - das sieht man wenn noch das REC in der Infoleiste blinckt)
      - manchmal bei Beginn des Streams für einige Sekunden grün
      - Bild und Stimme synchron

      Wünsche:
      Ich nutze einige Bouquets gerade für die Kategorisierung und Übersichtlichkeit - genau das funktioniert so leider nicht, da ich keine Möglichkeit gefunden habe direkt in andere Bouquets zu springen. Ein Ein- und Ausklappen oder durch "Druck an der richtigen Stelle" zum Wechsel würde ich toll finden

      Test Equipment:
      - Solo2
      - Fritz 7490
      - alles Per Wlan

      Fazit:
      Respect - good Job !!!! Ich kanns gebarauchen ... bissle Stabilität und Buquetwechsel... dann ist das ne Mega-Kombi mit gut einsetzbaren Szenarien in meinem Haushalt!
      Klasse!

      LG xoom222
      Stille Wasser sind auch nass :-)

      1 x Vu+ Duo
      1 x Uno
      1 x Ultimo
      1 x Solo2 WE
      Samsung PS50C6500, Sony KDL-60w855, HTL9100/12, Synology DS411Slim, Ds414Slim
      Poppstar MS35
    • Ergänzungen:

      EPG:
      - wird sauber ausgelesen


      Movie:
      - Aufnahmen der Solo2 HDD können ohne Probleme abgespielt werden
      Habe auf meiner HDD auch noch Verknüpfungen/Symlinks auf meinen Filer, diese werden allerdings nicht angezeigt :(
      Stille Wasser sind auch nass :-)

      1 x Vu+ Duo
      1 x Uno
      1 x Ultimo
      1 x Solo2 WE
      Samsung PS50C6500, Sony KDL-60w855, HTL9100/12, Synology DS411Slim, Ds414Slim
      Poppstar MS35

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von xoom222 ()

    • Rails schrieb:

      Fehler:
      - Wenn im Dateinamen ein "+" vorhanden ist, so wird die Aufnahme nicht gestartet. Entfernt man das "+" funktioniert es.


      Das habe ich mir noch mal überlegt. Das liegt wohl darin, dass ich den Pfad vom OpenWebIF in ohne Encodierung bekomme, ich due URL aber mit URL-Encoding absetzen muss.
      Offensichtlich wird dabei das "+" durch die Funktion von NSString nicht richtig codiert, und das liegt vermutlich daran, dass ein + oder auch ein ? in einer URL(vor allem bei GET Zugriffen) vorkommen darf und wohl nicht konvertiert wird.

      Ich schau mir das mal bei Gelegenheit an.

      Ansonsten - ich war ein paar Tage mit einer anderen App beschäftigt, hatte ich schon erwähnt. Daher war ich auch nicht mehr hier online um mein Postfach zu lesen.
      Aber an die eingehenden Beta-Anfragen sind jetzt die Einladungen heraus gegangen.

      Derzeit bastle ich an dem Auf/Zuklappen der Bouquet-Liste ;)

      Dann wäre wohl eine 2.Beta fällig...
    • xoom222 schrieb:

      Habe auf meiner HDD auch noch Verknüpfungen/Symlinks auf meinen Filer, diese werden allerdings nicht angezeigt :(


      Wird der Inhalt der Symlinks im OpenWebIF angezeigt?

      Versuche mal im Browser: http://<IPAdresse>/web/movielist
      Dann bekommst du eine XML-Datei als Antwort.

      Wenn die Symlinks (bzw. der Inhalt) dort nicht angezeigt wird, dann liegt es am OpenWebIF, nicht an meiner App - diese kann nur die Daten anzeigen, die es bekommt. Kann sein, dass der WebServer vom OpenWebIF Symlinks nicht folgt.
    • So super vielen Dank, habe die Einladung bekommen und schon installiert.

      Funktioniert schon mal super !
      Viel angenehmer als mit dem Kodi Clone ....

      Einpaar Verbesserungsmöglichkeiten habe ich noch (ist aber Luxus):
      - Das Bouquet Menü auch während des Live Streams von oben nach unten ziehbar machen (ohne das ich den Menubutten klicken muss)
      - Wenn Das Bouquet Menü offen ist, den Stream im Hintergrund weiter laufen lassen (ev. sogar leicht transparent oder in einem Ecken so wie auf der vu selber bei einigen Skins)
      - Mehrere Vu (Server) konfigurierbar machen, zumindest so, dass ich die Möglichkeit habe zu switchen zwischen den IP Adressen

      Wirklich Top Deine Arbeit, vielen Dank !!!

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von swissglider ()

    • Bei mir verbindet er mit der Vu+ duo2 deren Openwebif auf 81 steht nur wenn ich die IP:port angebe. Nicht selbsterklärend weil es so aussieht als würde das app den Port selbst erkennen. Danach kurze Mitteilung Fehler bei Verbinden und jetzt hängt er im "loading..." seit 5 Minuten.

      Habe das App nochmal deinstalliert und installiert, er findet die Duo2 mit ip:port aber sobald ich save und auf Movies gehe "Error Connection to STB failed". Jetzt komme ich gar nicht bis zum "loading..." screen. IdreamX funktioniert am Mac im selben Netzwerk mit den gleichen Einstellungen problemlos.

      Edit OK habe weiter oben gelesen, Portangabe geht noch nicht. Auf 80 kann ich es leider nicht testen. Der Port geht auch mit IDreamX nicht. Ich glaube da hängt sich die Starface Anlage ein.

      Kommt eine neue Version mit Port auf Tesflight?

      Dieser Beitrag wurde bereits 6 mal editiert, zuletzt von Drpiety ()

    • swissglider schrieb:

      So super vielen Dank, habe die Einladung bekommen und schon installiert.
      Einpaar Verbesserungsmöglichkeiten habe ich noch (ist aber Luxus):
      - Das Bouquet Menü auch während des Live Streams von oben nach unten ziehbar machen (ohne das ich den Menubutten klicken muss)
      - Wenn Das Bouquet Menü offen ist, den Stream im Hintergrund weiter laufen lassen (ev. sogar leicht transparent oder in einem Ecken so wie auf der vu selber bei einigen Skins)


      Gute Idee - das wäre auch eine Lösung für den ZAP-Mode. Es ist sehr angenehm, wenn man ein Bild hat, während man umschaltet. Macht die VU+ ja auch nicht anders.
    • Ich sehe auch kein Feld für die Portnummer. Bei mir ist Port 80 so weg dass selbst wenn ich Port 80 in Webif eintrage nur unter Port 81 mit IdreamX verbinden kann. Dürfte gar nicht gehen, tut es aber.
    • @jabbela
      xml wir angezeigt
      Stille Wasser sind auch nass :-)

      1 x Vu+ Duo
      1 x Uno
      1 x Ultimo
      1 x Solo2 WE
      Samsung PS50C6500, Sony KDL-60w855, HTL9100/12, Synology DS411Slim, Ds414Slim
      Poppstar MS35
    • Hi,

      ich habe die App nun mal länger getestet, und immer ca. nach 7 Minuten stürzt die App ab.
      Habe die App dann teilweise einfach wieder gestartet, teilweise zuerst total geschlossen, und habe auch die Box neu gestartet.
      Immer wieder stürzt sie leider ab.

      Ich habe eine Vu+ Duo2 alles über Ethernet Kabel - Kanal ist HD über Kabel.

      Wenn Du mir sagst, wo ich die Log Files oder so finde, kann ich diese Dir gerne zusenden.

      Grüss
      swissglider
    • Also das Eingabefeld für die Portnummer kommt in der nächsten Beta.
      @xoom222: also sind die Filme vom Filer im XML enthalten?
      Kannst du mir das XML mal schicken?

      Ansonsten - das mit dem auf und zuklappen der Bouquets ist leider schwieriger als erwartet. Ichhabe ein Sample von Apple für tvOS umgebaut, und das stürzt immer ab. Daher muss ich das verschieben. Ich hab da schon einen Tag investiert und konnte es dann doch nicht einbauen.

      Ansonsten habe ich eine neuere Version von libVLC eingebunden und mute den Ton, wenn man mit 1.5 oder schneller bei Filmen vorspult. Irgendwie ist das so auch performanter, so dass ich auch noch 6.0x eingebaut habe, aber ich kann nicht dafür garantieren, dass das immer klappt. Manchmal blieb der (SD-) Stream dann nach ca. 5-6 Minuten hängen.

      Das mit dem Bouquet-View herunterziehen wird nicht klappen, weil ich den Movie-Player bewusst (performance) als modales Fenster eingebaut habe. Aber mir ist da eine andere Möglichkeit eingefallen. Vorschau des anderen Streams dürfte daran scheitern, dass dann unter Umständen kein Tuner frei ist.

      Ein paar Kleinigkeiten baue ich vielleicht noch ein, dann möchte ich bis zum Wochenende die nächste Beta einstellen ;)
    • swissglider schrieb:

      Hi,

      ich habe die App nun mal länger getestet, und immer ca. nach 7 Minuten stürzt die App ab.
      Habe die App dann teilweise einfach wieder gestartet, teilweise zuerst total geschlossen, und habe auch die Box neu gestartet.
      Immer wieder stürzt sie leider ab.

      Ich habe eine Vu+ Duo2 alles über Ethernet Kabel - Kanal ist HD über Kabel.

      Wenn Du mir sagst, wo ich die Log Files oder so finde, kann ich diese Dir gerne zusenden.

      Grüss
      swissglider


      Wenn du in TestFlight bzw. in den Settings zugelassen hast, dass CrashReports and Entwickler geschickt werden, dann sollte ich sie eigentlich bekommen können. In itunesconnect habe ich sie aber noch nicht gefunden.
      Ansonsten kannst du mit Xcode und Mac die Logfiles öffnen (Devices-Fenster) und mir schicken.

      Wäre schon interessant, warum die App bei dir abstürzt.
    • Hallo zusammen.

      Heute bin ich mal dazu gekommen eine HD-Aufnahme zu schauen. :)
      Da diese mit massig Werbung kam, musste doch öfter gespult werden. Das geht leider nicht so gut. Bei max. 3-facher Geschwindigkeit blieb der Stream direkt hängen. Vielleicht könnte man, ähnlich wie im Movieplayer, Knöpfe einbauen die einfach ein paar Sekunden oder sogar Minuten vorhüpfen? So ein Werbeblock geht ja fast immer gute 8-10 Minuten.

      Die Box und auch das AppleTV sind beide per Kabel im Netzwerk und hängen sogar am selben Switch.
    • Das sind vermutlich die Einschränkungen des HTTP-Streamens.

      Das Vorspulen geht nur begrenzt und springen geht gar nicht. Das ließe sich nur umgehen, wenn man Dateizugriff vie FTP oder SMB hat. Aber selbst da ist die Verbindung zwischen den beiden Geräte auch eine Flaschenhals.
      Aber der Schwerpunkt der App liegt auch eher beim Live-TV, da kann man eh nicht vorhüpfen.

      Immerhin habe ich eine nicht ganz so elegante Lösung für das Bouquet-Problem gefunden - aber diese scheint zu funktionieren. Man bekommt erst Mal eine Tabelle mit den Bouquets. Wenn man da eine auswählt, kommen die Sender im Bouquet. Mit Swipe-Left, Tap-Left oder Menu kommt man wieder in die Bouquet-Überischt. Die App merkt sich auch das zuletzt gewählte Bouquet wird dieses (über die Nummer) automatisch wieder öffnen.

      Je nachdem,wie ich Zeit habe, werde ich dann die nächste Beta in ein paar Tagen einreichen. Da war noch ein Fehler in der libVLC, mal schauen, ob ich den noch fixen (lassen) kann.
    • So nach ein paar Tagen gelegentlicher Tests muss ich sagen, dass die App bei mir Stabil läuft. Habe aber bisher nur Live TV getestet und da gibt es keine Probleme.
      Mit Aufnahmen schauen habe ich mich noch nicht befasst, werde ich in den nächsten Tage mal testen .
    • jabbela schrieb:

      swissglider schrieb:

      Hi,

      ich habe die App nun mal länger getestet, und immer ca. nach 7 Minuten stürzt die App ab.
      Habe die App dann teilweise einfach wieder gestartet, teilweise zuerst total geschlossen, und habe auch die Box neu gestartet.
      Immer wieder stürzt sie leider ab.

      Ich habe eine Vu+ Duo2 alles über Ethernet Kabel - Kanal ist HD über Kabel.

      Wenn Du mir sagst, wo ich die Log Files oder so finde, kann ich diese Dir gerne zusenden.

      Grüss
      swissglider


      Wenn du in TestFlight bzw. in den Settings zugelassen hast, dass CrashReports and Entwickler geschickt werden, dann sollte ich sie eigentlich bekommen können. In itunesconnect habe ich sie aber noch nicht gefunden.
      Ansonsten kannst du mit Xcode und Mac die Logfiles öffnen (Devices-Fenster) und mir schicken.

      Wäre schon interessant, warum die App bei dir abstürzt.
      Ich habe dies nun in den Einstellungen in den Einstellung der ATV so eingestellt, dass die Diagnosedaten nun für App-Entwickler frei gegeben werden.
      Hoffe Du bekommst diese nun
    • Also bei mir ist es auch so wie bei @swissglider
      Manchmal läuft die App auch etwas Länger ohne jetzt die Zeit gestoppt zu haben aber ich glaube es waren dann auch mal ca.20 min.
      Ich habe noch ein weiteres Problem, meine aufnahmen werden nicht eingelesen, über denn Status "Loading..." komme ich nicht hinaus, wenn ich in dann das Trackpad drücke stürzt die App sofort ab.