iFlatFHD Anpassungen / modifications (colors, fonts, skinparts)

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Meine Infobar mit Verlauf-Hintergrund ist so gut wie fertig. Nur eine Sache klappt noch nicht:
      z.B. die Uhrzeit wird korrekt dargestellt: transparenter Hintergrund - man sieht den Farbverlauf der dahinter liegenden png.

      Source Code

      1. <widget source="session.Event_Now" render="Label" position="1575,910" size="90,30" font="Regular; 27" halign="left" foregroundColor="foreground" backgroundColor="background" transparent="1" zPosition="2">
      2. <convert type="EventTime">StartTime</convert>
      3. <convert type="ClockToText">Default</convert>
      4. </widget>

      Aber das Event-now links daneben hat nur einen halbtransparenten Hintergrund - man erahnt zwar den Farbverlauf, aber der Hintergrund ist durchgehend dunkler.

      Source Code

      1. <widget source="session.Event_Now" render="VRunningText" options="movetype=running,startpoint=0,direction=left,steptime=50,repeat=5,startdelay=1500,always=0" position="285,904" size="1240,75" font="Regular; 60" halign="left" valign="top" backgroundColor="background" transparent="1" zPosition="2" noWrap="1">
      2. <convert type="EventName">Name</convert>
      3. </widget>
      Bei beiden habe ich den gleichen Hintergrund und transparent="1" zPosition="2" eingestellt.
      Woran könnte das liegen?
      Gruß Christoph :281:
    • @chrisly
      Benutze mal in Verbindung mit dem Renderer "VRunningText" noch zusätzlich den Parameter alphatest="blend"

      Man kann auch in Verbindung mit alphatest="blend" noch backgroundColor="transparent" benutzen
      „In Deutschland ist die höchste Form der Anerkennung der Neid.“

      Zitat von Arthur Schopenhauer

      The post was edited 1 time, last by Eisman ().

    • Super - so klappt´s! :D
      Mit Eurer Hilfe habe ich es jetzt hinbekommen :337: - falls gewünscht, kann ich den Skinpart auch gerne hier veröffentlichen.
      Ich bin mir nur noch nicht sicher, ob der rechte Bereich mit Datum, Uhrzeit und Wetter vielleicht zu viel des Guten ist (eigentlich sollte meine Infobar noch minimalistischer werden) ...
      Files
      Gruß Christoph :281:

      The post was edited 2 times, last by chrisly ().

    • Ich hab den Beitrag von dort hierher verschoben, weil ich nicht erkennen kann, was deine Frage mit dem ursprünglichen Thread zu tun hat.

      The post was edited 1 time, last by hgdo ().

    • moin,
      gibt es eine anpassung für audiozap, bei mir wird das bild nur 1/4 tv-größe dargestellt. hab gelesen, bei anderen skin´s soll es funktionieren mit der vollen bilddarstellung.
    • renefisch wrote:

      gibt es eine anpassung für audiozap, bei mir wird das bild nur 1/4 tv-größe dargestellt. hab gelesen, bei anderen skin´s soll es funktionieren mit der vollen bilddarstellung.
      1. schon mal HIER gelesen ? ist wohl eher kein Skin-Problem und daher auch kein Thema für Anpassungen, denke ich.
      2. um welche deiner Boxen geht es ?
      3. in welchem Skin funktioniert das AutoZap angeblich ?
      auf meiner Uno4K sehe ich jedenfalls grad auch das "kleine Bild" :whistling: ... muss wohl "Hardwarebeschränkung" sein ?( .
    • Danke für die Info. Es geht um die solo4k. Hab audio zap auf der duo2 früher öfter genutzt und wollte jetzt nach langer Zeit mal wieder audio zap auf der solo4k nutzen. Ich hab gelesen, das es bei anderen ohne Problem läuft, aber vielleicht benutzen die keine 4kbox.
    • Die gMEPG-Skinparts mit Extradaten sind ja noch in der Testphase. Ich nutze sie jetzt schon länger und finde sie perfekt! :thumbsup:
      Nur ein kleines Problem habe ich, bin aber nicht sicher, ob es mit den neuen Skinparts zusammenhängt:
      Ich nutze Extradaten01-V2 mit MiniTV. Und es passiert immer mal wieder, dass bei anderen Änderungen (ich teste z.Zt. relativ viel mit eigenen Skinparts) das MiniTV verschwindet, dafür aber der komplette Hintergrund leicht transparent ist (auch nach GUI-Neustart). Erst, wenn man den Extradaten-Skinpart ab- und anwählt und speichert (inkl. Neustart), ist das MiniTV dann wieder da.
      Gruß Christoph :281:
    • Skinpart für den File Commander

      Hi Leute,

      Ich bin noch nicht so lange in dem Thema Skinning.
      Als Versuchskaninchen habe ich mir mal den File Commander aus dem neuen Open ATV 6.3 vorgenommen den ich gerne mit euch teilen möchte.

      Der Skin kann als ipk installiert werden, falls ihr möchtet könnt ihr euch die Farben auch anpassen im oberen Teil.
      Wenn es Probleme gibt mit der Installation, installiert ihr ihn am besten über die Konsole mit:

      opkg install --force-depends enigma2-plugin-skin-iflatfhd-filecommander-cfdesigns_v1.01_all.ipk

      Damit solltet ihr keine Probleme haben, notfalls mit 7zip entpacken und manuell kopieren.

      Falls euch was auffällt oder ihr verbesserungsvorschläge habt könnt ihr mir gerne eine Nachricht schreiben.
      Ich bin ja noch im Lern status :)

      Wünsche euch viel Spaß damit.


      File Editor:

      file_editor.jpg

      File List:

      file_list.jpg

      Image Viewer:

      image_viewer.jpg

      Menü:

      menü_ansicht.jpg

      Settings:

      settings_ansicht.jpg

      File Infos:

      status_informationen.jpg

      Archiv Viewer / Zipper:

      unzip_addon.jpg

      IPK Installer:

      enigma2-plugin-skin-iflatfhd-filecommander-cfdesigns_v1.01_all.ipk

      The post was edited 1 time, last by hgdo ().

    • SCREEN PARTS ERSTELLEN - PROBLEME BEI MANCHEN PLUGINS

      New

      Hi Leute

      Vielleicht hat jemand ein Tipp von euch. Ich habe 2 Probleme wo ich einfach nicht weiter komme :(

      Problem 1:
      Es gibt Plugins wo in der __init__.py "scale" Werte drin stehen die ihre Auflösung anpassen nach Auflösung.
      Gibt es da eine Möglichkeit diese über den Skin Part (.xml) zu überschreiben ?

      Hatte versucht das EmailClient Plugin anzupassen da es nur bis 1280x720 auflöst.
      Durch die Entfernung zum Fernseher kann ich da kaum was Lesen.

      Problem 2:
      Ich habe das Problem das sich manche Plugins einfach nicht Skinnen lassen.

      Wenn ich mir die Screen Names raussuche schaue ich ja immer in die .py Dateien und suche mir die classes raus.
      Beispiel:
      Display Spoiler

      class PluginsPanel_config(Screen, ConfigListScreen):
      skin = '\n\t<screen position="center,center" size="610,400" title="Wall Setup" />\n\t\t<widget name="config" position="10,0" size="450,30" scrollbarMode="showOnDemand" />\n\t\t<widget name="config2" position="10,40" size="550,360" scrollbarMode="showOnDemand" />\n\t</screen>'


      def __init__(self, session, plugin_path):
      Screen.__init__(self, session)
      self.plugin_path = plugin_path
      self.skin_path = plugin_path
      self.session = session
      self.list = []
      self['config2'] = mylist([])
      ConfigListScreen.__init__(self, self.list)
      self.list.append(getConfigListEntry('Sortieren nach plugin hits:', config.plugins.PluginsPanel.hits))
      self['config'].setList(self.list)
      self['setupActions'] = ActionMap(['SetupActions'], {'ok': self.change_hide,
      'cancel': self.saveConfig}, -1)
      self.readconfig()


      Hier würde ich z.b. folgenden Part schreiben:
      Display Spoiler
      <screen name="PluginsPanel_config" position="center,center" size="1450,802" title="Wall Setup" />
      <widget name="config" position="325,10" size="800,30" valign="center" halign="center" scrollbarMode="showOnDemand" transparent="1" />
      <widget name="config2" position="100,50" size="1250,700" scrollbarMode="showOnDemand" transparent="1" />
      <eLabel position="center,center" size="1450,802" backgroundColor="#00000000" zPosition="-8" />
      </screen>


      Wenn ich dann das Plugin nach E2 Neustart aufrufe bleibt das Plugin unverändert und es passiert garnichts.
      Ich weiß nicht was ich noch versuchen kann.

      Wenn mir dazu jemand einen goldenen Tipp geben kann oder einen Hinweis nach dem ich suchen kann wäre ich euch sehr Dankbar :)

      Liebe Grüße und einen guten Start in die Woche.

      The post was edited 3 times, last by hgdo ().

    • New

      schmetty2 wrote:

      Pack' die skin.xml mal in den PlugIn Ordner,
      sorry, find ich jedoch erst mal "Quark" :huh: , man müßte erstmal sehen, wofür self.skin_path überhaupt genutzt wird.
      @Scalino :
      • bei den classes solltest du auch immer nachsehen, ob da nicht was mit self.skinNames (oder so) definiert ist ...
      • Problem1 (emailclient) : theoretisch kann man im Skin über applets auch so einiges am Plugin "manipulieren". Da der emailclient hier im VTI nicht mehr per Feed angeboten wird, hat das wohl seine Gründe ... funktioniert hier nicht oder Lizenz-Geschichte ? ?( Ist jedoch egal, hier im Thread : "no support for emailclient" :!:
      • Problem2 : k.A., welches Plugin du meinst ?( ... der screen für "PluginsPanel_config" sieht für mich auf den ersten Blick mal gut aus. hab k.A, warum der SkinPart bei dir nicht funktioniert. Auch an die richtige Stelle geschobenn, in den Einstellungen - iFlatFHD aktiviert ? im Debug mal nachgesehen, ob der auch sauber aktiviert wird ?

      The post was edited 1 time, last by gordon55 ().

    • New

      Ich meinte natürlich die nicht die iFlat skin.xml, sondern eine skin.xml die nur diesen einen Screen enthält. Sorry, falsch ausgedrückt.
    • New

      Vielen Dank für eure Antworten und Hilfe :)

      Das mit dem Plugin konnte ich lösen für das PluginsPanel, ein "/" zuviel und schon funktioniert nichts mehr *hmpf*
      Manchmal sieht man den Wald vor lauter Bäumen nicht.

      Das mit dem Email Client ist zwar schade aber nehme ich so wie es ist :)
    • New

      moin,

      Das Wetter wird nicht mehr angezeigt auf meinem Client,
      habe ich noch versäumt etwas einzustellen??

      1_0_19_30D6_413_1_C00000_0_0_0 (1).jpg 1_0_19_30D6_413_1_C00000_0_0_0.jpg
      Lernen ist wie schwimmen gegen den Strom, sobald man aufhört treibt man zurück!!

      The post was edited 1 time, last by hgdo ().