Pinned [Kleine Hilfe]Umstellung vom Netzwerkbrowser/Freigabemanager auf echtes Automount (Freigaben in: /etc/auto.network)

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [Kleine Hilfe]Umstellung vom Netzwerkbrowser/Freigabemanager auf echtes Automount (Freigaben in: /etc/auto.network)

    Aktualisierung (04.08.2016): Ihr müsst euch nicht mehr mit dieser Anleitung herumschlagen. Hier gibt es jetzt ein Plugin, welches das Ganze automatisiert. Thx an @shadowrider


    Fast täglich finden sich hier im Forum z.T. seitenlange Threads die sich mit einem recht trivialen Sachverhalt beschäftigen. Die schlichte Umstellung auf echtes „Automount“. Ich werde hier nicht mehr erläutern, warum die Umstellung sinnvoll ist. Wer das vorhat oder wem das empfohlen wurde weiß zwischenzeitlich um die Vorteile, oder wird sie schätzen lernen.


    Diese kleine Hilfe ist insbesondere für diejenigen, die bereits funktionierende Mounts über den Freigabemanager haben und sich auch weiterhin nicht mit technischen Details beschäftigen wollen oder auch können.

    Benötigt wird lediglich ein Editor, der Linux-konforme Files schreibt. Nachdem was ich hier im Forum bisher gelesen habe wird der notepad++ am häufigsten verwendet/empfohlen. Den „eingebauten“ Editor „vi“ sollte sich man sich nur antun wenn man masochistisch veranlagt ist. Wer den bedienen kann braucht auch die folgende „Anleitung“ nicht :thumbsup:

    Der Umstieg ist einfach - das Folgende macht ihr auf eigene Gefahr ; leider sind solche Hinweise aus bestimmten Gründen immer nötig...... ;_(

    1. Man schaut sich die /etc/enigma2/automounts.xml (mit den bereits funktionierenden Mounts) an
    Das folgende Beispiel zeigt zwei NFS-Mounts und einen CIFS-Mount. Wichtig für die korrekte Übersetzung in die /etc/auto.network sind die Kursiv/rotdargestellten Einträge:
    <?xml version="1.0" ?>
    <mountmanager>
    <nfs> [Erläuterung: Hier ist das verwendete Protokoll definiert – im Beispiel NFS]
    <mount>
    <active>True</active>
    <hdd_replacement>False</hdd_replacement>
    [Erläuterung: Hier steht „TRUE“ falls ein Mount als Ersatz für eine ansonsten eingebaute HDD verwendet wird; ist das bei Euch so, muss der Server ohnehin permanent verfügbar sein – eine Umstellung dieses Mounts auf „auto.network“ ist deshalb mit keinen Vorteilen verbunden. Meine Empfehlung: Stehen lassen – man spart sich dadurch weitere Anpassungen an den Aufnahmepfaden….entgegen anderslautenden Aussagen ist es zwischenzeitlich problemlos möglich Freigaben mit dem Freigabemanager und der auto.network parallel zu betreiben.]
    <ip>192.168.0.10</ip> [Erläuterung: Das ist logischerweise die IP eures Servers]

    <sharename>QNAP1</sharename>
    [Erläuterung: Das ist ein frei wählbarer Name, der so gewählt werden sollte, dass ihr erkennt auf was ihr eigentlich zugreift; Leerzeichen vermeiden]
    <sharedir>Public</sharedir> [Erläuterung: Hier ist der komplette Pfad zur Freigabe angegeben. Bei QNAP-NASen – wie in diesem Beispiel – ist das in der Regel tatsächlich nur der auch von CIFS/Samba bekannte Name des Shares. Der eigentlich notwendige führende Slash darf hier nicht angegeben werden, da er bei Verwendung des Freigabemanagers automatisch hinzugefügt wird]
    <options>rw,nolock,tcp</options
    > [Erläuterung: Hier werden die Mountoptionen definiert. Das sind Minimalangaben, die unverändert übernommen werden sollten. An diesen Optionen sollte man nur rumspielen wenn man weiß man tut, oder wenn es konkrete Probleme gibt. Problembeschreibung im Forum posten!]
    </mount>
    </nfs> [Erläuterung: Mit diesem Eintrag wird der Eintrag abgeschlossen]
    <nfs> [Erläuterung: Hier beginnt ein neuer Mounteintrag – Erläuterung s.o.]
    <mount>
    <active>False</active>
    <hdd_replacement>False</hdd_replacement>
    <ip>192.168.0.11</ip>
    <sharename>Synology1</sharename><sharedir>volume1/Video</sharedir> [Erläuterung: Hier ist der komplette Pfad zur Freigabe angegeben. Dies ist ein Beispiel für ein Synology-NAS]
    <options>rw,nolock,tcp</options>

    </mount>
    </nfs>
    <cifs> [Erläuterung: Hier beginnt ein neuer Eintrag. In diesem Beispiel CIFS]
    <mount>
    <active>True</active>
    <hdd_replacement>False</hdd_replacement>
    <ip>192.168.0.100</ip>
    <sharename>WinPCFilme</sharename>
    <sharedir>Filme</sharedir>
    [Erläuterung: Im Gegensatz zu einem NFS-Mount steht hier IMMER nur der konkrete Freigabename des Shares auf dem Server]

    <options>rw</options> [Erläuterung: s.o. Bei einem CIFS-Mount sollten die Optionen auf ein absolutes Minimum reduziert bleiben]
    <username>username</username>
    [Erläuterung: Logischerweise der Benutzername für den Zugriff – falls keiner notwendig, kann hier was x-beliebiges eingetragen sein; am besten verwendet man in diesem Fall „guest“]
    <password>password</password> [Erläuterung: Logischerweise das Passwort für den Zugriff – falls keines notwendig, kann hier was x-beliebiges eingetragen sein]
    </mount>
    </cifs>



    2. Man öffnet die /etc/auto.network (mit einem linux-konformen Editor), die nackt so aussehen sollte (das „do NOT change manually“ getrost ignorieren) - ab VTI 9.0 ist diese Datei evtl. nicht vorhanden; einfach in /etc neu erstellen:

    Source Code

    1. # automatically generated by enigma 2
    2. # do NOT change manually!


    3. Jetzt ergänzen wir die Datei um die aus der automounts.xml bekannten Einträge (Ergänzungen in ROT):

    # automatically generated by enigma 2
    # do NOT change manually!
    QNAP1 -fstype=nfs,rw,soft,tcp,nolock 192.168.0.10:/Public
    Synology1 -fstype=nfs,rw,soft,tcp,nolock 192.168.0.11:/volume1/Video
    WinPCFilme -fstype=cifs,rw,sec=ntlm,user=username,password=password ://192.168.0.100/Filme





    Der geneigte Leser wird feststellen, dass ich hier bei den NFS-Mounts die Option "soft" hinzugefügt habe, obwohl sie in der automounts.xml (meist) nicht steht. Im Prinzip ist "soft" Standard - ich möchte allerdings immer sicherstellen, dass das auch immer verwendet wird. Deshalb hier eine kleine Ausnahme der eigentlichen Regel: Alles so übernehmen wie es bisher funktioniert ;love:
    edit: Bei den CIFS-Mountoptionen habe ich noch "sec=ntlm" hinzugefügt. Dieser Eintrag ist notwendig, wenn der Server nicht mit den aktuellen Sicherheitslevels zurecht kommt.

    4. Nach dem Speichern der auto.network noch die Rechte kontrollieren und ggf. auf 644 ändern (telnet und folgendes eingeben: chmod 644 /etc/auto.network). Das ist derzeit eminent wichtig.


    5. Wenn man das System sauber halten will, löscht man jetzt einfach die automounts.xml (oder man benennt sie vorsichtshalber, für einen einfachen Fall-Back, in z.B. automounts.xml.old um.

    6. Kiste neu starten. Die Mounts findet ihr jetzt unter /media/net/autofs.

    Bookmarks neu anlegen und Aufnahmepfade anpassen (das ist nun weiß Gott im WIKI sehr ausführlich beschrieben, deshalb schenke ich mir das hier).


    Sollte was unklar sein, oder in der Hitze des kurzen Gefechts Schreibfehler vorhanden sein - einfach ignorieren oder die verbesserte Erläuterung selbst posten D:. Für Fragen stehe ich - oder jeder andere, der sich halbwegs mit dem Zeugs auskennt - sicher gerne zur Verfügung......
    [i][b]Kein Backup - kein Mitleid[/b][/i]

    The post was edited 5 times, last by rolano: Hinweis auf evtl. fehlende auto.networt in /etc ab VTI 9.x ergänzt Hinweis auf "sec=ntlm" bei CIFS-Mounts (Server kommt mit aktuellen Sicherheitslevels nicht zurecht) - Achtung: Gilt auch für die automounts.xml ().

  • Auch von mir einen großen Dank !
    Schön gemacht ! :thumbsup:
    Ich würde die Codezeilen aber in #Code# setzen. Das ist m.E. übersichtlicher.
    Herzlichen Gruß,
    theos2

    ___________________________________________________________________________
    Kein Support per PN

    :319: Vodafone KD mit der VU+ <> Picons für Vodafone KD <> Mirror Glass Picons für Vodafone KD
  • theos2 wrote:

    Ich würde die Codezeilen aber in #Code# setzen. Das ist m.E. übersichtlicher.
    Tja, das ist durchaus richtig und wurde da wo es sinnvoll ist auch gemacht. Ansonsten sind in Code-Blöcken leider keine Formatierungen möglich - und Plain-Text macht´s dann wieder "unübersichtlich".
    Auch wollte und will ich keinen Schönheitspreis gewinnen :8) . Wen es interessiert sollte problemlos zurecht kommen; die "Anderen" werden ohnhin unter Missachtung der Sufu weiterhin munter drauflos posten. So isch halt das Foren-Leben ;rolleyes:
    [i][b]Kein Backup - kein Mitleid[/b][/i]
  • Sehr schöne Anleitung, aber leider ist die Syntax bei CIFS eine andere als bei NFS. Bitte korrigieren:

    Source Code

    1. WinPCFilme -fstype=cifs,rw,user=username,password=password ://192.168.0.100/Filme

    oder besser noch mit Namen, damit die IP-Adresse egal ist:

    Source Code

    1. WinPCFilme -fstype=cifs,rw,user=username,password=password ://vuduo2/Filme


    Gruß,
    Stefan
  • Teddybär wrote:

    (...)leider ist die Syntax bei CIFS eine andere als bei NFS.
    Yepp, und jeder sollte das wissen! Danke - lässt sich nur durch partiellen Hirntod mit Verlust der Augen/Finger-Koordination erklären :8| . Wäre ich Samurai würde ich mich jetzt in mein Schwert stürzen ;love: . Ich habe es oben korrigiert.

    Da der Hostname nur dann in der automounts steht, wenn der geneigte Anwender das - unter Umgehung der Klicki-Bunti-Vorgehensweise - auch tatsächlich selbst eingetragen hat, wird er die obige Hilfe ohnehin nicht brauchen, oder er ist in der Lage IP gegen Hostnamen zu tauschen. Oben werde ich DAS nicht ändern.
    [i][b]Kein Backup - kein Mitleid[/b][/i]
  • Hi

    In der automounts steht der normalerweise nicht und braucht da auch nicht zu stehen. Jeder Anwender sollte wissen was für eine Box er hat und dementsprechend den Namen herausfinden können anhand der Liste:

    VU+ Duo bm750
    VU+ Duo² vuduo2
    VU+ Solo² vusolo2
    VU+ Zero vuzero
    VU+ Solo SE vusolose

    Das halte ich für machbar.

    Gruß,
    Stefan
  • zuerst einmal

    :331:

    ich habe bei mir zwar unter Anleitung D: seinerzeit mittels der auto.network von CIFS auf NFS umgestellt aber seit einiger Zeit hatte ich alle paar Minuten sehr kurze Stopper in der Wiedergabe...

    mein Eintrag war, hier am Beispiel einer WDMyBook Live Platte:

    Platte1 -fstype=nfs,rw,soft,timeo=50,udp,nolock 192.168.178.43:/nfs/Public


    nach Lesen dieses Threads nun umgestellt auf:

    Platte1 -fstype=nfs,rw,soft,tcp,nolock MYBOOKLIVE1:/nfs/Public


    also eine Umstellung von udp auf tcp und statt IP direkt der Name

    und ;?: ...

    nun läuft alles ohne kurze Stopper ;!:

    *scho*
    Drickes
    VU+....Ultimo4K;....Duo²;......Duo;.......Uno(Twin-Tuner);...Solo
    VTI.....14.X.X........14.X.X,....8.2.X,............11.X.X,.........8.0.X
    Plugins:
    Yamp
    nfs.server
    Reconstructapsc
    automatic-fullbackup
    epgrefresh
    graphmultiepg
    lcd4linux

    Skin Atile HD

    The post was edited 1 time, last by Drickes ().

  • also meine automounts.xml sieht so aus, (siehe Bild 5)

    bin aber jetzt etwas verwirrt.
    soll ich den rot markierten Text einfach in die auto.network unten dran einfügen?

    <cifs> [Erläuterung: Hier beginnt ein neuer Eintrag. In diesem Beispiel CIFS]
    <mount>
    <active>True</active>
    <hdd_replacement>False</hdd_replacement>
    <ip>192.168.0.100</ip>
    <sharename>WinPCFilme</sharename>
    <sharedir>Filme</sharedir>[Erläuterung: Im Gegensatz zu einem NFS-Mount steht hier IMMER nur der konkrete Freigabename des Shares auf dem Server]
    <options>rw</options> [Erläuterung: s.o. Bei einem CIFS-Mount sollten die Optionen auf ein absolutes Minimum reduziert bleiben]
    <username>username</username>[Erläuterung: Logischerweise der Benutzername für den Zugriff – falls keiner notwendig, kann hier was x-beliebiges eingetragen sein; am besten verwendet man in diesem Fall „guest“]
    <password>password</password> [Erläuterung: Logischerweise das Passwort für den Zugriff – falls keines notwendig, kann hier was x-beliebiges eingetragen sein]
    </mount>
    </cifs>


    und/oder soll der rote text auch noch dazu?

    Zitat
    # automatically generated by enigma 2
    # do NOT change manually!
    QNAP1 -fstype=nfs,rw,soft,tcp,nolock 192.168.0.10:/Public
    Synology1 -fstype=nfs,rw,soft,tcp,nolock 192.168.0.11:/volume1/Video
    WinPCFilme -fstype=cifs,rw,user=username,password=password ://192.168.0.100/Filme



    Danke für die Hilfe
    Files
    • 5.JPG

      (29.58 kB, downloaded 184 times, last: )
    • 6.JPG

      (17.56 kB, downloaded 144 times, last: )
  • also so?

    mit dem < > vor und nach jeder Zeile - oder soll ich ein # davor und danach einfügen?


    # automatically generated by enigma
    2
    # do NOT change manually!

    <ip>192.168.xxx.xx</ip>
    <sharename>Serien</sharename>
    <sharedir>Serien</sharedir>
    <options>rw</options>
    <username>xxxxx</username>
    <password>xxxxx</password>
    </mount>
    </cifs>
    Serien -fstype=cifs,rw,user=username,password=password ://192.168.xxx.xx/Serien
  • Nein, so nicht. Nur die letzte Zeile und den ganzen Kram in <> brauchst du in der Autor.network nicht. Der steht doch in der letzten Zeile.

    The post was edited 1 time, last by Knifte ().

  • # automatically generated by enigma
    2# do NOT change manually!

    Serien -fstype=cifs,rw,user=username,password=password ://192.168.xxx.xx/Serien

    Knifte wrote:

    Nein, so nicht. Nur die letzte Zeile und den ganzen Kram in <> brauchst du in der Autor.network nicht. Der steht doch in der letzten Zeile.

    The post was edited 1 time, last by milli ().

  • Gibts eigentlich irgendwo eine Erläuterung für die Bedeutung der Parameter?
    TV: LG 42LH3010
    Receiver: VU+ Solo2 + NFS Einbindung
    Netzwerk: AVM Fritzbox 7490 | ZyXEL GS1900-24E Web-Managed Switch |2x Unifi AP AC Pro | Unifi UAP-AC-M

    NAS: Synology DS918+ | RaspberryPi@Oscam r11392, Sky V13
  • so, heute habe ich nochmal alles ausprobiert,

    d.h. Duo 2 ausgeschaltet, Server ausgeschaltet

    dann Duo2 einschalten - fernschauen ect.
    dann Server eingeschaltet - kurz warten bis er oben ist,

    nun Media player an der Duo 2 öffnen und was mir als erstes auffällt, ein neuer Ordner (Network Mount (autofs)) - keine Ahnung was das ist

    aber den Server hat er nivht automatisch gefunden.

    ich musste erst in die Einstellung - System - Netzwerk - Netzwerkverbindung - Freigabe Manager - Freigaben Verwaltung - (dort war er nicht verbunden)
    also 1x OK gedrückt zum Editieren - dann nochmal ok drücken und mit JA bestätigen

    erst dann war er verbunden und im Media Player war der Server zu sehen


    hmmm, was habe ich falsch gemacht?