tsocks konsolen tool für vu+

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • tsocks konsolen tool für vu+

      Ich habe mal tsocks für die vu+ paketiert.

      Getestet unter VTi 7.0 auf VU+ Ultimo

      Für Details zu dem Programm: linux.die.net/man/8/tsocks

      kurz: es ermöglicht beliebige Programme dazu zu zwingen für die Verbindung zum Internet einen Socks Proxy zu verwenden.
      z.B. könnte man nach erfolgreicher Installation ausfindig machen über welchen weg das enigma2 Binary gestartet wird und dieses Script wie folgt anpassen:

      Source Code

      1. tsocks enigma2 --weitere_cmd_argumente



      somit wird ab sofort der gesamte enigma2 Internettraffic über den in der "/etc/tsocks.conf" Konfigurationsdatei eingestellten Socks Proxy geleitet.


      ACHTUNG: getestet nur auf der vu+ ultimo, sollte aber auf allen Modellen laufen
      Files

      The post was edited 1 time, last by Cronix ().

    • Hi,

      ich möchte das gerne auf eine VU+ Solo2 installieren. Leider sieht das dann so aus:

      root@vusolo2:/# opkg install enigma2-plugin-binary-tsocks_1.8.ipk
      Collected errors:
      * open_outer: Failed to open package 'enigma2-plugin-binary-tsocks_1.8.ipk': Unrecognized archive format
      * pkg_extract_control_file_to_stream: Failed to extract control.tar.gz from package 'enigma2-plugin-binary-tsocks_1.8.ipk'.
      * pkg_init_from_file: Failed to extract control file from enigma2-plugin-binary-tsocks_1.8.ipk.
      root@vusolo2:/#

      The post was edited 2 times, last by e0281101225 ().

    • du kannst versuchen, es entpacken und dann die Verzeichnisse/Dateien auf die Box schieben
      (mach vorher eine Sicherung falls was schief geht)
      ============================================================================================
    • Anybody tried this with a more up to date vti? 13-14?

      tsocks is failing to start with

      ERROR: ld.so: object '/usr/lib/libtsocks.so' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.

      but the library exists...

      any ideas?

      (btw had to extract the package manually and copy files to folders)

      The post was edited 1 time, last by michalhainc ().