VU+ Duo Bootloader Update erfolgreich?

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • VU+ Duo Bootloader Update erfolgreich?

      Hallo Forum,

      beim Versuch vom Original auf das letzte VTi Image zu aktualisieren, habe ich mir die Box offenbar zerschossen.

      * Zunächst habe ich wie gefordert ein Bootloader Update durchgeführt, was den Angaben im LCD Display erfolgreich war.
      * Danach habe ich rebootet und per USB das letzte VTi Image eingespielt, was den Meldungen auf dem LCD nach ebenfalls erfolgreich war.

      Beim anschließenden Reboot hing die Box bei "Starting"

      Der Kardinalfehler: Ich habe kein Backup des Original Images gemacht! m( (ja schimpft nur ...)

      Also habe ich probiert das "Original Image 6.0" (und auch 5.11) einzuspielen. Beim Booten dieser Images kommt die Box immerhin nach "Starting" bis zu "VU+ Duo", hängt sich dann aber ebenfalls auf.

      Inzwischen habe ich ein Flash-/Boot-Log per serieller Konsole erstellt.

      Einspielen des Bootloader Updates:

      Source Code

      1. BCM73350010
      2. 012
      3. Shmoo Version=1.9
      4. MEMC-00000000 RW=00000010 WW=0000004A G=00000001 R=00000008 W=0000001B
      5. MEMC-00000001 RW=0000000E WW=00000049 G=00000001 R=00000007 W=0000000C #$
      6. 3
      7. COPY CODE
      8. A567
      9. BCM97335B0 CFE v2.17, CFE core v2.12, Endian Mode: Little
      10. Build Date: Thu Sep 29 12:01:32 2011 (shcheong@ncsh)
      11. Copyright (C) Broadcom Corporation.
      12. writing vfd
      13. DDR Freq: 395MHz
      14. CPU speed: 405MHz
      15. Memory Config: 32+16 non-UMA
      16. Device Tech: 1Gb
      17. Total memory: 384MB
      18. Boot Device: NAND
      19. ECC: Hamming
      20. Total flash: 128MB
      21. Initializing USB.
      22. USB: Locating Class 09 Vendor 0000 Product 0000: USB Hub
      23. USB: Locating Class 09 Vendor 0000 Product 0000: USB Hub
      24. CFE initialized.
      25. USB: New device connected to bus 1 hub 1 port 1
      26. USB: Resetting device on bus 1 port 1
      27. USB: Locating Class 08 Vendor 048D Product 1165: Mass-Storage Device
      28. USBMASS: Unit 0 connected
      29. checking usb
      30. Reading usbdisk0:/vuplus/duo/cfe_cfe_auto.bin: >> Done. 287604 bytes read
      31. Programming...
      32. nand_erase_block 0x1fc00000 0x20000 donenand_erase_block 0x1fc20000 0x20000 donenand_erase_block 0x1fc40000 0x20000 donedone. 287604 bytes written
      33. please remove usb first and reboot
      Display All


      Dem Dateinamen "duo_cfe_3_0_usb.zip" zur Folge würde ich beim Booten nun CFE Version 3.0 erwarten. Beim folgenden Flashen/Booten des Orginal Images 6.0 wird aber erneut CFE v2.17 gemeldet.

      Boot Log Original Image 6.0 (Auszug, gesamtes Log ist hier sichtbar: Link entfernt!

      Source Code

      1. BCM97335B0 CFE v2.17, CFE core v2.12, Endian Mode: Little
      2. Build Date: Thu Sep 29 12:01:32 2011 (shcheong@ncsh)
      3. Copyright (C) Broadcom Corporation.
      4. [...]
      5. CFE initialized.
      6. checking usb
      7. Loader:elf Filesys:raw Dev:flash0.kernel File: Options:rootfstype=jffs2 root=/dev/mtdblock0 rw mem=0x8000000 bcmrac=3
      8. Loading: 0x80001000/3566980 0x80367d84/144016 Entry address is 0x80346000
      9. TP1 Entry Address at 0x80000ffc = 80346000
      10. Starting program at 0x80346000
      11. <5>Linux version 2.6.18-7.3 (vuplus@team3-server) (gcc version 4.4.3 (GCC) ) #1 SMP Fri Sep 23 03:12:10 KST 2011
      12. Fetching vars from bootloader... OK (E,D,B,C)
      13. Detected 256 MB on MEMC0 (strap 0xe5430060)
      14. CFE EnvVar: LINUX_FFS_STARTAD: 00000000, LINUX_FFS_SIZE: 07600000
      15. CFE EnvVar: LINUX_PART_STARTAD: 07600000, LINUX_PART_SIZE: 00400000
      16. g_board_RAM_size=256MB
      17. Options: sata=1 enet=1 emac_1=1 no_mdio=0 docsis=0 ebi_war=0 pci=1 smp=1
      18. CPU revision is: 0002a044
      19. FPU revision is: 00130001
      20. [...]
      21. brcmnand_probe: CS0: dev_id=ecf10095
      22. NAND Config: Reg=55042200, chipSize=128 MB, blockSize=128K, erase_shift=11
      23. busWidth=1, pageSize=2048B, page_shift=11, page_mask=000007ff
      24. BrcmNAND mfg ec f1 Samsung K9F1G08U0A 128MB
      25. [...]
      26. brcmnandCET: Status -> Deferred
      27. numchips=1, size=8000000
      28. Creating 7 MTD partitions on "bcm7xxx-nand.0":
      29. 0x0000000000000000-0x0000000007600000 : "rootfs"
      30. 0x0000000007600000-0x0000000007a00000 : "kernel"
      31. 0x0000000007800000-0x0000000007c00000 : "boot"
      32. 0x0000000007c00000-0x0000000007d00000 : "cfe"
      33. 0x0000000007d00000-0x0000000007d80000 : "mac"
      34. 0x0000000007d80000-0x0000000007e00000 : "env"
      35. 0x0000000007e00000-0x0000000007f00000 : "nvm"
      36. usbmon: debugfs is not available
      37. [...]
      38. VFS: Mounted root (jffs2 filesystem).
      39. Freeing unused kernel memory: 136k freed
      40. mount: mounting sysfs on /sys failed: Device or resource busy
      41. Startting the hotplug events dispatcher
      42. Synthesizing the initial hotplug events
      43. Waiting for /dev to be fully populated
      44. brcm-pm: enabling power to SATA block
      45. [...]
      46. udevd-event[326]: node_symlink: rename(/dev/fb.udev-tmp, /dev/fb) failed: Is a directory
      47. [...]
      48. jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000000: 0x3cf2 instead
      49. jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000004: 0x7841 instead
      50. jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000008: 0x7be3 instead
      51. jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x0000000c: 0x3e9a instead
      52. jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000010: 0xa909 instead
      Display All

      Wurde das Bootloader Update demnach nicht durchgeführt, oder läuft daneben noch etwas anderes falsch? Das erwartete Dateien nicht gefunden werden, ist ja deutlich sichtbar.

      Was kann ich sinnvollerweise tun, um doch noch ein Image (Original/VTi/BH) zum Laufen zu bekommen? Bootloader Up/Downgrade?

      Oder Hilft nur noch Einschicken an den Hersteller?


      Danke+Gruß

      Olaf
    • Hast Du irgendas an den hinteren USB-Anschlüssen "hängen"?
      Sollte es eine interne Festplatte geben, die evtl. auch mal testweise
      abstecken und schauen ob die Box dann bootet.
      Nach dem Flashen v. VTI kommt nicht der Installationsassistent?
      Dass nach einen Neuflash der Bootvorgang wesentlich länger dauert als
      sonst ist Dir bekannt?
      Radar

      The post was edited 1 time, last by Radar ().

    • Hallo Radar,

      danke für die Antwort.

      Die USB Platte war bereits abgezogen, das Netzwerk nun auch. Aktuell stecken nur Power, SAT, HDMI+Chinch-Audio. Zum Flashen nutze ich die Front USB Buchse.

      Ich habe gerade nochmal das letzte VTI für die DUO (vuplus-image-bm750-20140425184139_vti_6-0-8_usb.zip) probiert. Mit dem VTI Image bekomme ich eine Kernel Panic (s.u.). Da komme ich mit dem Original Image noch etwas weiter

      Ich frage mich ja immer weiterhin, ob das Bootloader Update mit "CFE v2.17, CFE core v2.12" tatsächlich erfolgreich war?



      Source Code

      1. BCM73350010
      2. 012
      3. Shmoo Version=1.9
      4. MEMC-00000000 RW=00000011 WW=0000004A G=00000001 R=00000008 W=0000001B
      5. MEMC-00000001 RW=0000000D WW=0000004B G=00000001 R=00000006 W=0000000D #$
      6. 3
      7. COPY CODE
      8. A567
      9. BCM97335B0 CFE v2.17, CFE core v2.12, Endian Mode: Little
      10. Build Date: Thu Sep 29 12:01:32 2011 (shcheong@ncsh)
      11. Copyright (C) Broadcom Corporation.
      12. writing vfd
      13. DDR Freq: 395MHz
      14. CPU speed: 405MHz
      15. Memory Config: 32+16 non-UMA
      16. Device Tech: 1Gb
      17. Total memory: 384MB
      18. Boot Device: NAND
      19. ECC: Hamming
      20. Total flash: 128MB
      21. Initializing USB.
      22. USB: Locating Class 09 Vendor 0000 Product 0000: USB Hub
      23. USB: Locating Class 09 Vendor 0000 Product 0000: USB Hub
      24. CFE initialized.
      25. checking usb
      26. Loader:elf Filesys:raw Dev:flash0.kernel File: Options:rootfstype=jffs2 root=/dev/mtdblock0 rw mem=0x8000000 bcmrac=3
      27. Loading: 0x80001000/7057696 0x806bc120/120320 Entry address is 0x80545040
      28. TP1 Entry Address at 0x80000ffc = 80545040
      29. Starting program at 0x80545040
      30. Linux version 3.1.1 (vti@build-vti) (gcc version 4.6.4 20120303 (prerelease) (GCC) ) #1 SMP Sun Mar 16 18:27:16 CET 2014
      31. Fetching vars from bootloader... found 11 vars.
      32. Early serial console at MMIO32 0x10400b00 (options '115200n8')
      33. bootconsole [uart0] enabled
      34. Options: sata=1 enet=1 emac_1=1 no_mdio=0 docsis=0 pci=1 smp=1 moca=0 usb=1
      35. Using 256 MB + 128 MB RAM (from CFE)
      36. bootconsole [early0] enabled
      37. CPU revision is: 0002a044 (Brcm4380)
      38. FPU revision is: 00130001
      39. Determined physical RAM map:
      40. memory: 10000000 @ 00000000 (usable)
      41. bmem: adding 112 MB RESERVED region at 144 MB (0x07000000@0x09000000)
      42. Initrd not found or empty - disabling initrd
      43. Zone PFN ranges:
      44. Normal 0x00000000 -> 0x00010000
      45. Movable zone start PFN for each node
      46. early_node_map[1] active PFN ranges
      47. 0: 0x00000000 -> 0x00010000
      48. PERCPU: Embedded 7 pages/cpu @81203000 s4384 r8192 d16096 u32768
      49. Built 1 zonelists in Zone order, mobility grouping on. Total pages: 65024
      50. Kernel command line: bmem=112M ubi.mtd=0 root=ubi0:rootfs rootfstype=ubifs rw rootflags=sync
      51. PID hash table entries: 1024 (order: 0, 4096 bytes)
      52. Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
      53. Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
      54. Primary instruction cache 32kB, VIPT, 2-way, linesize 64 bytes.
      55. Primary data cache 64kB, 4-way, VIPT, cache aliases, linesize 64 bytes
      56. Memory: 138116k/262144k available (5453k kernel code, 124028k reserved, 1199k data, 240k init, 0k highmem)
      57. Hierarchical RCU implementation.
      58. NR_IRQS:128
      59. Detected MIPS clock frequency: 404 MHz (202.497 MHz counter)
      60. Calibrating delay loop... 403.45 BogoMIPS (lpj=201728)
      61. pid_max: default: 32768 minimum: 301
      62. Mount-cache hash table entries: 512
      63. SMP: Booting CPU1...
      64. CPU revision is: 0002a044 (Brcm4380)
      65. FPU revision is: 00130001
      66. Primary instruction cache 32kB, VIPT, 2-way, linesize 64 bytes.
      67. Primary data cache 64kB, 4-way, VIPT, cache aliases, linesize 64 bytes
      68. SMP: CPU1 is running
      69. Brought up 2 CPUs
      70. NET: Registered protocol family 16
      71. PCI2.3->SDRAM window: 512 MB
      72. bio: create slab <bio-0> at 0
      73. SCSI subsystem initialized
      74. usbcore: registered new interface driver usbfs
      75. usbcore: registered new interface driver hub
      76. usbcore: registered new device driver usb
      77. Advanced Linux Sound Architecture Driver Version 1.0.24.
      78. PCI: found device 14e4:8602 on SATA bus, slot 0 (irq 42)
      79. pci 0000:01:00.0: BAR 5: assigned [mem 0x10510000-0x10510fff]
      80. pci 0000:01:00.0: BAR 5: set to [mem 0x10510000-0x10510fff] (PCI address [0x10510000-0x10510fff])
      81. pci 0000:01:00.0: BAR 6: assigned [mem 0x10511000-0x105117ff pref]
      82. cfg80211: Calling CRDA to update world regulatory domain
      83. Switching to clocksource upg
      84. NET: Registered protocol family 2
      85. IP route cache hash table entries: 2048 (order: 1, 8192 bytes)
      86. TCP established hash table entries: 8192 (order: 4, 65536 bytes)
      87. TCP bind hash table entries: 8192 (order: 4, 65536 bytes)
      88. TCP: Hash tables configured (established 8192 bind 8192)
      89. TCP reno registered
      90. UDP hash table entries: 128 (order: 0, 4096 bytes)
      91. UDP-Lite hash table entries: 128 (order: 0, 4096 bytes)
      92. NET: Registered protocol family 1
      93. RPC: Registered named UNIX socket transport module.
      94. RPC: Registered udp transport module.
      95. RPC: Registered tcp transport module.
      96. RPC: Registered tcp NFSv4.1 backchannel transport module.
      97. NTFS driver 2.1.30 [Flags: R/W].
      98. JFFS2 version 2.2. (NAND) (SUMMARY) © 2001-2006 Red Hat, Inc.
      99. msgmni has been set to 269
      100. io scheduler noop registered
      101. io scheduler cfq registered (default)
      102. Serial: 8250/16550 driver, 4 ports, IRQ sharing disabled
      103. serial8250.0: ttyS0 at MMIO 0x10400b00 (irq = 22) is a 16550A
      104. console [ttyS0] enabled, bootconsole disabled
      105. console [ttyS0] enabled, bootconsole disabled
      106. serial8250.0: ttyS1 at MMIO 0x10400b40 (irq = 66) is a 16550A
      107. serial8250.0: ttyS2 at MMIO 0x10400b80 (irq = 67) is a 16550A
      108. loop: module loaded
      109. brcm-pm: enabling sata clocks
      110. PCI: Enabling device 0000:01:00.0 (0000 -> 0003)
      111. scsi0 : sata_brcmstb
      112. scsi1 : sata_brcmstb
      113. ata1: SATA max UDMA7 mmio m4096@0x10510000 port 0x10510000 irq 42
      114. ata2: SATA max UDMA7 mmio m4096@0x10510000 port 0x10510100 irq 42
      115. Broadcom STB NAND controller (BrcmNand Controller)
      116. bcmemac: Broadcom STB 10/100 EMAC driver v3.0
      117. bcmemac: registered interface #0 at 0x10080000 as 'eth0' (00:1d:ec:03:db:80)
      118. bcmemac: not registering interface #1 at 0x10090000 (no PHY detected)
      119. usbcore: registered new interface driver zd1201
      120. ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
      121. brcm-pm: enabling usb clocks
      122. ehci-brcm ehci-brcm.0: Broadcom STB EHCI
      123. ehci-brcm ehci-brcm.0: new USB bus registered, assigned bus number 1
      124. ehci-brcm ehci-brcm.0: irq 62, io mem 0x10480300
      125. ehci-brcm ehci-brcm.0: USB 0.0 started, EHCI 1.00
      126. hub 1-0:1.0: USB hub found
      127. hub 1-0:1.0: 2 ports detected
      128. ehci-brcm ehci-brcm.1: Broadcom STB EHCI
      129. ehci-brcm ehci-brcm.1: new USB bus registered, assigned bus number 2
      130. ehci-brcm ehci-brcm.1: irq 57, io mem 0x10480500
      131. ehci-brcm ehci-brcm.1: USB 0.0 started, EHCI 1.00
      132. hub 2-0:1.0: USB hub found
      133. hub 2-0:1.0: 2 ports detected
      134. ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
      135. ohci-brcm ohci-brcm.0: Broadcom STB OHCI
      136. ohci-brcm ohci-brcm.0: new USB bus registered, assigned bus number 3
      137. ohci-brcm ohci-brcm.0: irq 63, io mem 0x10480400
      138. hub 3-0:1.0: USB hub found
      139. hub 3-0:1.0: 2 ports detected
      140. ohci-brcm ohci-brcm.1: Broadcom STB OHCI
      141. ohci-brcm ohci-brcm.1: new USB bus registered, assigned bus number 4
      142. ohci-brcm ohci-brcm.1: irq 64, io mem 0x10480600
      143. hub 4-0:1.0: USB hub found
      144. hub 4-0:1.0: 2 ports detected
      145. ata1: SATA link down (SStatus 4 SControl 300)
      146. Initializing USB Mass Storage driver...
      147. usbcore: registered new interface driver usb-storage
      148. USB Mass Storage support registered.
      149. mousedev: PS/2 mouse device common for all mice
      150. i2c /dev entries driver
      151. lirc_dev: IR Remote Control driver registered, major 254
      152. IR NEC protocol handler initialized
      153. IR RC5(x) protocol handler initialized
      154. IR RC6 protocol handler initialized
      155. IR JVC protocol handler initialized
      156. IR Sony protocol handler initialized
      157. IR RC5 (streamzap) protocol handler initialized
      158. IR MCE Keyboard/mouse protocol handler initialized
      159. IR LIRC bridge handler initialized
      160. Linux video capture interface: v2.00
      161. usbcore: registered new interface driver usbhid
      162. usbhid: USB HID core driver
      163. ALSA device list:
      164. No soundcards found.
      165. TCP cubic registered
      166. NET: Registered protocol family 17
      167. lib80211: common routines for IEEE802.11 drivers
      168. EBI CS0: setting up NAND flash (primary)
      169. mtd->oobsize=0, mtd->eccOobSize=0
      170. NAND_CS_NAND_XOR=00000001
      171. B4: NandSelect=40000101, nandConfig=55042200, chipSelect=0
      172. brcmnand_read_id: CS0: dev_id=ecf10095
      173. After: NandSelect=40000101, nandConfig=55042200
      174. Block size=00020000, erase shift=17
      175. NAND Config: Reg=55042200, chipSize=128 MB, blockSize=128K, erase_shift=11
      176. busWidth=1, pageSize=2048B, page_shift=11, page_mask=000007ff
      177. BrcmNAND mfg ec f1 Samsung K9F1G08U0A 128MB on CS0
      178. Found NAND on CS0: ACC=d3000000, cfg=55042200, flashId=ecf10095, tim1=4232222d, tim2=00000d94
      179. BrcmNAND version = 0x0201 128MB @00000000
      180. B4: NandSelect=40000101, nandConfig=55042200, chipSelect=0
      181. brcmnand_read_id: CS0: dev_id=ecf10095
      182. After: NandSelect=40000101, nandConfig=55042200
      183. Found NAND flash on Chip Select 0, chipSize=128MB, usable size=128MB, base=0
      184. brcmnand_scan: B4 nand_select = 40000101
      185. brcmnand_scan: After nand_select = 40000101
      186. page_shift=11, bbt_erase_shift=17, chip_shift=27, phys_erase_shift=17
      187. Brcm NAND controller version = 2.1 NAND flash size 128MB @18000000
      188. ECC layout=brcmnand_oob_bch4_4k
      189. brcmnand_scan: mtd->oobsize=64
      190. brcmnand_scan: oobavail=50, eccsize=512, writesize=2048
      191. brcmnand_scan, eccsize=512, writesize=2048, eccsteps=4, ecclevel=15, eccbytes=3
      192. -->brcmnand_default_bbt
      193. brcmnand_default_bbt: bbt_td = bbt_main_descr
      194. Creating 7 MTD partitions on "brcmnand.0":
      195. 0x000000000000-0x000007600000 : "rootfs"
      196. 0x000007600000-0x000007a00000 : "kernel"
      197. 0x000007a00000-0x000007c00000 : "boot"
      198. 0x000007c00000-0x000007d00000 : "cfe"
      199. 0x000007d00000-0x000007d80000 : "mac"
      200. 0x000007d80000-0x000007e00000 : "env"
      201. 0x000007e00000-0x000007f00000 : "nvm"
      202. UBI: attaching mtd0 to ubi0
      203. UBI: physical eraseblock size: 131072 bytes (128 KiB)
      204. UBI: logical eraseblock size: 126976 bytes
      205. UBI: smallest flash I/O unit: 2048
      206. UBI: VID header offset: 2048 (aligned 2048)
      207. UBI: data offset: 4096
      208. ata2: SATA link down (SStatus 4 SControl 300)
      209. UBI: max. sequence number: 0
      210. UBI: volume 0 ("rootfs") re-sized from 714 to 930 LEBs
      211. UBI: attached mtd0 to ubi0
      212. UBI: MTD device name: "rootfs"
      213. UBI: MTD device size: 118 MiB
      214. UBI: number of good PEBs: 943
      215. UBI: number of bad PEBs: 1
      216. UBI: number of corrupted PEBs: 0
      217. UBI: max. allowed volumes: 128
      218. UBI: wear-leveling threshold: 4096
      219. UBI: number of internal volumes: 1
      220. UBI: number of user volumes: 1
      221. UBI: available PEBs: 0
      222. UBI: total number of reserved PEBs: 943
      223. UBI: number of PEBs reserved for bad PEB handling: 9
      224. UBI: max/mean erase counter: 1/0
      225. UBI: image sequence number: 77738492
      226. UBI: background thread "ubi_bgt0d" started, PID 43
      227. UBIFS: parse sync
      228. UBIFS: start fixing up free space
      229. UBIFS: free space fixup complete
      230. UBIFS: mounted UBI device 0, volume 0, name "rootfs"
      231. UBIFS: file system size: 116690944 bytes (113956 KiB, 111 MiB, 919 LEBs)
      232. UBIFS: journal size: 9023488 bytes (8812 KiB, 8 MiB, 72 LEBs)
      233. UBIFS: media format: w4/r0 (latest is w4/r0)
      234. UBIFS: default compressor: lzo
      235. UBIFS: reserved for root: 0 bytes (0 KiB)
      236. UBIFS error (pid 1): ubifs_read_node: bad node type (255 but expected 9)
      237. UBIFS error (pid 1): ubifs_read_node: bad node at LEB 713:13096, LEB mapping status 1
      238. UBIFS error (pid 1): ubifs_iget: failed to read inode 1, error -22
      239. List of all partitions:
      240. 1f00 120832 mtdblock0 (driver?)
      241. 1f01 4096 mtdblock1 (driver?)
      242. 1f02 2048 mtdblock2 (driver?)
      243. 1f03 1024 mtdblock3 (driver?)
      244. 1f04 512 mtdblock4 (driver?)
      245. 1f05 512 mtdblock5 (driver?)
      246. 1f06 1024 mtdblock6 (driver?)
      247. No filesystem could mount root, tried: ubifs
      248. Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,1)
      249. Rebooting in 180 seconds..
      Display All


      Viele Grüße
      Olaf
    • Kannst Du gegentesten, einfach ein altes Image flashen, das den neuen Bootloader
      noch nicht benötigt.
      Beim VTI glaube ich war das die Version 3.1.
      Andernfalls halt den Bootloader nochmal neu bei uns runterladen
      und nochmal flashen.
      Darauf achten, dass Du wirklich den für Deine Box runterholst
      und nicht versehentlich den der alten Solo oder neuen Duo²
      Radar
    • Hmm.

      Aktuell finde ich im Forum nur VTI 4.0, nichts älteres.

      Vielleicht suche ich auch nicht richtig. Vielleicht kann mich einer mit der Nase drauf drücken?
      Aus irgendwelchen windigen Quellen mag ich das gerade nur ungern herunterladen.

      Beste Grüße
      Olaf
    • Wenn das nicht ganz obskure Seiten sind, kannst das Image schon runterladen.
      Hast Du versucht den Bootloader nochmal zu flashen?
      Eine Clonebox wird es ja nicht sein, auf denen sollen die neueren Images
      nicht funktionieren.
      Radar
    • Hallo!

      Ja, ich habe erneut probiert den Bootloader zu flashen. Mit USB Sticks in verschiedenen Größen, 4,1 und 2 GB. Einen noch kleineren/älteren USB-Stick habe ich bislang noch nicht auftreiben können.

      Den 2 GB Stick habe ich auch schon mit dem "HP Format Tool" Dinges unter Windoze formatiert. Wahlweise FAT und FAT32.

      Das Flashen läuft den Meldungen nach (serielles Log siehe unten) auch jedes Mal erfolgreich ab. Allerdings wird beim anschließenden Booten weiter CFE 2.17 gemeldet, was mir komisch erscheint.Im Netz habe ich ein VTi Image Version 3.1 gefunden. Dies lies sich allerdings nicht erfolgreich flashen und brach ab. Andere Quellen wollen dass ich sinngemäß erst "downloader.exe" runterlade, um anschliessend den Download zu starten ... davon hab ich bislang abgesehen. ;)

      Bislang ist der Status so, dass der Bootloader und die meisten aktuelleren Images sich per USB "erfolgreich" flashen lassen. Beim booten hängen viele Images bei "Starting" fest, mit diversen Fehlern im seriellen Log (u.a. halt mit kernel panic "unable to find VFS"). Am weitesten (mit "VU+ Duo" im LCD-Display) kommen noch die Original Image 5.11 und 6.0. Die finden ihr VFS zwar, aber das Dateisystem scheint nicht lesbar zu sein.

      Das "VU Tool" unter Windows bzw. serielles Flashen habe ich noch nicht probiert. Den Bootloader habe ich bislang auch nur als USB Variante gefunden... vielleicht sollte ich trotzdem die serielle Variante mal probieren? Irgendwo las ich, dass es eine Art "Recovery" Option verbirgt...

      Interessant wäre für mich auch noch die Frage, wie ich die Kernelparameter beim Booten beinflussen kann. Kann man die irgendwie anpassen, ggf. beim Flashen neuer Images? Fände ich hinsichtlich des "rootfs" parameters interessant.

      Source Code

      1. Kernel command line: rootfstype=jffs2 root=/dev/mtdblock0 rw mem=0x8000000 bcmrac=3 console=ttyS0,115200
      2. [...]
      3. JFFS2 warning: (20) jffs2_do_read_inode_internal: Truncating ino #3862 to 549624 bytes failed because it only had 524288 bytes to start with!
      4. Initializing USB Mass Storage driver...
      5. usbcore: registered new driver usb-storage
      6. USB Mass Storage support registered.
      7. NTFS driver 2.1.27 [Flags: R/W MODULE].
      8. jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000000: 0xc131 instead
      9. jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00000004: 0x211d instead


      Zum Glück ist meine Box noch keine 2 Jahre alt, und ich verfüge über eine Rechnung. :) Nun kann ich natürlich das 6.0 Image flashen, und die Box als Garantiefall retunieren. Allerdings würde ich langfristig gerne ein anderes Image einsetzen, weshalb ich gerne wissen würde, was schiefgegangen ist, damit ich nicht wieder in die selbe Falle tappe.


      Viele Grüße
      Olaf
      ---
      Serielles Log vom Flashen des Bootloaders:

      Source Code

      1. BCM73350010
      2. 012
      3. Shmoo Version=1.9
      4. MEMC-00000000 RW=00000011 WW=0000004A G=00000001 R=00000008 W=0000001B
      5. MEMC-00000001 RW=0000000D WW=0000004B G=00000001 R=00000006 W=0000000D #$
      6. 3
      7. COPY CODE
      8. A567
      9. BCM97335B0 CFE v2.17, CFE core v2.12, Endian Mode: Little
      10. Build Date: Thu Sep 29 12:01:32 2011 (shcheong@ncsh)
      11. Copyright (C) Broadcom Corporation.
      12. writing vfd
      13. DDR Freq: 395MHz
      14. CPU speed: 405MHz
      15. Memory Config: 32+16 non-UMA
      16. Device Tech: 1Gb
      17. Total memory: 384MB
      18. Boot Device: NAND
      19. ECC: Hamming
      20. Total flash: 128MB
      21. Initializing USB.
      22. USB: Locating Class 09 Vendor 0000 Product 0000: USB Hub
      23. USB: Locating Class 09 Vendor 0000 Product 0000: USB Hub
      24. CFE initialized.
      25. USB: New device connected to bus 1 hub 1 port 1
      26. USB: Resetting device on bus 1 port 1
      27. USB: Locating Class 08 Vendor 0951 Product 1607: Mass-Storage Device
      28. USBMASS: Unit 0 connected
      29. checking usb
      30. Reading usbdisk0:/vuplus/duo/cfe_cfe_auto.bin: >> Done. 287604 bytes read
      31. Programming...
      32. nand_erase_block 0x1fc00000 0x20000 donenand_erase_block 0x1fc20000 0x20000 donenand_erase_block 0x1fc40000 0x20000 donedone. 287604 bytes written
      33. please remove usb first and reboot
      Display All
    • So,

      die Box läuft wieder! :)

      Auch ich kann nur betonen wie wichtig es ist, den "richtigen" USB Stick zu verwenden!

      Zuvor habe ich viele Versuche unter Linux unternommen, Bootloader/Image auf den Stick zu kopieren. Geklappt hat es erst, als ich *alle* Schreiboperationen auf einen mit HP Tool formatierten Stick unter Windows vorgenommen habe:

      * 2GB Kingston DataTraveler mit HP Format Tool auf FAT32 formatiert.
      * Bootloader unter Windows 7 von NTFS Partition auf USB Stick kopiert (hat recht lange gedauert )
      * Bootloader nochmals geflasht. (Ging sehr schnell)
      * Image unter Windows 7 von NTFS Partition auf USB Stick kopiert (hat mehrere Minuten gedauert)
      * Basis Image 6.0 erfolgreich geflashed (dauerte viel länger als bei allen vorherigen Versuchen, gefühlt 2 Minuten bis das LCD von "Reading from USB" auf "Erasing Flash" wechselte)

      Nach einem Reboot meckerte Windows den USB Stick als "Problembehaftet" an, obwohl ich ihn "sicher entfernt" hatte. Win7 war offensichtlich mit dem alten FAT32 nicht zufrieden , und boot eine Reparatur an. Dies habe ich nicht getan!

      Inzwischen konnte ich auch das Basis Image 7 flashen. Und die Box meldet weiter CFE Version 2.17. Dies ist also KEIN Hinweis darauf, ob das Bootloader Update erfolgreich war oder nicht.

      HTH
      Olaf
    • osfreak wrote:

      Nach einem Reboot meckerte Windows den USB Stick als "Problembehaftet" an, obwohl ich ihn "sicher entfernt" hatte. Win7 war offensichtlich mit dem alten FAT32 nicht zufrieden , und boot eine Reparatur an. Dies habe ich nicht getan!
      Auch Win7 bietet für die kleinen USB-Datensticks (glaube sogar automatisch) die FAT32-Formatierung an.
      Wenn Du den Stick sicher entfernt hast aber letztendlich nicht abgezogen, dann liest Window beim Neustart
      den Stick automatisch wieder ein.
      Auch manche Antivirenprogramme meckern wenn während des Bootvorgangs von Windows ein Datensick gesteckt ist.
      Wie dem auch sei, wenn Du das VTI als Version 3.2.X (oder höher) auf der Box installieren kannst, dann hat die
      den neuen Bootloader intus. Bei den Originalversionen weiss ich nicht so genau (glaube 6.X und höher) ab welcher Version
      der neue Bootloader sein muss.
      Radar
    • (gelöst) VU+ Duo Bootloader Update erfolgreich?

      Hallo!

      Hab inzwischen das aktuelle VTI drauf. Das Bootloader Update war damit am Ende auf jeden Fall erfolgreich - und ich glücklich! D:

      In meinem Fall haben halt USB-Sticks mit anderer (aktuellerer) FAT Formatierung ebenfalls ein "erfolgreiches" Flashen von Bootloadern und Images gemeldet, nur hat die Box danach nicht mehr gebootet.
      Ich nehme für mich die Erkenntnis mit, dass das Flashen der DUO nur sauber funktioniert, wenn der Stick <4GB ist _und_ das richtige (alte) FAT-Format hat. Möglicherweise spielt es auch eine Rolle, dass der gesamte Flash Vorgang mit dem alten Format in "Slow-Speed" ablief.

      Ferner wird immer noch CFE 2.17 gemeldet, was damit kein Indiz ist, ob das Bootloader Update erfolgreich war.

      Dennoch: Thema gelöst! :thumbsup:

      Danke+Gruß

      Olaf