Angepinnt How To: OpenVPN

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Geh doch mal in die Erweiterungen und öffne da das openvpn.
      Mit Multiquickbutton kannst du das Plugin in Reichweite bringen, also auf eine Farbtaste legen.
      MfG
      Überschreiben war richtig. im openvpn-Ordner sollten nun drei Dateien liegen.

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von JoachimPaul ()

    • Das mit dem Multiquickbutton finde ich nicht. Ist doch aber auch nicht so wichtig oder? In dem openvpn Ordner liegen 4 Dateien. Die drei die in der Anleitung stehen und die LOG.txt

      Ich habe nun auch das mit dem telnet gemacht. Wie kann ich nun sehen ob die VPN aktiviert ist oder nicht? Und wenn ich ihn restarte ob sie danach noch aktiviert ist oder nicht.
    • Ins OpenVPN Plugin auf der Box gehen und auf "Show OpenVPN status", dann zeigts obs an oder aus ist.
      TV: LG 42LH3010
      Receiver: VU+ Solo2 + NFS Einbindung
      Netzwerk: AVM Fritzbox 7490 | AVM FRITZ!WLAN Repeater 310 | AVM FRITZ!WLAN Repeater 1750E AP | ZyXEL GS1900-24E Web-Managed Switch | TP-Link TL-SG1005D 5-Port GBit Switch | TP-Link TL-SG1008D 8-Port GBit Switch

      NAS: HP ProLiant N54L Microserver - Xpenology DSM 5.2 - 10 TB | RaspberryPi@Oscam r10136, Sky V13 + MTV Unlimited
    • Multiquickbutton wirst du später schätzen lernen, wenn du mehrere Plugins installiert hast.
      Und: Ja, im openvpn sind 4 Dateien.
      MfG
    • srolle schrieb:

      @FiWo: Hmm, dass eine Verbindung steht, aber nichts reinkommt, spricht eigentlich dafür, dass der Port dicht sein müsste. Da du den aber schon weitergeleitet hast, bin ich ehrlich gesagt auch überfragt. Hast du die .conf noch mal gecheckt? Und hast du mal versucht, ob du mit irgendeinem anderem Dienst extern über das Internet auf deine Box zugreifen kannst?
      @srolle

      Ja.
      Mit anderen Diensten kann ich auf die Box zugreifen.
      Mit meinem privaten VPN über LAN klappt Streaming Super. Auch auf den Androiden.

      Noch einer ne Idee?
    • Hi Fiwo .


      steht dein VPN für die Box.
      Bei mir ja und ich habe folgendes beobachtet weiss aber nicht ob ich dir damit helfe.
      Per hide und Openvpn verbindung aufgebaut. Vorher und nachher ip Check mit dem Opera Browser der Uno gemacht. Klappt
      Danach VPN steht versucht mit Dreamdroid per dyndns auf die box geht nicht obwohl ports zur uno weitergeleitet werden. VPN dann aus gemacht und probiert voila geht. Das war für mich der ultimative Test ob die Box wirklich den Traffic tunnelt und ich von draussen nicht rauf komme.
    • Openvpn mit hide.to

      Hallo,

      ich muss jetzt mal um Rat fragen.
      Die openvpnvti. conf habe ich wie in der pdf angegeben modifizert, log eingefügt, aber ich bekomme die Meldung : OPN fails to start. Please check your openvpnvti.conf
      ich habe alles 3x überprüft, alle Beiträge gelesen, komme aber nicht weiter.

      was mache ich falsch ?

      Hat jemand einen Tip, wo ich ansetzen könnte ?

      Vielen Dank schon mal.
      Gruß
    • Ich habe bei HIDE keine ZIP-Datei laden können. Habe dann mal die openvpn.conf und hide.login (lt. Beitrag 1) erstellt und gestartet (ohne die pem-Datei). Geht natürlich nicht und ich erhalte Fehlermeldungen.

      srolle schrieb:

      FiWo schrieb:

      Wird dir bei VyprVPN ein eigener Client von denen angeboten? Falls ja, müsstest du dort irgendwo die config-Datei angezeigt bekommen.



      Ich sehe bei HIDE kein VyprVPN?? Stehe hier echt auf dem Schlauch ?-(

      Hier mal meine LOG.txt

      Sat Dec 14 08:41:52 2013 OpenVPN 2.1.3 mipsel-oe-linux [SSL] [LZO2] [EPOLL] built on Jun 17 2013
      Sat Dec 14 08:41:52 2013 WARNING: file 'hide.login' is group or others accessible
      Sat Dec 14 08:41:52 2013 WARNING: No server certificate verification method has been enabled. See openvpn.net/howto.html#mitm for more info.
      Sat Dec 14 08:41:52 2013 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
      Sat Dec 14 08:41:52 2013 Cannot load CA certificate file TrustedRoot.pem path (null) (SSL_CTX_load_verify_locations): error:02001002:system library:fopen:No such file or directory: error:2006D080:BIO routines:BIO_new_file:no such file: error:0B084002:x509 certificate routines:X509_load_cert_crl_file:system lib
      Sat Dec 14 08:41:52 2013 Exiting


      So richtig kann ich aber auch nicht aus der Log-Datei erkennen, ob es "nur" an der fehlenden pem liegt?
      Gruss
      schnorpser

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von schnorpser ()

    • Hallo zusammen,
      nach stundenlangen probieren bekomm ich mein vpn nicht zum laufen.
      Ich hoffe ihr könnt mir vielleicht helfen.
      Also ich hab ivacy und hab soweit alle nötigen Dateien erstellt.
      Hier mal meine conf.:
      Spoiler anzeigen
      client
      dev tun
      proto udp
      remote openvpn.ivacy.com 1194
      resolv-retry infinite
      nobind
      persist-key
      persist-tun
      ca /etc/openvpn/ivacy-ca.crt
      cert /etc/openvpn/ivacy-client.crt
      key /etc/openvpn/ivacy-client.key
      tls-auth /etc/openvpn/ivacy-tls.key 1
      ns-cert-type server
      comp-lzo
      verb 3
      auth-user-pass password.txt
      redirect-gateway
      script-security 3
      reneg-sec 0

      log /etc/openvpn/LOG.txt



      Dabei bekomme ich die ganze Zeit in der LOG Datei diese Fehler angezeigt, die ich nicht beseitigt bekomme:

      Spoiler anzeigen
      Sun Dec 15 00:12:29 2013 OpenVPN 2.1.3 mipsel-oe-linux [SSL] [LZO2] [EPOLL] built on Jun 17 2013

      Sun Dec 15 00:12:29 2013 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts

      Sun Dec 15 00:12:29 2013 Cannot load certificate file /etc/openvpn/ivacy-client.crt: error:0906D06C:PEM routines:PEM_read_bio:no start line: error:140AD009:SSL routines:SSL_CTX_use_certificate_file:PEM lib

      Sun Dec 15 00:12:29 2013 Exiting



      Ich hoffe einer weiß rat und könnte mir helfen.
      Danke schonmal.
    • Offenbar ist Deine /etc/openvpn/ivacy-client.crt nicht korrekt.
      Wenn sie im angegebenen Pfad mit diesem Namen existiert und das korrekte Zertifikat vom Anbieter enthält, könnte noch das Dateiformat falsch sein. Die Datei muss UNIX-Zeilenenden haben. Der gute alte Windows-Editor Notepad macht nur Windows-Zeilenenden.

      Mehr Hinweise habe ich leider auch nicht, aber Ferndiagnose ist halt immer schwierig. Bei mir hatte es auch nicht gleich funktioniert, da mein Editor automatisch die Dateidendung ".txt" angehängt hat. Die crt-Dateien hießen also .crt.txt! Hab ich leider nicht gleich gesehen.

      Viele Grüße
      Matthias
    • srolle schrieb:

      @ schorpers und all die, die keine .zip-Datei "finden":


      Ja eben auf den Link komme ich nicht, sieht bei mir auch anders aus (Schritt 6, s. hide1.png. Bei Schritt 8 ist Ende (hide2.png).
      Dateien
      • hide1.png

        (540,95 kB, 216 mal heruntergeladen, zuletzt: )
      • hide2.png

        (587,48 kB, 163 mal heruntergeladen, zuletzt: )
      Gruss
      schnorpser
    • schnorpser schrieb:

      srolle schrieb:

      @ schorpers und all die, die keine .zip-Datei "finden":


      Ja eben auf den Link komme ich nicht, sieht bei mir auch anders aus (Schritt 6, s. hide1.png. Bei Schritt 8 ist Ende (hide2.png).



      Du must als Protokoll schon "OpenVPN" auswählen. Das Tutorial heißt ja schließlich "OpenVPN" und nicht "PPTN-VPN". Ich dachte das wäre offensichtlich, ich werde es aber trotzdem mal in der Anleitung ergänzen. ;P
      "Wir essen Opa!" ----> "Wir essen, Opa!"
      Satzzeichen retten Leben.
    • Ich kann leider kein anderes Protokoll auswählen???? Ich habe mal den Support nun kontaktiert.
      Dateien
      • hide3.png

        (643,14 kB, 158 mal heruntergeladen, zuletzt: )
      Gruss
      schnorpser

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von schnorpser ()

    • @srolle

      Ich muß Dir meinen größten Dank aussprechen.Danke für diese super Anleitung.Ich habe jetzt genau das,nach was ich schon Monate suchte.Mit dem ganzen VPN gedöhns bin ich fast verrückt geworden.
      Ich hatte nur das gleiche Problem wie quadedi mit der .txt Endung des Editors. Jetzt läuft es aber und da ich eh schon länger bei Hide.IO bin war diese Anleitung genau auf mich zugeschnitten.
      Ich nutze allerdings die Plus Mitgliedschaft und bin jetzt am überlegen,ob ich auf Premium umsteigen soll.Jetzt kann ich ja glaube ich nicht gleichzeitig am Pc und über die Vu+ per VPN ins Internet.
      VU+ Solo2

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von MPille ()