Angepinnt How To: OpenVPN

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • How To: OpenVPN

      Hey Leute,

      um der Community mal etwas zurückzugeben, habe ich eine kleine Anleitung zum OpenVPN-Plugin geschrieben.

      Da ich mich damals einen ganzen Tag mühsam durch mehrere Foren lesen musste, um es zum laufen zu bringen, will ich hiermit manchen einiges an Zeit ersparen. ;)

      Wenn irgendwo was unklar sein sollte, bitte bescheid geben.

      PS: Über 600 Downloads und gerade mal 6 "Danke" ist eine krasse Quote. ;|

      srolle
      Dateien
      "Wir essen Opa!" ----> "Wir essen, Opa!"
      Satzzeichen retten Leben.

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von srolle ()

    • Sage schon mal klasse und vielen Dank ohne es ausprobiert zu haben. Im Durchfliegen sieht es aber gut aus und Super veranschaulicht!
    • Gehe ich recht in der Annahme das wenn ich einen VPN-Tunnel einsetze es "sorry" schei*egal" ist
      wenn ich das Mediaportal bis zum Anschlag ausreitze?
      Sprich, schauen was ich möchte ohne die bösen Abmahnanwälte zu fürchten?
      Oder habe ich noch andere Möglichkeiten die sich bis Dato meiner Kenntnis entziehen?


      FiWo

      Edit:
      @srolle

      kannst du die Linux Dateien bitte anhängen?
      Habe ein VPn bei "VyprVPN", leider geht da nur Win, iOS und Android als Installation.
      Linux fehlt gänzlich.

      Thx FiWo

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von FiWo ()

    • Hallo srolle,
      ich habe eigentlich alles hinbekommen. Läuft aber trotzdem leider noch nicht.
      Allerdings habe ich bei hide als Betriebssystem Windows 7 ausgewählt. Nur dann gab es eine Datei zum runterladen.
      Bei Ubuntu sehe ich keine, und Linux wird mir nicht angezeigt.
      Das VTIPlugin OpenVPN sagte: Autostart is set.
      OpenVPN ist not running.
      Die Config habe ich aus deine PDF rauskopiert und per notepad+ eingesetzt. War das ein Fehler?
      Im Plugin gibt es drei Dateien: - hide.login, openvpnvti.con und TrustedRoot.pem
      Eine LogDatei sagtu.a.:
      Wed Nov 6 14:43:37 2013 OpenVPN 2.1.3 mipsel-oe-linux [SSL] [LZO2] [EPOLL] built on Jun 17 2013
      Wed Nov 6 14:43:37 2013 WARNING: No server certificate verification method has been enabled.

      Habe ich eine falsche TrustedRoot.pem, weil ich Windows 7 als Betriebssystem genutzt habe?
      MfG
    • FiWo schrieb:

      Gehe ich recht in der Annahme das wenn ich einen VPN-Tunnel einsetze es "sorry" schei*egal" ist
      wenn ich das Mediaportal bis zum Anschlag ausreitze?
      Sprich, schauen was ich möchte ohne die bösen Abmahnanwälte zu fürchten?
      Oder habe ich noch andere Möglichkeiten die sich bis Dato meiner Kenntnis entziehen?
      Wenn dein VPN-Provider definitiv keine Daten rausgibt bzw. mitloggt, dann ja.
      Noch größere Anonymität würde man mit TOR erzielen, worunter allerdings die Geschwindigkeit deutlich leidet, weshalb es dann für MediaPortal schon wieder nicht in Frage kommt..

      FiWo schrieb:

      kannst du die Linux Dateien bitte anhängen?
      Habe ein VPn bei "VyprVPN", leider geht da nur Win, iOS und Android als Installation.
      Linux fehlt gänzlich.
      Der Inhalt der .conf-Datei habe ich ja zitiert. Die .pem-Datei ist bei jedem individuell, da dort der Zertifizierungsschlüssel enthalten ist. Wird dir bei VyprVPN ein eigener Client von denen angeboten? Falls ja, müsstest du dort irgendwo die config-Datei angezeigt bekommen.


      @JoachimPaul:

      Wird dir wenn du direkt an der Box beim Plugin "Show OpenVPN config file" wählst, der Inhalt deiner .conf-Datei angezeigt? Falls nein, bennene die Datei auch mal in "openvpnvti.conf" um, falls sie wirklich mit ".con" bei dir endet. Direkt zu kopieren ist kein Fehler gewesen, du musst aber bedenken, dass die Zeile "nl.hide.io 3478" angepasst werden muss, wenn du z.b. als Serverstandort Luxemburg wählst.

      Diese Zeile müssen übrigens alle auf ihren VPN-Provider bzw. den gewählten Server anpassen, wenn nicht hide.io als Provider genommen wird!





      "Wir essen Opa!" ----> "Wir essen, Opa!"
      Satzzeichen retten Leben.

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von srolle ()

    • Hallo srolle,
      danke für deine Hinweise.
      Es läuft jetzt alles. Ein Fehler bei mir war: Ich hatte die VPN-Verbindung am Laptop aktiv, als diese Verbindung getrennt war, hat sich das VTI-Plugin sofort erfolgreich gezeigt. D:

      Hier noch ein Hinweis zur Linux-Datei bei Hide: Die findet man unter Serverlist/Details. Ich wollte immer irgendwie über Installation, das war nicht der richtige Weg.
      MfG
    • @srolle
      bei VyprVPN wird mir leider kein Linux (Ubuntu) Client angeboten.
      Sprich, ich habe keine .conf-Datei
      Kann auch nix runterladen. / Fakt, mir fehlen die zwei Datein zum editieren.

      Shit, hab immer noch kein VPN auf der Box.
      Mit dem PC ohne Probs, Client installiert, Neustart und "fun"
      Was mache ich falsch?

      Please help.

      FiWo
    • hi. ich hätte auch noch ein problem.
      habe dank diesem Beitrag erfolgreich eine von Verbindung zu hide.io hergestellt. leider habe ich zwischendurch immer mal wieder Aussetzer bzw. Hänger und es dauert bis wieder was geht. Ist beim stremmen oder so natürlich relativ nervig. hat jemand Erfahrungen damit oder kann mir sagen woran das liegen könnte? ?-(

      super Anleitung übrigens! ;thumbup:
    • He, wenn ich auf Setup VPN gehe, bekomme ich keine .zip mehr. Was soll ich nun machen? Oder braucht mann dafür die Gekaufte Version? Brauche ich überhaupt mehrere VPN's oder reicht eine?

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von rabe0577 ()

    • Also du brauchst einen VPN, der mit dem OpenVPN-Protokoll läuft. Der ist bei hide.io kostenpflichtig und entspricht dem Plus-Paket. Steht übrigens auch alles bei den einzelnen Paketen auf der hide.io-Homepage.
      "Wir essen Opa!" ----> "Wir essen, Opa!"
      Satzzeichen retten Leben.
    • Ah ok. Und wie viele Geräte braucht mann dafür? Reicht das Plus-Paket oder braucht mann das Premium?

      Gibtes das auch irgendwo kostenlos? Oder kosten alle VPN Hoster mit dem sowas geht was?
    • Ich nochmal.

      VPN steht.
      Laut App-Status rennt der Dämon und ist auch im BluePanel.
      Unter Info so zu sehen.
      Daten werden gesendet, leider nicht empfangen.
      D.h.: Mediaportal bleibt Dunkel.
      Anbieter ist YPrVPN.
      Am PC (Win_7) und am Handy (Android) alles ohne Probs.
      Nur an der Solo² mit Vti 6.03 tote Hose.
      Portforwarding ist eingerichtet.
      Was läuft hier falsch?

      FiWo
      Dateien
      • Portfreigabe.jpg

        (34,21 kB, 576 mal heruntergeladen, zuletzt: )
    • @rabe: Das Plus-Paket bei hide.io reicht völlig, jenachdem wie viel Traffic du im Monat brauchst.

      @FiWo: Hmm, dass eine Verbindung steht, aber nichts reinkommt, spricht eigentlich dafür, dass der Port dicht sein müsste. Da du den aber schon weitergeleitet hast, bin ich ehrlich gesagt auch überfragt. Hast du die .conf noch mal gecheckt? Und hast du mal versucht, ob du mit irgendeinem anderem Dienst extern über das Internet auf deine Box zugreifen kannst?
      "Wir essen Opa!" ----> "Wir essen, Opa!"
      Satzzeichen retten Leben.
    • @srolle Habe mir nun das Premium Paket gekauft, und habe es so gemacht ie du es in der Anleitung geschrieben hast. Mit dem OpenVPN Protokoll und so, aber ich bekomme keine .zip zum Download. Bin nur bei dieser Anleitung mit dem Bildern und so...

      Was soll ich nun machen?

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von rabe0577 ()

    • Post Nr. 6 gelesen?
      Ich war auch erleichtert als ich das gefunden hatte.
      MfG

      JoachimPaul schrieb:

      Hier noch ein Hinweis zur Linux-Datei bei Hide: Die findet man unter Serverlist/Details. Ich wollte immer irgendwie über Installation, das war nicht der richtige Weg.
    • Ah super.

      Nun habe ich alles so gemacht. Musste eigentlich die alte openvpnvti.conf mit der neuen überschrieben werden? Das habe ich nun gemacht. Nur wenn ich wie es da steht lange auf die Gelbe Taste drücke kommt da nur das mit der Tonspur wählen und nichts mit OpenVPN.

      Was soll ich da machen?