Open WebIf https

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • gordon55 schrieb:

      gib mal als Adresse im Browser ein : https:// und die ip-der-Box
      was bekommst du als Rückmeldung ?
      Diese Verbindung ist nicht sicher...

      Im Internetexplorer kommt:
      Es besteht ein Problem mit dem Sicherheitszertifikat der Website.

      Das Sicherheitszertifikat dieser Website wurde nicht von einer vertrauenswürdigen Zertifizierungsstelle ausgestellt.
      Das Sicherheitszertifikat dieser Website wurde für eine andere Adresse der Website ausgestellt.

      Die Sicherheitszertifikatprobleme deuten eventuell auf den Versuch hin, Sie auszutricksen bzw. Daten die Sie an den Server gesendet haben abzufangen.

      Muss ich das "Webinterface" installieren? Oder liegt es an der VTI-Version 8.0?

      Bin echt ratlos...
      Danke für eure Hilfe!

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von hgdo ()

    • Nein, das liegt daran dass das Sicherheitszertifikat von der Box selber erstellt und unterschrieben wurde, nicht jedoch von einer der (von den Browsern) anerkannten (und vermeintlich sicheren) sogenannten Root-Zertifizierungsstellen. Diese Warnung kannst du in diesem Fall ignorieren (und dauerhaft bestätigen), weil du ja weisst, dass es sich um deine Box handelt.

      [Oder pro Jahr 50€ - 100€ ausgeben und das Zertifikat unterschreiben lassen (kenne aber die aktuellen Preise nicht) - allerdings müsstest du dann noch dafür sorgen, dass deine Box immer dieselbe IP-Adresse hat - ist meiner Meinung nach den Aufwand definitiv nicht wert.]
    • Vielen Dank, nun komme ich nach ein paar "Sicherheitswarnungen-und Bestätigungen" per ip_der_box auf die VU+ bzw auf das WebInterface. Mein Fehler war, dass ich das "s" bei https vergessen habe...

      Kann man es irgendwie einstellen, dass man nur noch per https auf das WebInterface kommt?

      Zur Zeit geht bei mir immer noch beides.

      Ist das ein Problem, wenn man von außen auf das Webinterface zugreifen will?
    • Inwiefern wäre https unsicher, wenn es nur um TV-Aufnahmen geht, die man eigentlich (ggf. mit einer Sitzungskennung) ressourcenschonender auch plain über Port 8001 oder 8002 streamen könnte?

      Gibt's kein iptables o.ä. auf der Vu+, um Bot-IPs nach einigen Passwortfehlversuchen automatisch stundenweise zu bannen?

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von hgdo ()

    • Autsch - Antwort auf einen Beitrag von 2016 ...

      Trotzdem: ich halte es für wahrscheinlich, dass trotzdem (vielleicht derzeit nicht öffentlich bekannte) Sicherheitslücken ausgenutzt werden können, um deine Box von extern fernzusteuern bzw. zu übernehmen.

      Sprich: eine breite Front offene Ports (Portweiterleitungen) gegen einen einzigen Port (VPN), über den nur stark kryptographisch gesicherter Code passieren darf - was ist sicherer?
    • 2016er gut gelagert wie Wein mit den Jahren vielleicht sogar wertvoller. ;)

      Spaß beiseite, OpenVPN-Server und iptables mit reap kann die Vu+ in aktuellem VTI und hat vielleicht sogar schon jemand beschrieben/Erfahrungen damit?

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von T-E-N ()

    • rdamas schrieb:

      ich halte es für wahrscheinlich, dass trotzdem (vielleicht derzeit nicht öffentlich bekannte) Sicherheitslücken ausgenutzt werden können, um deine Box von extern fernzusteuern bzw. zu übernehmen.
      Verwendet OpenWebif das root-Passwort, kein separat für https einstellbares?

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von hgdo ()

    • Nüscht, solange du nicht das VTi-Debug-Logging aktivierst. Wenn du etwas mitloggen möchtest, ist es es besser, wenn du das selber einbaust. In den OpenWeb-Sourcen nach "suppresslog" suchen.

      Du kannst übrigens problemlos (auf der Konsole mit Linux-Mitteln) einen weiteren (Linux-)User einrichten und mit einem Passwort versehen, der dann das Web-Interface benutzen darf.