Pinned Der Gerätemanager im VTI

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Der Gerätemanager im VTI

      Hi @all,

      hier ist mal eine kleine Zusammenfassung vom Gerätemanager im VTI.

      Was macht der Gerätemanager ?
      Der Gerätemanager ist dafür verantwortlich, dass die angeschlossene Blockgeräte (Festplatten, USB Sticks) gemountet werden. In der Windows Welt kann man das grob mit der Zuordnung eines Laufwerks zu einem Laufwerksbuchstaben vergleichen. In der Linux Welt sind die Laufwerksbuchstaben Verzeichnisse im Dateisystem. Mit dem Gerätemanager wird diese Zuordnung über die Bedienoberfläche von enigma2 ermöglicht.
      Des Weiteren können über den Gerätemanager Festplatten und USB Stick initialisiert und formatiert werden. Beim Initialisieren wird das angeschlossen Gerät neu partitioniert und im Anschluss formatiert. Wenn es sich um eine Festplatte handelt wird auch gleich das Verzeichnis /media/hdd/movie angelegt, in dem bei enigma2 standardmäßig alle Aufnahmen landen. Alle Partitionen auf der Festplatte oder dem Stick werden somit gelöscht. Beim Formatieren wird nur die ausgewählte Partition des Gerätes formatiert. Die restlichen Partitionen bleiben davon unberührt.

      Das Initialisieren muss nur 1x durchgeführt werden wenn das Gerät zum ersten mal an die VU+ angesteckt wird. Nach dem Flashen eines neuen Images ist dies nicht wieder erforderlich.

      Wo findet man den Gerätemanager ?
      Menü => Einstellungen => System => VTI Gerätemanager

      Wie funktioniert der Gerätemanager ?
      Beim ersten Start der Box nach dem Flashen werden die Blockgeräte /dev/sda1 und /dev/sdb1 automatisch gemountet, wenn diese angeschlossen sind.
      /dev/sda1 nach /media/hdd
      /dev/sdb1 nach /media/usb

      /dev/sda1 ist hier das erste angesteckte Gerät und /dev/sdb1 das zweite. Das sdx steht hier für das Gerät und die Ziffer dahinter gibt die Partition an. Die Zuordnung welches Gerät /dev/sda wird und welches /dev/sdb wird von dem Dienst udev festgelegt. Das zuerst erkannte Gerät wird als /dev/sda angelegt und das zweite als /dev/sdb und so weiter.
      Bei VU+ Boxen mit internen Festplatten wird in aller Regel die interne Festplatte immer /dev/sda sein und /dev/sdb ein USB Stick. Bei der VU+ Solo kann dies schon mal umgekehrt sein.

      Werden die Blockgeräte erst nach dem ersten Start angesteckt muss diese Zuordnung manuell gemacht werden in dem der Gerätemanager aufgerufen wird.

      Im Startmenü des Gerätemanagers werden alle erkannten Geräte aufgelistet.



      Mit der gelben Taste (Initialisieren) kann dabei ein noch nicht initialisiertes Gerät für die Verwendung mit der VU+ vorbereitet werden.
      Mit der blauen Taste können die aktuell eingehängten (gemounteten) Geräte angezeigt werden:



      Wählt man jetzt ein Gerät aus und drückt die OK Taste erscheint folgendes Bild:



      Hier sieht man dann wie viele Partitionen auf dem Gerät vorhanden sind und welchem Mountpunkt die einzelnen Partitionen zugeordnet sind.
      In dem Beispiel ist die Festplatte unter dem Laufwerk /media/hdd eingehängt. Erscheint kein Ordnername in Klammern ist die Partition nicht gemountet und steht dem System somit auch nicht zur Verfügung.
      Wird eine Partition ausgewählt und man drückt die OK-Taste werden bereits eingehängte Dateisysteme wieder ausgehängt. Die Anzeige ändert sich dann wie folgt:



      Wird jetzt wieder die OK Taste gedrückt kann die gewählte Partition eingehängt werden. Dafür gibt es dann verschiedene Auswahlmöglichkeiten.



      Wenn der gewünschte Mountpunkt ausgewählt wurde, wird dieser durch die OK-Taste übernommen und die Partition ist eingehängt.
      In aller Regel sollte eine Festplatte nach /media/hdd gemountet werden und USB Sticks nach /media/usb. Wenn keine Festplatte an der VU+ angeschlossen ist würde ich persönlich sogar den USB Stick nach /media/hdd einhängen (somit wird verhindert das durch eine versehentlich gemachte Aufnahme der Flashspeicher voll läuft)

      Wird im Partitionsmenü die gelbe Taste gedrückt kann die jeweils ausgewählte Partition formatiert werden.



      Festplatten sollten mit dem Dateisystem ext3 formatiert werden und USB Sticks mit ext2, da die Schreibzyklen von Flashspeichern begrenzt sind und das ext2 Dateisystem durch das fehlende Dateisystemjournal weniger Schreibzugriffe verursacht.
      Nach erfolgreichem Mounten der einzelnen Partitionen, wird die Konfiguration automatisch gespeichert. Die Einstellungen bleiben auch nach einem Neustart erhalten und müssen nicht mehr getätigt werden.


      Da es bei der VU+ Duo ab und an vorkommt, das diese nicht richtig bootet (komische Zeichen im Display bzw. Box zeigt keine Reaktion auf Aktionen der Fernbedienung) wenn USB Sticks mit einem ext2 oder ext3 Dateisystem angesteckt sind, können USB Sticks mit zwei Partitionen versehen werden. Dies geschieht durch die Auswahl des Sticks im Hauptmenü und anschließender Initialisierung mit der gelben Taste. Bei der Auswahl wählt man hier die Partitionierung 1% / 99%.
      Hier wird dann eine kleine erste Partition und eine große zweite Partition angelegt. Wenn die Initialisierung durchgeführt wurde formatiert man die kleine erste Partition mit dem Dateisystem vfat und die große zweite Partition kann so belassen werden.
      Für die weitere Verwendung muss dann nur die große zweite Partition als /media/usb gemountet werden. Die erste muss nicht eingebunden werden. Durch diesen kleinen Workaround wird das auftretende Bootproblem verhindert.

    • RE: Der Gerätemanager im VTI

      Original von plnick
      hier ist mal eine kleine Zusammenfassung vom Gerätemanager im VTI.


      kleine Zusammenfassung ist gut :tongue:

      Vielen Dank für die sehr ausführliche Beschreibung! :444:
      Gruß, Amosso

      TV: Sony 65"
      AV Receiver: Onkyo TX-NR 708 mit Teufel System 5
    • RE: Der Gerätemanager im VTI

      Ein gutes Tool!
      Danke für deine Mühe.
      Startet bei "Initialisieren" die Formatierung immer noch sofort?
      VU_HD_Series,secondinfobar,Epgrefresh,Oscam-ymod,Moviecut,Cutlisteditor,EMC,Picturecenter,Seagate Pipeline ST3500312CS.
      Seit ext4 (4kB Partitionen), writeback und dir-index(H-Tree) keine Ruckler mehr.
    • RE: Der Gerätemanager im VTI

      Hallo habe kein VTI Gerätemanager im System uß ich eventuell noch etwas installieren
      Peter
    • RE: Der Gerätemanager im VTI

      Hallo,

      könnte mir jemand kurz erklären, wie ich eine Festplatte als HDD3 mounten kann im Gerätemanager? Bei mir geht die Auswahl nur bis HDD2 - und die sind alle schon belegt mit anderen Platten.
      Habs auch schon mit benutzerdefiniert versucht, aber das geht irgendwie auch nicht. Da passiert gar nix.
      Einen Ordner /media/hdd3 hab ich schon erstellt...
      Wieso erscheint der nicht in der Auswahl im Gerätemanager? Woher stammen denn die Einträge dort? Also aus welcher Datei usw?

      Bin etwas ratlos...
      Files
      • screenshot.png

        (26.98 kB, downloaded 191 times, last: )
    • RE: Der Gerätemanager im VTI

      Hab das grad mal mit einem Stick ausprobiert, geht mit Benutzerdefiniert einwandfrei:

      Ach ja: Den Ordner /media/hdd3 darfst Du nicht manuell anlegen, der WIRD angelegt.
      Files
      • hdd3-1.jpg

        (18.98 kB, downloaded 153 times, last: )
      www.exilschwaelmer.de
      Linux ist im Prinzip ein einfaches Betriebssystem.
      Es gehört jedoch Genialität dazu, diese Einfachheit zu erkennen.
      Kein Support via PN.

      The post was edited 1 time, last by Exilschwaelmer ().

    • RE: Der Gerätemanager im VTI

      mach einen eintrag in /etc/fstab

      Source Code

      1. /dev/sda1 /media/hdd auto defaults 0 0


      dev halt anpassen
      Ich hab nur Pech mit Frauen , die erste ist mir abgehauen die zweite nicht.
      Diskutiere niemals mit einem Idioten. Er zieht dich auf sein Niveau herab und schlägt dich dort durch Erfahrung!
    • RE: Der Gerätemanager im VTI

      Ähhhh.... ?( =)

      Dann mache ich wohl irgendwas falsch?!

      Wenn ich auf benutzerdefiniert gehe, dann muss dort doch dann eingetippt werden "/media/hdd3"? Oder muss danach noch ein "/" ?? Das könnte natürlich auch sein...

      Danke fürs Probieren, Exil!
    • RE: Der Gerätemanager im VTI

      dev halt anpassen


      Danke, das würde ich gerne. Aber ich habe im Moment drei Platten und einen Stick dran und die Box fährt jeden Abend komplett herunter und da ist es am nächsten Morgen oft ein Glücksspiel, welches Gerät dann welches sdX erhält.

      Oder kann man das beeinflussen?
    • RE: Der Gerätemanager im VTI

      Original von dmk3000
      "/media/hdd3"

      Genau so hab ich's gemacht, dann Grün gedrückt und fertig.
      www.exilschwaelmer.de
      Linux ist im Prinzip ein einfaches Betriebssystem.
      Es gehört jedoch Genialität dazu, diese Einfachheit zu erkennen.
      Kein Support via PN.
    • RE: Der Gerätemanager im VTI

      Genau so hab ich's gemacht, dann Grün gedrückt und fertig.


      Joooo! =)

      Jetzt hat es geklappt! Hab den Ordner HDD3 unter media noch mal gelöscht und dann zurück in den Gerätemanager und neu probiert. Jetzt ist alles schön!

      Danke vielmals für Deine Hilfe, Exil!! =)
    • Hallo,

      nach flashen von vti 5.0 wird meine Festplatte nicht mehr erkannt!! Der Gerätemanager wird auch nicht mehr angezeigt>!! woran kann das liegen??
    • ich habe auf meiner Solo2 und meine Zero das VTI 9.0.3 laufen.
      Auf der Solo2 ist ein anderer SKIN (aus dem Image) aktiviert, damit gefällt der Gattin die Anzeige des Aufnahme-Balken besser.

      Nun habe ich in die Solo2 eine HDD eingebaut (die auch erkannt wird und initialisiert werden kann) aber ich finde den Gerätemanager nicht.
      Auf der Zero ist der Gerätemanager im VTI Menü (ziemlich unten) zu finden, bei der Solo2 nicht.

      was tun, ohne die ganzen Einstellungen wieder neu machen zu dürfen?

      LG
      Kalle
    • Finde ihn bei mir auch nur unter Menü/VTI/Gerätem.Teste doch nur mal ob mit nem anderen Skin der GM wieder da ist. Im übrigen ist es ganz einfach ALLES im VTI Panel zu sichern und nach dem Flashen wieder herzustellen :thumbup:
      "Wissen ist Macht!!! Nischt wissen,macht nischt...!!!...zumindest bei uns a dar Äberlausitz"

      Gruß NEO660

      Vu+Duo/Duo2/solo2/solo se/Ultimo4K - Image: VTI aktuell -1m-Gibertini Antenne/INVERTO Prem Quattro LNB/JULTEC JRM 0908A- TVs: LG FLATRON M2262D,LG 32 LN5404 - Router: FRITZ!Box 7490,Repeater 1750E,Fritz!Box 7170 als Repeater - Karten: ORF_ICE,HD+01,oscam

      !!! Bin kein Fachmann.Gebe hier nur meinen Wissensstand und meine Lebenserfahrung wieder,das kann auch zu Fehlern führen !!! :thumbup:
    • anbei ein Screenshot in dem man sieht dass kein Gerätemanager vorhanden ist :-/
      ich würde den SKIN gerne wieder zurücksetzen, aber dieser Menüpunkt (Einstellungen\System\Skin) ist ebenfalls nicht mehr da :(
      Ich habe die Favoriten, Plugins und Settings gespeichert, befürchte aber, wenn ich die Settings wieder herstellen würde, wäre es wieder so wie jetzt.


      vti.jpg

      The post was edited 1 time, last by Varaderokalle ().

    • Hast den Gerätemanager ausgeblendet, bitte blaue Taste drücken.
      Alternativ in VTI Panel - Systemwerkzeuge schauen ob es dort den Gerätemanager gibt.
      Wenn auch dort nicht vorhanden, in VTI Panel - Softwaremanager - Systemerweiterungen ob der Devicemanager 2 installiert (grüner Haken) ist.

      Was den Skin angeht, hast vielleicht das Plugin AtileHD deinstalliert?

      Bitte dein Profil um Imageversion und Box ergänzen.
      Nehmt das Leben nicht zu ernst, ihr kommt eh nicht lebend raus!

      The post was edited 1 time, last by ditschi1691 ().

    • ich habe jetzt mal die Solo2 auf VTI 11 upgedatet.
      nun habe ich wieder einen Gerätemanager, die Platte wird erkannt, initialisiert und eingehängt (mal als media\hdd oder auch als media\hdd1), aber nun kommt die Box nicht mehr an meine CIFS Freigabe auf dem NAS und bei Aufnahme sagt der Receiver: keine Festplatte erkannt oder nicht initialisiert.

      Ich glaub da ist irgendwas durcheinander gekommen und ich muss reseten.


      (Profil aktualisiere ich gleich)

      Edit:
      hab das Gerät auf Werkseinstellungen zurück gesetzt und die Grundinstallation durchgehechelt.
      Die Hdd ist nun drin und arbeitet. Symlink auf's NAS geht auch.
      Komisch dass die HDD als Einhängepunkt net/media/cifs112 (das ist die frühere Freigabe meines NAS) eingehängt ist. Mir aktuell aber egal.

      The post was edited 1 time, last by Varaderokalle ().