OpenSSL - VU+ Solo4K

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • OpenSSL - VU+ Solo4K

      Hello, I have a problem with OpenSSL, there is a 6 year old version

      root @ vusolo4k: ~ # openssl version
      OpenSSL 1.0.2a 19 Mar 2015

      It has not been updated yet. Could someone deal with this please? I'm having problems playing and downloading videos from the CZ / SK Archives plugin, it's written a lot about it

      If one of the developers will deal with this from the VTI team, I will be very happy as it is my favorite image.

      The post was edited 1 time, last by schomi: Forum link removed according to board rules! ().

    • könnte man Openssl 1.0.2a mal gehen eine aktuellere version tauschen?

      There's a 1.1.0 somewhere in the depth of the forum as well, please use the search.

      If that doesn't resolve your problems, you probably have old certificates on your box; in that case you'd want to update these as well: Telekom Sport Plugin
      Diskutiere nie mit einem Idioten. Er zieht dich auf sein Niveau runter und schlägt dich mit seiner Erfahrung.

      The post was edited 1 time, last by rdamas ().

    • Exactly.

      VTi is built using libssl1.0.0, and the latest released version of that series should be libssl1.0.2u, with only minor changes to the "s" version. If you don't need new features from libssl1.1.0 that's the library you should install.

      I'm using this version since 2019.

      Display Spoiler

      Source Code

      1. root@vusolo4k:~# openssl version -a
      2. OpenSSL 1.0.2a 19 Mar 2015 (Library: OpenSSL 1.0.2s 28 May 2019)
      3. built on: reproducible build, date unspecified
      4. platform: linux-armv4
      5. options: bn(64,32) rc4(ptr,char) des(idx,cisc,16,long) idea(int) blowfish(ptr)
      6. compiler: gcc -I. -I.. -I../include -fPIC -DOPENSSL_PIC -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -march=armv7-a -Wa,--noexecstack -O3 -Wall -DOPENSSL_BN_ASM_MONT -DOPENSSL_BN_ASM_GF2m -DSHA1_ASM -DSHA256_ASM -DSHA512_ASM -DAES_ASM -DBSAES_ASM -DGHASH_ASM
      7. OPENSSLDIR: "/usr/lib/ssl"
      Diskutiere nie mit einem Idioten. Er zieht dich auf sein Niveau runter und schlägt dich mit seiner Erfahrung.

      The post was edited 2 times, last by rdamas ().

    • Simply look on your box what you have installed now. You can check which packages are installed either looking at the output of opkg list-installed or by exmining the contens of directory /var/lib/opkg/info.

      I guess you need at least the two "lib*" packages, the "openssl" package and the "*-conf", "*-engines" and "*-misc" packages. You surely don't need to install more.
      Diskutiere nie mit einem Idioten. Er zieht dich auf sein Niveau runter und schlägt dich mit seiner Erfahrung.
    • Then try:
      opkg install libcrypto1.0.0_1.0.2s-r0_armv7ahf-vfp-neon.ipk libssl1.0.0_1.0.2s-r0_armv7ahf-vfp-neon.ipk
      opkg install openssl_1.0.2s-r0_armv7ahf-vfp-neon.ipk openssl-conf_1.0.2s-r0_armv7ahf-vfp-neon.ipk
      opkg install openssl-engines_1.0.2s-r0_armv7ahf-vfp-neon.ipk openssl-misc_1.0.2s-r0_armv7ahf-vfp-neon.ipk
      Diskutiere nie mit einem Idioten. Er zieht dich auf sein Niveau runter und schlägt dich mit seiner Erfahrung.

      The post was edited 1 time, last by rdamas ().

    • I installed these seven before you wrote me the answer. I believe it will be okay, and it still doesn't play the videos I need. The OpenSSL version changed to May 28, 2019 so I don't understand why it still won't play.
      Of course, before installation, I had the old certificates uninstalled using the
      opkg remove ca-certificates command; rm -f /etc/ca-certificates.conf*
      Images
      • 2021-10-31_22-22-30.jpg

        47.33 kB, 819×139, viewed 7 times

      The post was edited 4 times, last by hgdo ().