verfügbares Update kommt immer wieder

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • verfügbares Update kommt immer wieder

      New

      Hallo,
      meine Ultimo 4K bietet schreibt mir seit ca. 2 Wochen beim Einschalten, dass ein Update verfügbar sei. Ich öffne dann das vorgeschlagene Menü und bestätige mit grün "aktualisieren".
      Die Pakete (2 Stk.) werden heruntergeladen. Es wird gefragt, ob installiert werden soll. Ich bestätige mir "ja" und das Update beginnt inkl. eines Neustarts. Es steht auch immer oben links Update please wait. Die Box fahrt anschließend runter und startet neu. Dann steht wieder Update ... nachdem das Update scheinbar installiert ist (Balken läuft nicht mehr) erscheint wieder das TV Bild des letzten eingestellten Senders. Nach einigen Minuten kommt erneut die Meldung, dass ein Update verfügbar ist, und ob ich es installieren möchte. :wall1:
      So geht das seit ca 2 Wochen. Auch ein Schutdown mit anshcließendem Neustarrt am Netzschalter bringt keine Abhilfe.
      Kann mir jemand einen Rat geben, wie ich dieses Update so installieren kann, damit es auch installiert ist.
      Vielen Dank schon einmal.
      Gruß Franky
    • New

      @Franky221

      Versuch mal das Update mit Telnet zu machen. Wie das geht, ist hier beschrieben: VTi updaten – Vu+ WIKI

      Ansonsten würde ich einfach die Benachrichtigung und auch die automatische Suche nach Aktualisierungen ausschalten: Einstellungen - System – Vu+ WIKI

      Dann hast du zumindest Ruhe.
      Eventuelle Ratschläge gebe ich nach bestem Wissen und Gewissen aber ohne jede Gewähr. Bei Fragen fragen.
      Tipps:
      Screenshots erstellen VU+ Wiki

      The post was edited 1 time, last by Dibagger ().

    • New

      Ich habe es versucht. Telnet vom PC aus bin ich auf die Ultimo4K gekommen.
      Dann auf der Telnet console (am PC) die beiden Befehhle opkq update und opkq upgrade versucht.
      Meldung war: command not found.
      Muss ich auf der VU+ noch irgend ein Paket für Telnet installieren?
    • New

      opkg nicht opkq!
      Herzlichen Gruß,
      theos2

      ___________________________________________________________________________
      Kein Support per PN

      :319: Vodafone KD mit der VU+ <> Picons für Vodafone KD <> Mirror Glass Picons für Vodafone KD
    • New

      Danke für die Hinweise.
      ;( Ich sag es immer wieder, wer lesen kann ist klar im Vorteil.

      nun hat es geklappt. mit update hat er etliche Dateien herunter geladen und "Inflating" durchgeführt. Was immer da heißt.
      dann habe ich es noch einmal mit Upgrade versucht, worauf eine Error Meldung kam. Ich habe das mal als Bild angehangen.

      In der VU+ habe ich nun die Meldung abgeschaltet. Wenn ich in der Updateliste nachsehe ist das Update für vuplus-wifi-util 16.1.2021 auch bereits aufgelistet.
      Files

      The post was edited 1 time, last by Franky221 ().

    • New

      @Franky221

      "Inflating" heißt, dass das komprimierte File ausgepackt (wörtlich: aufgeblasen) wird.

      Von einem md5sum-Error beim Update war hier in den letzten Wochen mehrfach zu lesen. Einer hat das durch Neuflashen beendet, sonst habe ich jetzt nicht so richtig eine Lösung gefunden. Ich würde das einfach mal 'ne Weile beobachten.

      Wenn du dich selbst mal umsehen möchtest: Einfach mal "update md5sum mismatch" in die Board-Suche eingeben ...
      Eventuelle Ratschläge gebe ich nach bestem Wissen und Gewissen aber ohne jede Gewähr. Bei Fragen fragen.
      Tipps:
      Screenshots erstellen VU+ Wiki

      The post was edited 1 time, last by Dibagger ().

    • New

      Gibt aus meiner Sicht keine einfache Lösung - die md5-Summe steht im Feed-Index-File, welches alle Pakete am Feed indiziert. Such mal in /var/lib/opkg/VTi-all_static nach "Package: update-rc.d" - da findest du den Index-Eintrag für das Paket "update-rc.d" und die md5-Summe zum Paket.

      Und die passt nicht zur md5-Summe des heruntergeladenen Pakets. Das kannst du jetzt wohl nur austricksen, indem du die md5-Summe im Index-File lokal korrigierst. Ansonsten lässt sich das Paket nicht über den Paket-Manager installieren.

      Der Feed-Index muss am Feed selber neu gebaut werden. Warum das bisher nicht passiert ist, ist mir schleierhaft...
    • New

      Vielen Dank an Euch,
      ich werde das jetzt erst mal so lassen. Es funktioniert ja alles.
      Ich bin nicht so versiert, dass ich mich in die Tiefen des System vorwagen könnte um dort Checksummen anzupassen.
      Veileicht klärt sich das ja bei einem späteren Update von allein auf.
      WEnn irgend etwas auf der Box mal nicht mehr funktionieren sollte, werde ich sie auf Werkseinstellungen zurück setzen und das Image neu aufspielen, also nicht aus dem Backup.
      Aber das ist ja wieder einiges an Arbeit, und die mache ich mir erst, wenn was wichtiges nicht funktioniert.
      Vielen Dank
      Franky :331:
    • New

      Franky221 wrote:

      werde ich sie auf Werkseinstellungen zurück setzen und das Image neu aufspielen,
      Das ist doppelt und somit überflüssig, auf Werkseinstellung zurücksetzen kann man sich mMn grundsätzlich sparen, insbesondere wenn man anschliessend h das Image neu aufspielt (damit wird komplett alles im Flash überschrieben).
      ACHTUNG!!!! Hier folgt eine Signatur:


      Die Benutzung der Suche ist NICHT verboten! D:

      "Hilfe!!!" ist kein sinnvoller Titel für einen neuen Thread, ebensowenig "VU+Zero" oder vergleichbares.

      Keine Hilfe ohne ausgefülltes Profil!
      Kein Netzwerksupport bei manueller IP-Adress-Vergabe :-)
      Kein Support bei portforwardings/ Portfreigaben
    • New

      Hallo, da bin ich nochmal,
      Danke Euch Beiden, Ich habe die Box neu geflasht und dann gleich das Update machen lassen. Im Anschluss meine Sicherungen zurück gespielt.
      Nun ist Ruhe und die standigen Update Versuche sind vorbei. Beim Aufruf der Aktualisierungen wird mir gemeldet, dass 0 Pakete verfügbar sind.
      Vielen Dank nochmals.
      :318: