VTI 15.0.0 - Hilfe bei Updates erbeten

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • VTI 15.0.0 - Hilfe bei Updates erbeten

      Liebes Forum,

      ich bräuchte bitte Hilfe beim Updaten meiner VU+ Duo2. Das "BUILD" sagt 30.11.2018, aber offenbar habe ich 15.0.0?

      Version Duo2.jpg

      Sie läuft offenbar auf 15.0.0, aber irgendwie verschwinden die Update-Schaltflächen nicht.

      20210710_113531.jpg

      Oder ich verstehe es nicht richtig? Ich dachte, wenn ich die Box aktualisiere, dann verschwinden auch die Einträge.

      Das tun sie aber nicht. :|

      Und ein Update bleibt sowieso immer stehen, wenn ich auf "Neuigkeiten" klicke:

      Das Paket "Phyton Six" lässt sich nämlich nicht aktualisieren?

      20210710_113504.jpg

      Kann ich die Aktualisierung irgendwie anders durchführen?

      Oder kann ich das alles ignorieren? Offenbar habe ich ja schon 15.0.0, wie man dem ersten Screenshot entnehmen kann?

      Danke für eure Hilfe! :saint:
      Wolf

      The post was edited 2 times, last by Solo_für_UNCLE ().

    • Die Update-Schaltfläche verschwindet nicht, die EInträge in der Liste ebenfalls nicht. Wenn ein "Update" sagt, du bist auf aktuellem Stand, dann bist du auch auf aktuellem Stand.

      Für das Python-six Update versuche es auf der Kommandozeile durchzuführen (da hast du im Zweifel auch die besseren Fehlermeldungen):

      opkg install python-six - vielleicht braucht es eine der Optionen --force-depends, --force-reinstall, --force-overwrite

      Allgemein kannst du ein Update immer in der Konsole durchführen, dort einfach software-update eingeben.
    • @rdamas: Vielen Dank!

      Habe es versucht, aber:

      Collected errors:
      * opkg_install_pkg: Package python-six md5sum mismatch. Either the opkg or the package index are corrupt. Try 'opkg update'.
      * opkg_install_cmd: Cannot install package python-six.
      root@vuduo2:~#

      Auch das "opkg update" habe ich gemacht, hilft aber auch nicht!

      Source Code

      1. root@vuduo2:~# opkg update
      2. Downloading: VTi-all.gz
      3. Inflating: VTi-all
      4. Updated list of available packages in /var/lib/opkg/VTi-all.
      5. Downloading: VTi-all_static.gz
      6. Inflating: VTi-all_static
      7. Updated list of available packages in /var/lib/opkg/VTi-all_static.
      8. Downloading: VTi-mips32el.gz
      9. Inflating: VTi-mips32el
      10. Updated list of available packages in /var/lib/opkg/VTi-mips32el.
      11. Downloading: VTi-mips32el_static.gz
      12. Inflating: VTi-mips32el_static
      13. Updated list of available packages in /var/lib/opkg/VTi-mips32el_static.
      14. Downloading: VTi-softcams_mips32el.gz
      15. Inflating: VTi-softcams_mips32el
      16. Updated list of available packages in /var/lib/opkg/VTi-softcams_mips32el.
      17. Downloading: VTi-thirdparty.gz
      18. Inflating: VTi-thirdparty
      19. Updated list of available packages in /var/lib/opkg/VTi-thirdparty.
      20. Downloading: VTi-thirdparty_mips32el.gz
      21. Inflating: VTi-thirdparty_mips32el
      22. Updated list of available packages in /var/lib/opkg/VTi-thirdparty_mips32el.
      23. Downloading: VTi-vuduo2.gz
      24. Inflating: VTi-vuduo2
      25. Updated list of available packages in /var/lib/opkg/VTi-vuduo2.
      26. Downloading: VTi-vuduo2_static.gz
      27. Inflating: VTi-vuduo2_static
      28. Updated list of available packages in /var/lib/opkg/VTi-vuduo2_static.
      29. root@vuduo2:~# opkg install python-six
      30. Upgrading python-six from 1.9.0-r0 to 1.15.0-r0 on root.
      31. Downloading: python-six_1.15.0-r0_mips32el.ipk
      32. Collected errors:
      33. * opkg_install_pkg: Package python-six md5sum mismatch. Either the opkg or the package index are corrupt. Try 'opkg update'.
      34. * opkg_install_cmd: Cannot install package python-six.
      35. root@vuduo2:~#
      Display All


      Bevor ich es "force" - ist das normal? :)

      Danke Wolf!

      The post was edited 2 times, last by Solo_für_UNCLE ().

    • Nee - Paket ist am Feed kaputt. Da scheint momentan der Wurm drin zu sein.

      Brauchst du das Paket?

      Edit: das Paket am Feed ist so wie es aussieht in Ordnung, nur die Checksumme im Paket-Index ist falsch. Ich hänge das Paket einfach mal an - kannst du von Hand installieren.

      The post was edited 2 times, last by rdamas: Anhang gelöscht - aktuellere Version in #6 ().

    • Source Code

      1. root@vuduo2:/tmp# opkg install /tmp/python-six_1.15.0-r0_mips32el.ipk
      2. Upgrading python-six from 1.9.0-r0 to 1.15.0-r0 on root.
      3. Collected errors:
      4. * opkg_install_pkg: Package python-six md5sum mismatch. Either the opkg or the package index are corrupt. Try 'opkg update'.
      5. * opkg_install_cmd: Cannot install package python-six.
      6. root@vuduo2:/tmp#
      Danke für die Bemühungen, aber offenbar funktioniert das trotzdem nicht.

      Oder mein Befehl ist falsch? :)
    • Hmm - das muss ich nicht verstehen!? Versucht opkg wirklich, das Paket vom Feed zu installieren, obwohl du ihm den Filenamen direkt mit übergibst? Oder vergleicht opkg hier die Checksumme aus seinem Index, obwohl du das File nicht vom Feed installieren willst?

      Sieht für mich nach einem Bug in opkg aus - allerdings ist die Version von opkg auch schon steinalt.

      Abhilfe: installiere die aktuelle Version des Pakets. Angehängt.
      Files
    • Source Code

      1. root@vuduo2:/tmp# opkg install /tmp/python-six_1.16.0-r0_mips32el.ipk
      2. Upgrading python-six from 1.9.0-r0 to 1.16.0-r0 on root.
      3. Removing obsolete file /usr/lib/python2.7/site-packages/six-1.9.0-py2.7.egg-info/PKG-INFO.
      4. Removing obsolete file /usr/lib/python2.7/site-packages/six-1.9.0-py2.7.egg-info/top_level.txt.
      5. Removing obsolete file /usr/lib/python2.7/site-packages/six-1.9.0-py2.7.egg-info/SOURCES.txt.
      6. Removing obsolete file /usr/lib/python2.7/site-packages/six-1.9.0-py2.7.egg-info/dependency_links.txt.
      7. Configuring python-six.
      8. root@vuduo2:/tmp#

      Danke - das hat funktioniert! ;) :D
    • @rdamas, das war echt ein SuperJob, ich bin begeistert, den Befehl "software-update" habe ich doch in all den Jahren glatt wieder vergessen.
      Niemand ist perfekt !