Ultimo4k keine IPv6 Adresse?

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Ultimo4k keine IPv6 Adresse?

      Meine Ultimos4k haben keine IPv6 Adresse mehr. Hab noch nie drauf geachtet, nun kommt aber heute der GF Anschluß und ich bräuchte eine IPv6.
      Meine Zero4k hat eine IPv6.
      Muss hier noch was aktiviert oder konfiguriert werden? IPv6 Kernel Modul ist installiert.
      Was kann ich machen?

      Display Spoiler

      root@vuultimo4k:~# ifconfig
      eth0 Link encap:Ethernet HWaddr 00:1d:ec:10:64:44
      inet addr:172.16.0.50 Bcast:172.16.0.255 Mask:255.255.255.0
      UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
      RX packets:7156 errors:0 dropped:323 overruns:0 frame:0
      TX packets:3469 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0
      RX bytes:9334940 (8.9 MiB) TX bytes:227833 (222.4 KiB)


      lo Link encap:Local Loopback
      inet addr:127.0.0.1 Mask:255.0.0.0
      UP LOOPBACK RUNNING MTU:65536 Metric:1
      RX packets:43 errors:0 dropped:0 overruns:0 frame:0
      TX packets:43 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0
      RX bytes:3172 (3.0 KiB) TX bytes:3172 (3.0 KiB)


      sys0 Link encap:Ethernet HWaddr 00:1d:ec:10:64:44
      UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
      RX packets:7156 errors:0 dropped:0 overruns:0 frame:0
      TX packets:3469 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000
      RX bytes:9463748 (9.0 MiB) TX bytes:241709 (236.0 KiB)



      root@vuzero4k:~# ifconfig
      eth0 Link encap:Ethernet HWaddr 00:1d:ec:12:d8:13
      inet addr:172.16.0.49 Bcast:172.16.0.255 Mask:255.255.255.0
      inet6 addr: 2a02:2450:1021:2be:21d:ecff:fe12:d813/64 Scope:Global
      inet6 addr: fe80::21d:ecff:fe12:d813/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
      RX packets:686671 errors:0 dropped:155556 overruns:0 frame:0
      TX packets:316678 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000
      RX bytes:122515490 (116.8 MiB) TX bytes:230294023 (219.6 MiB)


      lo Link encap:Local Loopback
      inet addr:127.0.0.1 Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING MTU:65536 Metric:1
      RX packets:233 errors:0 dropped:0 overruns:0 frame:0
      TX packets:233 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0
      RX bytes:20810 (20.3 KiB) TX bytes:20810 (20.3 KiB)
      Files
      • ipv6.PNG

        (130.24 kB, downloaded 22 times, last: )
      Nicht jeder Käse kommt aus Holland, mancher kommt aus Bayern... :8)
      „Der Vorteil der Klugheit besteht darin, dass man sich dumm stellen kann. Das Gegenteil ist schon schwieriger.“ K.T.
      „Der Neid ist die aufrichtigste Form der Anerkennung.“ W.B.

      UNVEU!

      The post was edited 1 time, last by Phelbes ().

    • Auch beim Glasfaseranschluss brauchst du die nicht zwingend.

      Von außen wirst du ja vermutlich eh via VPN zugreifen. Das bei IPv6 ans laufen zu bekommen ist etwas komplizierter.

      Aber der Zugriff aufs Heimnetz ist dann relativ einfach und funktioniert dann „intern“ auch wunderbar via IPv4.
    • Das ist schon klar, nur, warum hat die Zero eine IPv6 und die Ultimo nicht?
      Zumal es meines Wissens nach schon mal funktioniert hat.

      Hab jetzt mal in die sysctl folgendes eingetragen:

      Display Spoiler

      net.ipv6.conf.all.disable_ipv6 = 0
      net.ipv6.conf.default.disable_ipv6 = 0
      net.ipv6.conf.lo.disable_ipv6 = 0
      net.ipv6.conf.eth0.disable_ipv6 = 0


      Merkwürdigerweise wird in der FB eine IPv6 Adresse angezeigt bei "ifconfig" aber nicht???
      Nicht jeder Käse kommt aus Holland, mancher kommt aus Bayern... :8)
      „Der Vorteil der Klugheit besteht darin, dass man sich dumm stellen kann. Das Gegenteil ist schon schwieriger.“ K.T.
      „Der Neid ist die aufrichtigste Form der Anerkennung.“ W.B.

      UNVEU!

      The post was edited 1 time, last by hgdo: Bitte keine Doppelpostings ().

    • Jo, "Zielhost nicht erreichbar" ist die Antwort.

      Auf der Zero4k ist alles Ok.

      Auf der Box scheint auch alles vorhanden was gebraucht wird:

      Display Spoiler

      root@vuultimo4k:~# opkg list *ipv6*
      kernel-module-ipv6 - 1:3.14.28-r6.12-vti06 - ipv6 kernel module
      ipv6 kernel module; IPv6 protocol stack for Linux
      kernel-module-ipv6 - 1:3.14.28-r6.12-vti05
      kernel-module-ipv6 - 1:3.14.28-r6.11-vti05
      kernel-module-ipv6 - 1:3.14.28-r5.13-vti04
      kernel-module-ipv6 - 1:3.14.28-r5.12-vti03
      kernel-module-ipv6 - 1:3.14.28-r5.12-vti02
      Nicht jeder Käse kommt aus Holland, mancher kommt aus Bayern... :8)
      „Der Vorteil der Klugheit besteht darin, dass man sich dumm stellen kann. Das Gegenteil ist schon schwieriger.“ K.T.
      „Der Neid ist die aufrichtigste Form der Anerkennung.“ W.B.

      UNVEU!

      The post was edited 1 time, last by Phelbes ().

    • Dass bei opkg was angezeigt wird, heisst ja weder dass du es auch installiert hast noch dass das Modul auch geladen ist.

      Ist es geladen? => lsmod | grep ipv6
      Kannst auch mal unter /proc/sys/net schauen, ob da ein Verzeichnis für ipv6 vorhanden ist.
      Und wenn ja, ob deine sysctl-Einstellungen auch funktionieren:

      cat /proc/sys/net/ipv6/conf/all/disable_ipv6
    • /proc/sys/net kein ipv6 Verzeichnis vorhanden.

      lsmod zeigt:
      Display Spoiler
      root@vuultimo4k:~# lsmod
      Module Size Used by
      bthid 2995 0
      btusb 52035 1
      wakeup_drv 3262 0
      brcmfb 1483 3
      dvb_bcm7444 3606231 98 brcmfb
      dvb_base 7273098 7 dvb_bcm7444
      bcm_event 2903 5 dvb_bcm7444
      procmk 1984 2 dvb_bcm7444,bcm_event
      dhd 203007 0

      root@vuultimo4k:~# opkg install kernel-module-ipv6 - 1:3.14.28-r6.12-vti06
      Package kernel-module-ipv6 (1:3.14.28-r6.12-vti06) installed in root is up to date.
      Was kann ich tun?

      Hab mal mit "modprobe" ipv6 das Modul gestartet:
      Und siehe da, IPv& adresse ist da:
      Display Spoiler
      oot@vuultimo4k:~# ifconfigeth0 Link encap:Ethernet HWaddr 00:1d:ec:10:64:44
      inet addr:172.16.0.xx Bcast:172.16.0.255 Mask:255.255.255.0
      inet6 addr: fe80::xxx:xxx:fe10:xxx/64 Scope:Link
      inet6 addr: 2a02:2450:1021:8142:21d:ecff:fe10:6444/64 Scope:Global
      UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
      RX packets:9697 errors:0 dropped:1139 overruns:0 frame:0
      TX packets:4570 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0
      RX bytes:9971948 (9.5 MiB) TX bytes:346731 (338.6 KiB)
      Vorher noch den Ordner ipv6 von der zero4k kopiert.
      Mal sehen was der Neustart sagt.

      Nach Neustart wird das Modul nicht geladen. Wo muss ich das einstellen?

      Mit dem Eintrag in die bootmisc.sh

      "modprobe ipv6"

      ist auch nach Neustart die ipv6 Adresse vorhanden.

      Display Spoiler

      root@vuultimo4k:~# lsmod
      Module Size Used by
      bthid 2995 0
      btusb 52035 1
      wakeup_drv 3262 0
      brcmfb 1483 3
      dvb_bcm7444 3606231 105 brcmfb
      dvb_base 7273098 7 dvb_bcm7444
      bcm_event 2903 5 dvb_bcm7444
      procmk 1984 2 dvb_bcm7444,bcm_event
      dhd 203007 0
      ipv6 267532 38
      Nicht jeder Käse kommt aus Holland, mancher kommt aus Bayern... :8)
      „Der Vorteil der Klugheit besteht darin, dass man sich dumm stellen kann. Das Gegenteil ist schon schwieriger.“ K.T.
      „Der Neid ist die aufrichtigste Form der Anerkennung.“ W.B.

      UNVEU!

      The post was edited 5 times, last by hgdo ().