2,5 Gb Lan USB-Adapter an VU

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Vielen Dank für deine Hilfe rdamas, 5 Daumen hoch ! :thumbup:
      War auf jeden Fall einen Versuch wert und ich hab sogar was gelernt ;)
      Wenn einer der Admins mitliest oder Mister X anstupsen könnte, wär´s super.
      Auf dem Feed wäre es edel, zum testen reicht auch ne ipk als anhang
    • New

      hm, scheinbar niemand - schade ;(
      ok dann anders rum. Wie kriegt man eine Build-Umgebung hin bzw. was braucht man alles, um ein ipk bzw. Kernel-Modul mit Treiber zu basteln ?
      ja, ich weiß, erstmal mehr Ahnung als ich habe ;)
      Logischerweise eine Linux Umgebung (das könnte Softwaremäßig auf meinem Windoof10 über ne Virtualisierung wie VMware klappen), als nächstes irgendein Tool, um das Ultimo4k-Image zu dekompilieren, dann müßte es möglich sein, die Treiber auszutauschen bzw. den im Image schon vorhandenen r8152-Treiber mit der neueren Version zu überschreiben, Image neu kompilieren und zurück auf die Box... Soweit meine Theorie, vermutlich steckt der Teufel aber wie immer im Detail...
      Die Variante von rdamas über ipk ist sicher die elegantere, aber da hab ich nicht mal ne Vorstellung, wie das gehen könnte...
      Vlt. kann mir jemand zumindest einen groben Überblick verpassen, ob die Theorie einigermaßen stimmt und auf was ich mich da evtl. einlasse.

      Das es verrückt ich, weiß ich schon, andererseits habe ich mich früher auch schon zu ähnlich blöden Aktionen hinreißen lassen (nur für ein Game mal eben einen PC aus rumliegenden Alt-Teilen zusammengeschraubt, weil man das mittels einer Mod im Coop spielen konnte und da brauchte man nen dedicated server).
    • New

      Thema Build-Umgebung: eine Ultra-Kurzfassung steht auf der Webseite code.vuplus.com -> Getting Started.

      Die etwas längere (immer noch Kurzfassung):

      - wenn du eine Virtualisierung benutzen möchtest: Virtualbox funktioniert hier gut.

      - für die VU Build-Umgebung benötigst du sehr wahrscheinlich immer noch ein Ubuntu-16 (das ist schon 4 Jahre alt), bei mir habe ich ein Ubuntu-16.04.5 LTS am laufen. Bei neueren Distros kann es Kompat-Probleme geben. Google-Suche nach "virtualbox ubuntu 16.04 lts image" liefert dir Links zu fertigen Virtualbox-Images.

      - wenn du das am laufen hast, musst du das Meta-Paket "build-essential" installieren (sudo apt-get update; sudo apt-get install build-essential).

      - danach den Anweisungen unter code.vuplus.com -> Getting Started folgen. (Wobei du für das bauen von Paketen für die Ultimo4k natürlich nicht "MACHINE=vusolo4k" benutzen solltest :) )

      - damit würdest du versuchen, ein komplettes Image zu bauen. Lass erst einmal laufen (so ein zwei Stunden), kannst du aber irgendwann abbrechen (Ctrl+C).

      - wenn du "make help" aufrufst, steht da auch, was du machen musst, um einzelne Pakete von Hand zu bauen. Das möchtest du nämlich jetzt mit dem Paket "linux-vuplus-ultimo4k" machen.

      - das kannst du im Prinzip schon mal anfangen, aber du solltest dich vorbereiten und die Sourcen für deinen Treiber irgendwo ausgepackt rumliegen haben, weil du die beiden Files r8152.c und das .h File in den Kernel-Source-Code reinkopieren musst.

      - Verzeichnispfad dafür ist build/vuultimo4k/tmp/work-shared/vuultimo4k/kernel-source/drivers/net/usb/

      - das fertige Kernel-Modul r8152.ko liegt dann im Verzeichnis build/vuultimo4k/tmp/work/vuultimo4k-oe-linux-gnueabi/linux-vuplus-vuultimo4k/linux-vuplus-vuultimo4k-1_3.14.28-r7.12/build/drivers/net/usb/ (modulo Tippfehler). Das kannst du auf deine Ultimo4k in das Verzeichnis /lib/modules/3.14.28-1.12/kernel/drivers/net/usb/ kopieren und dann auf der Box "depmod -a" aufrufen.

      - oder warten, bis das ipk fertig gestellt ist. Das findest du im Verzeichnis build/vuultimo4k/tmp/deploy/ipk/vuultimo4k
    • New

      Hi rdamas, welcome back ;)
      thx für die Aufstellung, ubuntu16.04 lts unter vmware installiert, meta paket ebenso

      rdamas wrote:





      - danach den Anweisungen unter code.vuplus.com -> Getting Started folgen. (Wobei du für das bauen von Paketen für die Ultimo4k natürlich nicht "MACHINE=vusolo4k" benutzen solltest :)


      Die Anweisungen bei code.vu sind wirklich kurz <grins> macht aber nix, man muß ja keinen Roman schreiben...
      Bis dahin lief alles, nach Eingabe "make image MACHINE=vuultimo4k" gings auch gleich munter los mit SubModulpfaden und Klonen etc bis nach der Meldung "The Vuplus SDK is now up to date" und "Building image for vuultimo4k" ne nette Fehlermeldung kam...
      "Error: OE-core´s config sanity checker detected a potential misconfiguration ... blabla ... Please install the following missing utilities: texi2html, makeinfo, svn, gawk, chrpath, sshpass, glib-mkenums.
      Summary:There was 1 Error message shown, returning a non-zero exit code.
      Makefile:154: die Regel für Ziel "image" scheiterte
      make: *** (eckigeklammerauf image eckigeklamerzu) Fehler 1"
      Was paßt da nicht ? Fehlen echt noch utilities oder liegts an was anderem ??? Die Fehlermeldungen sind etwas verwirrend (misconfiguration/missing utilities/non-zero exit code/regel gescheitert)... erinnert ein wenig an Windoof "Es ist ein unerwarteter Fehler aufgetreten <Bluescreen>" - was mich immer kolossal beruhigt, da die restlichen Fehler logischerweise erwartet werden... ;)
    • New

      Die fehlenden Programme befinden sich in den Paketen:
      texi2html, texinfo, gawk, chrpath, subversion, sshpass und libglib2.0-dev

      Alle zusammen mit "sudo apt-get install texi2html texinfo gawk chrpath subversion sshpass libglib2.0-dev" installieren.

      Und sehr gut möglich, dass noch weitere Pakete fehlen - sag einfach Bescheid.
    • New

      Hast du die Sourcen für den Treiber ausgetauscht? Oder sind die Treibersourcen original? Ich frag nur sicherheitshalber ^^ (von der Größe des IPK's sieht das nach ungepatcht aus, ich hätte eher 55k erwartet...)

      The post was edited 2 times, last by rdamas ().

    • New

      Nein, an den Sourcen habe ich nichts geändert. Weißt du aus dem Stegreif wo diese hinkopiert werden müssen?
      Dann würde ich das bitbake nochmal laufen lassen.

      edit:
      Sorry, in Beitrag #44 steht die Antwort.

      The post was edited 1 time, last by bartali ().

    • New

      Morgen zusammen!
      thx bartali, werds in kürze ausprobieren !
      @ rdamas: image habe ich mal durchlaufen lassen, jetzt stimmt nur die ordnerstruktur nicht mit deiner beschreibung überein:
      ...build/vuultimo4k/tmp/work-shared/GCC-4.9.2-r0...
      der teil .../vuultimo4k/kernel-source/drivers/net/usb/ ist gar nicht vorhanden ???
      Falls gewünscht/notwendig, kann ich die Konsolenmeldungen noch anhängen, die hab ich für alle fälle mal in ein textfile kopiert, man weiß ja nie... ;)

      Noch eine prinzipielle Frage, kann man das kernelmodul bzw. das ipk zur besseren unterscheidung vom original umbenennen (z.b. in r8156), oder spielt dann linux/image nicht mehr mit ?
    • New

      Zuerst die Antwort auf die prinzipielle Frage: nein, geht nicht - es sei denn du kannst die Kernelsourcen selber soweit patchen, dass daraus ein komplett neues Modul wird. Auch umbenennen des ipk ist nicht sinnvoll, wenn das Kernelmodul nicht umbenannt wird, weil dadurch ein Konflikt entsteht: der Filename würde von zwei verschiedenen Modulen benutzt.

      Zum ersten Teil: alles an Informationen ist sinnvoll; meine Build-Umgebung existiert schon ein paar Jahre, und ich habe die Verzeichnisse und Namen vom Solo4k-Build abgeleitet.

      Aber: hast du denn schon den Kernel-Build angestossen? (Also "bitbake linux-vuuplus-ultimo4k" aufgerufen?) Die Kernel-Sourcen werden erst dadurch heruntergeladen, wenn sie noch nicht vorhanden sind.

      Was du noch kontrollieren kannst:
      - um herauszufinden, wo du die *.c und *.h Files hinkopieren musst, aus dem build-Verzeichnis heraus aurfufen: find . -name r8152.c - das sollte dir den Pfad zum Kernel-Source-Verzeichnis ausgeben - wenn schon vorhanden und ausgepackt.
    • New

      Ok, sowas hab ich mir schon gedacht, eben den Konflikt wollte ich damit vermeiden.
      <Klick>, Kernel-Build hab ich noch nicht angestoßen, dann fehlen die Kernel-Sourcen und in Folge auch die Verzeichnisse, macht Sinn.
      Mann, Mann, Mann, rdamas ohne dich könnte ich mir die Kugel geben ;)

      noch eins zum testweisen installieren von kernel-modulen... ist es sinnvoll, z.b. dein erstes modul zu deinstallieren, oder ist ein deaktivieren unterm softwaremanager ausreichend ? Ich denke da an die Windoof Treiberinstallation, da ist es manchmal besser, den Treiber zu deinstallieren und dann durch einen neuen zu ersetzen (=saubere Neuinstallation) oder ist da Linux gnädiger zu den Usern ?

      zum Thema .c und .h files - HAHA schon wieder was gelernt, die Suchfunktion von Ubuntu hat mir zwar die Dateien angezeigt, aber nicht die Ordner... ich werde vorschlagen, dich von rdamas zu DR.rdamas zu befördern :thumbsup:
    • New

      Das fertige ipk zu installieren ist der einfachste Weg. Natürlich kannst du auch testweise die fertig kompilierte .ko Datei in das Verzeichnis unter /lib/modules/... kopieren und danach depmod aufrufen (wie ich das oben schon mal so geschrieben habe).

      Theoretisch musst du die Box dafür noch nicht mal neu starten, mit "rmmod r8152" wird ein Kernel-Modul aus dem Kernel entladen, mit "modprobe r8152" wird es geladen. Dass das funktioniert hat, kannst du dann im File /var/log/messages oder durch Aufruf von dmesg kontrollieren.

      Display Spoiler
      Das habe ich alles auch nur parat, weil ich schon seit 1993 Linux benutze. Damals ist mit Slackware die erste Linux-Distribution auf den Markt geworfen worden, und das konfigurieren und compilieren des Kernels gehörte einfach dazu. Genauso wie das jumpern von IRQ's auf deinen ISA-Karten.
    • New

      ich probier zuerst das fertige ipk (ist am einfachsten).
      ok, dann ist linux netter als windoof und ich werde das vorhandene kernel entladen.
      Wenns da hakt, kümmer ich mich weiter um das dekompilieren vom Image, da ist bitbake gerade nicht so kooperativ, wie ich es gerne hätte.

      Zum Spoiler: Dachte ich mir schon, daß du damit länger rumspielst, Daß du die Konsolenbefehle auswendig kannst, hat dich verraten ;)
      Jumper setzen kenn ich auch noch gut, das durfte man am Motherboard machen, wenn ein schnellerer /neuerer Prozessor kam und der Kerntakt angepasst werden mußte und - oh Gott - die IRQ Belegung bei alten PC's... je einen für die Soundkarte,SCSI-Controller undundund <würg>. jaja und dann die Handbücher nur in Englisch und Internet oder Google war noch nicht mal erfunden ... ich kanns nicht mehr genau sagen, aber bei mir gings irgendwann zwischen 1988 und 1992 mit dem ersten PC und DR-DOS los, davor gabs noch ne schöne "Brotkiste" die auf den Namen Commodore128 hörte.
    • New

      Morgen zusammen!
      Das ipk von Bartali hab ich installiert und per modprobe geladen.
      (zur Info, vorher war eine Deinstallation des alten r8152-Moduls von rdamas per Softwaremanager nötig, da sich sonst das ipk nicht installieren lassen wollte "0 Pakete installiert...". Der Versuch mit rmmod r8152 wurde mit "mod nicht geladen" quittiert. Laden per modprobe war dann nötig, da mir der Softwaremanager nach Installation des ipk eine Aktualiserung des Moduls r8152 andrehen wollte, vermutlich mit der originalen Version vom Feed).

      lt. log wurde ein "new interface driver r8152" registriert - Bingo!
      Danach wurde der USB-Adapter angestöpselt, lt. log "usb 2-2: new SuperSpeed USB device number 2 using xhci-brcm" und "usb 2-2: Parent hub missing LPM exit latency info. Power management will be impacted."
      Das Log (Messages) und das Ergebnis von lsusb -v zusammen mit Ip addr list (in einer datei) hänge ich mal an.
      Zusammengefaßt würde ich sagen, USB-Gerät erkannt, Treiber installiert, nur als ethernet device wurde es nicht erkannt. Wir sind nah dran ;)
      Hm, wie soll ich jetzt am besten weiterverfahren? Netzwerkschnittstelle deaktivieren, Neustart und hoffen, daß der USB-Adapter den Job übernimmt ?
      Files
      • messages.txt

        (49.07 kB, downloaded 5 times, last: )
      • lsusb-v.txt

        (49.52 kB, downloaded 4 times, last: )
    • New

      Existiert das File unter /etc/udev/rules.d/50-usb-realtek-net.rules noch?

      Wegen des rules-Files musst du die Box wahrscheinlich doch einmal neu starten.

      Und poste danach auch mal die Ausgabe von "modinfo r8152"

      Netzwerkschnittstelle solltest du erst dann deaktivieren, wenn das neue Device bei den Ethernet-Devices auftaucht (also bei "ip addr list" angezeigt wird). Wenn das Gerät erkannt wurde, musst du dem System wahrscheinlich noch mitteilen, was es damit machen soll (in den Files unter /etc/network) - aber erst einmal musst du dem Device überhaupt eine Adresse von Hand zuweisen können, vorher bringt das nichts.
    • New

      Nein, das File ist weg (wg. Deinstallation vermutlich).

      (modinfo nach Neustart):
      Display Spoiler
      root@vuultimo4k:~# modinfo r8152
      filename: /lib/modules/3.14.28-1.12/kernel/drivers/net/usb/r8152.ko
      license: GPL
      description: Realtek RTL8152/RTL8153 Based USB Ethernet Adapters
      author: Realtek linux nic maintainers <nic_swsd@realtek.com>
      alias: usb:v04E8pA101d*dc*dsc*dp*ic*isc*ip*in*
      alias: usb:v0BDAp8153d*dc*dsc*dp*ic*isc*ip*in*
      alias: usb:v0BDAp8152d*dc*dsc*dp*ic*isc*ip*in*
      depends:
      intree: Y

      vermagic: 3.14.28-1.12 SMP mod_unload ARMv7 p2v8
      Ip addr list:
      Display Spoiler
      1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue
      link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
      inet 127.0.0.1/8 scope host lo
      valid_lft forever preferred_lft forever
      inet6 ::1/128 scope host
      valid_lft forever preferred_lft forever
      2: sys0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq qlen 1000
      link/ether 00:1d:ec:12:e7:0d brd ff:ff:ff:ff:ff:ff
      inet6 fe80::21d:ecff:fe12:e70d/64 scope link
      valid_lft forever preferred_lft forever
      3: eth0@sys0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue
      link/ether 00:1d:ec:12:e7:0d brd ff:ff:ff:ff:ff:ff
      inet 192.168.1.14/24 brd 192.168.1.255 scope global eth0
      valid_lft forever preferred_lft forever
      inet6 fe80::21d:ecff:fe12:e70d/64 scope link
      valid_lft forever preferred_lft forever
      4: wlan3: <BROADCAST,MULTICAST> mtu 1500 qdisc noop qlen 1000
      link/ether 00:90:4c:11:22:33 brd ff:ff:ff:ff:ff:ff
      Hm. da seh ich noch nix

      The post was edited 1 time, last by hgdo ().