2,5 Gb Lan USB-Adapter an VU

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • 2,5 Gb Lan USB-Adapter an VU

      Hallo zusammen,

      Eine Frage an die Technik-Experten...
      beim Stöbern bin ich über einen USB3.0-Lan Adapter gestolpert, der Lan Verbindungen bis 2,5 Gb ermöglicht (Plugable 2,5 Gb USB C und USB nach Ethernet Adapter).
      Hat das schonmal wer ausprobiert bzw. kann das an VU Boxen überhaupt funktionieren ? Im Forum bin ich nicht fündig geworden und soweit ich mich erinnere, war es bei USB-Wlan-Sticks auch immer so eine Sache, da nicht alle Sticks mit der VU bzw. dem Image funktionierten.
      Lt. Beschreibung ist der Adapter mit "modernen OS" incl, Linux ab Kernel 3.2 kompatibel, aber an der Stelle bin ich schon überfragt, weil ich nicht mal weiß, ob bzw. welches Linux-Kernel das VTI 14.x Image verwendet...

      Vielen Dank !
    • Es geht ja um LAN und nicht WLAN. So ein Adapter eher für ein NAS. Vermute, dass im Image gar kein Treiber für so einen Adapter drinnen ist. Wird der TE selbst rausfinden müssen ob das klappt und in Folge hier berichten. Es gibt hier einen Thread in Zusammenhang mit einer solchen 2.5 GB Netzwerkverbindung. Nicht einfach so eine Konfiguration.

      The post was edited 2 times, last by Radar ().

    • Nur weil ein Adapter eine gewisse Geschwindigkeit ermöglich heißt das noch lange nicht dass diese auch umgesetzt wird. Mm blödsinniger Versuch weil keine Treiber vorhanden und der benutzte Chip im Receiver gar nicht darauf ausgelegt ist. Ergo nutzlos,ebenso wie WLAN Sticks die in der Theorie viel versprechen welches aber immer langsamer ist als ein optimales LAN,von mangelhafter Latenz ganz zu schweigen.

      The post was edited 3 times, last by robertx66 ().

    • Das, und dann schau mal, wieviel netto bei GBit-LAN rauskommt. Ich glaube doch im Leben nicht daran, dass über USB mehr transferiert werden kann, wenn selbst der dafür ausgelegte Kanal GBit-LAN nicht an die theoretisch mögliche Grenze kommt.

      Das Geld für dieses Experiment würde ich eher in ein gutes Essen stecken :D
    • rdamas wrote:

      Das, und dann schau mal, wieviel netto bei GBit-LAN rauskommt. Ich glaube doch im Leben nicht daran, dass über USB mehr transferiert werden kann
      Also USB 3.0 (gen 1) hat ja 5Gb/s...also mehr als Puffer um auch 2.5Gbit zu können.
      Kann schon sinn machen wenn man oft Filme von Vu+ nach 2.5Gb/s NAS oder PC kopiert.
      Natürlich muss man schauen wie und ob man da die Treiber ans laufen bekommt...
      Docendo Discimus
      KEIN SUPPORT PER PN!

      Bouquets edtieren? Picons verwalten? Thread (v20.0 released)

      The post was edited 1 time, last by Clemens ().

    • Ja schon, aber das bleibt trotzdem theoretisches Maximum. Ich hab jetzt noch keine Tests auf den 4k-Boxen gemacht, wieviel Brandbreite die USB-3.0 Ports wirklich bereitstellen können, aber ich wäre extrem positiv überrascht, wenn da mehr bei rum kommt als bei GBit.

      Ich gehe davon aus, dass ein SoC bei weitem nicht an das Maximum ran kommt.
    • @Clemens: Bei Verkabelung bis max 4,5 (3?)m Länge ,was zeigt dass alle Theorie grau ist...
      Edit -Im Netz gibts unterschiedliche Angaben zur max Länge der Kabel.

      The post was edited 5 times, last by robertx66 ().

    • Meine UNO$KSE schafft nur 85MB/s und reizt damit den Gigabit-Anschluss nicht mal aus. Was sollte ein 2,5GBit Adapter dann bringen?
      Der limitierende Faktor dürfte die schwache CPU sein, es sei denn die Ultimo4K kommt auf 110MB/s, dann und nur dann könnte man darüber nachdenken.
    • Vielen Dank für die Beiträge ;)

      zu Post 10: Ja das ist die Idee, die Ultimo 4k hat USB 3.0 d.h. es müßte theoretisch mehr an MB/sec durchgehen als durch 1Gb Lan und damit ließe sich doch ein NAS oder ein Wifi 6 Router richtig schön füttern (falls am anderen Ende ebenfalls ein 2,5 Gb vorhanden ist versteht sich).
      zu Post 13: Der limitierende Faktor ist m.M.n. die Netzwerkkarte (genauer gesagt, die eingebaute LAN-Schnittstelle, die keine dedizierte Netzwerkkarte ist) - bei direkter Lan-Verkabelung zum Laptop kam ich max. auch nur bis ca. 90 MB/s, was schon recht ordentlich ist, aber noch Luft nach oben läßt.

      Ist sicher kein Allerweltsproblem, aber hey, bei so einer schönen Bastelbox wie der VU, will man ja auch mal basteln ;)
      <Humormodul an> Und gibts was schöneres als eine absolut perfekte Lösung für ein absolut nicht vorhandenes Problem zu finden ? <Humormodul aus>

      Der Adapter kostet irgendwas mit 40,- €, das kann ich locker verschmerzen, wenn´s nicht klappt. Teuer wirds erst, wenn es tatsächlich hinhaut, dann muß natürlich ein neuer Router oder ein NAS mit passendem 2,5 Gb Anschluß her... ;)
    • Mir ist bei den BCM Chips auch nie ganz klar, wieviel die CPU an der Datenschaufelei beteiligt ist und wieviel durch autonome Hardware, DMA usw abgewickelt wird. Bei den Zugriffen auf die HDD ist sicher noch eine Menge Arbeit bei der CPU, um die ganze Verwaltung der Blöcke zu erledigen. Die Übertragung der Blöcke ins RAM geht sicher per DMA. Beim LAN wird sicher viele durch DMA gemacht USB wird sicher auch DMA nutzen, aber ob das mit 2,5 Gbit wirklich viel schneller als beim 1gbit ist, wäre ein Versuch wert. Ich glaube selber an keine große Steigerung
    • Also ich bin mit Sicherheit kein Linux Performance-Guru, aber wenn ich eine Datei übertrage und mir mit "top" die CPU-Auslastung anschaue, die wegen des smbd bei nahezu 100% liegt, dann ist die CPU hier wohl der limitierende Faktor und ich glaube nicht, dass eine andere Schnittstelle an diesem Zustand was großartig ändert. Aber probiere es gern aus, wenn Du überhaupt einen Treiber für den Adapter findest, der unter VU installiert werden kann.
    • New

      Zur Info an alle Interessierten/Neugierigen ;)
      Bis jetzt kein Erfolg, scheint mir ein Problem mit dem Treiber zu geben.
      USB-Port an der Box mit USB-Festplatte geht, Lankabel/Verbindung zum Router geht, Adapter am PC geht auch, also Hardware funzt alles.

      Bis jetzt hab ich folgendes - erfolglos - getestet (Kurzversion, immer mit kompletten Box-Neustart, Test durchgeführt, Änderung rückgängig gemacht, Box-Neustart):
      -Adapter einfach angesteckt (ok kein Plug&Play)
      -verschiedene Kernel-Module vom Feed installiert (am Feed liegt ein Modul mit dem Namen r8152, der Treiber vom Hersteller und vom Realtek Chipsatz des Adapters heißt r8152.53.56, der im Adapter verwendete Chipsatz ist r8156)
      - Linuxtreiber manuell über /tmp als tar.gz über VTI installiert (liegt jetzt in einem eigenen Verzeichnis namens /r8152_2.13.0 auf der Box in /rootfs - die angehängte _2.13.0 ist die Treiberversion). Da nutzt er vermutlich natürlich nichts, den müßte ich der Box als Kernel-Modul andrehen bzw. irgendwie beim Start der Box laden.

      Da kenn ich mich als Linux-Noob natürlich nicht mehr aus und den vom Feed installierten r8152 konnte ich zwar auf der Box "ausfindig" machen (/rootfs/var/lib/opkg/info), aber das sind keine Treiberdateien, somit scheidet ein "mit dem neuen Treiber überschreiben" auch aus.
      Damit bin ich mit meinem Latein (erstmal) am Ende, wie man so schön sagt.
      Rein spekulativ würde ich sagen, daß die Kernel-Module (=Treiber) vom Feed tief im Image vergraben sind und sich nicht mal eben so ersetzen/austauschen lassen.

      Falls ich irgendwo nen Denkfehler/was übersehen habe, oder jemand noch ne Idee hat, bitte nur her damit.

      Danke!
    • New

      rdamas wrote:

      Das Geld für dieses Experiment würde ich eher in ein gutes Essen stecken
      Nee, keinen Denkfehler, aber definitiv nicht genug Hintergrund-Wissen.

      Was für ein Kernel ist auf der Ultimo4k installiert? Bekommst du in der Shell heraus, indem du dort uname -a eingibst. Ist das der 3.14.28 oder der 4.1.sowieso? Kannst du die tar.gz-Datei entweder mal hier anhängen oder eine URL zum Download angeben? Dann würde ich (weil ich neugierig bin) wenigstens mal versuchen, den Kernel-Treiber zu übersetzen - vielleicht klappt das.