Aufnahmen werden manchmal geteilt. Schreibaussetzer? (HDD: ST2000LM003)

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Aufnahmen werden manchmal geteilt. Schreibaussetzer? (HDD: ST2000LM003)

      Ich habe seit Juni 2019 eine 2TB Festplatte ST2000LM003 verbaut. Ich hatte extra eine HDD ohne SMR ausgewählt aufgrund von Aussetzern bei meiner ursprünglichen ST2000LM015.

      Mit diesen Aussetzern hatte ich bis vor kurzem auch absolut keine Probleme mehr. Nun hat sich seit ein paar Wochen allerdings ein neues Problem eingeschlichen. Es kommt nun immer mal wieder vor, dass ich bei einer Aufnahme plötzlich 2 Dateien habe. Einmal Filmname.ts und dann eine weitere Datei Filmname_001.ts. Es scheint hier so zu sein, dass in diesen Fällen irgendwann die Aufnahme kurz aussetzt und dann in einer 2. Datei fortsetzt. Letzte Woche habe ich die Festplatte mal aufgeräumt und einiges an Platz geschaffen. Es waren vorher noch ca. 400MB von 2000MB frei und jetzt ca 1000MB frei. Seitdem trat das Problem (bisher) nicht mehr auf. Ob es daran liegt oder ob das Zufall ist, kann ich leider nicht sagen. Aber selbst wenn: Irgendwann wird die Festplatte ja wieder etwas voller und ich möchte ein solches Problem für die Zukunft gern irgendwie vermeiden.

      Eine zweite Sache, die ich bereits von Anfang an (sowohl mit ST2000LM015 als auch mit ST2000LM003) hatte, die mich auch immer wieder stört: Ich schneide Aufnahmen mit SmartCutter auf einem Windows-Rechner. Es kommt sehr oft vor, dass die Aufnahmen sich hier nicht öffnen lassen oder dass der Output aus dem Smartcutter korrupt ist (schätzungsweise bei 2-3 von 10 Aufnahmen). Aus diesem Grund nehme ich Filme oft 2-3 mal auf, so dass ich (einigermaßen) sicher gehen kann, dass ich zumindest eine der Aufnahmen problemlos im Smartcutter öffnen und bearbeiten kann. Ist das ein Festplatten- oder ein Vu-Problem?

      Meine Frage ist nun, ob das tatsächlich an der Festplatte liegt und falls ja, was kann ich hier machen? Wieder eine andere Festplatte? Wäre eine SSD besser? Was ist dann aber mit Permanent Timeshift, wird der mir nicht irgendwann die SSD kaputt machen, aufgrund der geringeren Lebensdauer (bzw limiterten Anzahl an Schreibvorgängen) von SSDs?

      Meine Box ist eine Vu+ Duo4K mit der aktuellsten VTI-Version.

      The post was edited 4 times, last by Puddies ().

    • Das ist auch meine Vermutung mit dem Crash des vti. So eine _001.ts wird angelegt, wenn die Datei ohne _001 schon vorhanden ist. Wenn es dann wieder einen Crash während der Aufnahme geben solllte, würde dann sogar eine _002 usw. angelegt, weil das vti nach dem Crash und Neustart die Aufnahme wieder startet und dann diese Namensüberprüfung der Aufnahmen durchführt und dann neue Namen mit _00x erzeugt
    • Puddies wrote:

      ca. 400MB von 2000MB frei und jetzt ca 1000MB frei.
      da hast du dich vermutlich in den Einheiten vertan, oder?

      Ich kenne die filename_001.ts nur von einem GUIneustart durch crash oder ignorieren der Warnung, nicht vom Schreiben auf eine volle HDD.
      ACHTUNG!!!! Hier folgt eine Signatur:


      Die Benutzung der Suche ist NICHT verboten! D:

      "Hilfe!!!" ist kein sinnvoller Titel für einen neuen Thread, ebensowenig "VU+Zero" oder vergleichbares.

      Keine Hilfe ohne ausgefülltes Profil!
    • @GaborDenes Ich meinte natürlich GB, nicht MB. Richtig, danke.

      Unter /media/hdd habe ich tatsächlich ein paar Crashlogs. Leider kann ich nicht sagen, ob das die Zeitpunkte sind, zu denen die Aufnahmen unterbrochen wurden, da ich die Aufnahmen blöderweise schon gelöscht habe. :( Bei der nächsten Unterbrechung würde ich aber mal darauf achten.

      Zu den Crashlogs: Es sind 6 Stück an der Zahl, 4 davon sind einfach leer. Ich habe die beiden nicht leeren hier hochgeladen, kann sich jemand hierauf einen Reim machen, wodurch der Crash jeweils verursacht wurde? Und warum könnten hier 4 leere Crashlogs liegen?
      Files
    • Leere Logs sind hier im Forum meistens im Zusammenhang nicht richtig funktionierendem Netzwerk/NAS Anbindungen zu lesen. NAS eingeschlafen oder so etwas.
      Beim Crash vom 04.08. hast du einen externen Datenträger eingesteckt, dann startet Mytube und hast eine Meldung über falschen API Key erhalten. Nach Bestätigung dieser Meldung gab es dann einen Crash. Scheint ein Einzelfall zu sein.

      Beim Crash vom 21.08. ist das etwas anderes. Hier hat Enigma2 einen Fehler gemeldet. Mehr kann man dazu nicht heraus lesen. Diese Meldung gibt aber öfters in Verbindung mit einem NAS-Laufwerken, genau wie bei leeren Logs.

      Hast du ein NAS als Festplattenersatz konfiguriert?
      Dann würde das mit den bislang zu lesenden Crashlogs zusammen passen.

      EDIT
      Wenn du wie im Post1 geschrieben hast nur die Festplatte eingebaut hast, deutet das auf eine fehlerhafte Festplatte hin.
      Ich habe bei mir eine kleine SSD eingebaut, Timeshift ist darauf aktiv und ich nehme darauf auf. Nach Ende der Aufnahme lasse ich die Aufnahmen auf das NAS verschieben. Bislang damit keine Probleme.
      Rechtschreibfehler sind beabsichtigt, sie fördern ein genaueres Lesen
      Debug Log aktivieren Putty Telnet Screenshots erstellen

      The post was edited 1 time, last by hajeku123 ().

    • Teilweise. Ich nutze das NAS meiner Fritz-Box, allerdings nicht als Festplattenersatz. Diese geteilten Aufnahmen habe ich auf der intern eingebauten HDD, nicht auf der NAS-HDD.

      Zu meinem NAS, falls das die Ursache sein sollte: Seit dem Update auf 7.20 nutzt das Fritz-NAS nicht mehr smb2, sondern smb3.
      Hiermit hatte ich Probleme, wodurch ich in den Settings die Optionen rw,vers=2.0 eingestellt habe (mit rw,vers=3.0 hing sich die Box beim Zugriff aufs NAS immer auf).

      Allerdings habe ich seit dem Setzen der Option rw,vers=2.0 keine Probleme mehr mit dem Zugriff aufs NAS. Für mich schien es eigentlich immer wie geschmiert zu funktionieren.
      Hier ist meine automounts.xml:

      XML Source Code

      1. <?xml version="1.0" ?>
      2. <mountmanager>
      3. <cifs>
      4. <mount>
      5. <active>True</active>
      6. <hdd_replacement>False</hdd_replacement>
      7. <ip>192.168.178.1</ip>
      8. <sharename>FRITZ.NAS</sharename>
      9. <sharedir>FRITZ.NAS</sharedir>
      10. <options>rw,vers=2.0</options>
      11. <username>xxxxx</username>
      12. <password>xxxxx</password>
      13. <mount_system>classic</mount_system>
      14. </mount>
      15. </cifs>
      16. </mountmanager>
      Display All
      Kann das NAS mit den Abstürzen etwas zu tun haben?
    • möglich, stell von Classic auf Autofs um.

      EDIT

      Puddies wrote:

      Eine zweite Sache, die ich bereits von Anfang an (sowohl mit ST2000LM015 als auch mit ST2000LM003) hatte, die mich auch immer wieder stört: Ich schneide Aufnahmen mit SmartCutter auf einem Windows-Rechner. Es kommt sehr oft vor, dass die Aufnahmen sich hier nicht öffnen lassen oder dass der Output aus dem Smartcutter korrupt ist (schätzungsweise bei 2-3 von 10 Aufnahmen). Aus diesem Grund nehme ich Filme oft 2-3 mal auf, so dass ich (einigermaßen) sicher gehen kann, dass ich zumindest eine der Aufnahmen problemlos im Smartcutter öffnen und bearbeiten kann. Ist das ein Festplatten- oder ein Vu-Problem?
      Wenn die Aufnahmen sich normal über die Movielist wiedergeben lassen, ist das mehr ein Problem vom Smartcutter.
      Könntest mal Plugin Autocut installieren, dann "Bearbeiten erzwingen" aktivieren, "Werbung entfernen" deaktivieren und am besten die Ausgabe in ein separates Verzeichnis umleiten. Dann bekommst du nach der Aufnahme automatisch in dem definierten Verzeichnis eine Kopie von der Originalaufnahme mit welcher Smartcutter sollte umgehen können.

      Alternativ auch mal avidemux als Schneideprogramm anschauen
      Rechtschreibfehler sind beabsichtigt, sie fördern ein genaueres Lesen
      Debug Log aktivieren Putty Telnet Screenshots erstellen

      The post was edited 1 time, last by hajeku123 ().

    • Das NFS habe ich Anfang der Woche noch auf automount umgestellt. Es gab zwar bisher keine geteilten Aufnahmen mehr, aber vorgestern gab es nochmal einen Crash-Log, wie ich gerade sehe.
      Kann mir jemand sagen, was er zu bedeuten hat? Die Crashlogs sind ziemlich lang, ich blicke hier nicht wirklich durch, um zu sehen, wobei die Kiste da abgestürzt ist.
      Files

      The post was edited 4 times, last by Puddies ().

    • Liefern beide einen leeren Output.

      edit: mit "autosleep" liefert mir das Kommando folgendes:

      Source Code

      1. root@vuduo4k:~# grep -r "autosleep" /usr/lib/enigma2/*
      2. /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/timers.pyo:autosleepinstandbyonlyt
      3. /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/timers.pyo:autosleepdelayt
      4. /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/timers.pyo:autosleeprepeatR0
      5. /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/timers.py: "autosleepinstandbyonly": str(timer.autosleepinstandbyonly),
      6. /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/timers.py: "autosleepdelay": str(timer.autosleepdelay),
      7. /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/timers.py: "autosleeprepeat": str(timer.autosleeprepeat),
      8. /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/timers.py: autosleepinstandbyonly = "no"
      9. /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/timers.py: if "autosleepinstandbyonly" in request.args.keys():
      10. /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/timers.py: autosleepinstandbyonly = request.args["autosleepinstandbyonly"][0]
      11. /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/timers.py: autosleepdelay = "0"
      12. /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/timers.py: if "autosleepdelay" in request.args.keys():
      13. /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/timers.py: autosleepdelay = request.args["autosleepdelay"][0]
      14. /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/timers.py: autosleeprepeat = "once"
      15. /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/timers.py: if "autosleeprepeat" in request.args.keys():
      16. /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/timers.py: autosleeprepeat = request.args["autosleeprepeat"][0]
      17. /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/timers.py: entry.autosleepinstandbyonly = autosleepinstandbyonly
      18. /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/timers.py: entry.autosleepdelay = int(autosleepdelay)
      19. /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/timers.py: entry.autosleeprepeat = autosleeprepeat
      20. /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/timers.py: minutes = str(timer.autosleepdelay)
      21. /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/timers.py: timer.autosleepdelay = int(time)
      22. /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/timers.py: timer.autosleepdelay = int(time)
      23. /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/timers.py: timer.autosleepdelay = int(time)
      24. /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/timers.py: timer.autosleepdelay = int(time)
      25. /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/timers.py: entry.autosleepdelay = time
      Display All

      The post was edited 2 times, last by Puddies ().

    • Dann weis ich auch nicht, wo "AutoSleep" herkommt.
      Wenn du "autosleep" klein schreibst und danach suchst ist es normal, dass OpenWebif gefunden wird. Das ist aber etwas anderes und hat mit "AutoSleep" nichts zu tun.
      Rechtschreibfehler sind beabsichtigt, sie fördern ein genaueres Lesen
      Debug Log aktivieren Putty Telnet Screenshots erstellen

      The post was edited 1 time, last by hajeku123 ().

    • Ach, ich habe es gefunden. Das AutoSleep ist aus dem IhadTutorial. Das hatte ich mir vor längerer Zeit mal installiert, um mich in die Plugin-Welt einzuarbeiten, habe es aber letztendlich nie gemacht.
      Ich hatte gestern das IhadTutorial gelöscht, um mal aufzuräumen. Daran hatte ich nicht mehr gedacht....

      Das hier ist der Output:

      Source Code

      1. grep -r "AutoSleep" /usr/lib/enigma2/*
      2. /usr/lib/enigma2/python/Plugins/IhadTutorial/lesson_10/plugin.py:config.plugins.AutoSleep = ConfigSubsection()
      3. /usr/lib/enigma2/python/Plugins/IhadTutorial/lesson_10/plugin.py:config.plugins.AutoSleep.enable = ConfigYesNo(default = False)
      4. /usr/lib/enigma2/python/Plugins/IhadTutorial/lesson_10/plugin.py:class AutoSleepScreen(Screen):
      5. /usr/lib/enigma2/python/Plugins/IhadTutorial/lesson_10/plugin.py: if config.plugins.AutoSleep.enable.value:
      6. /usr/lib/enigma2/python/Plugins/IhadTutorial/lesson_10/plugin.py: if config.plugins.AutoSleep.enable.value:
      7. /usr/lib/enigma2/python/Plugins/IhadTutorial/lesson_10/plugin.py: config.plugins.AutoSleep.enable.setValue(False)
      8. /usr/lib/enigma2/python/Plugins/IhadTutorial/lesson_10/plugin.py: config.plugins.AutoSleep.enable.setValue(True)
      9. /usr/lib/enigma2/python/Plugins/IhadTutorial/lesson_10/plugin.py: config.plugins.AutoSleep.enable.save()
      10. /usr/lib/enigma2/python/Plugins/IhadTutorial/lesson_10/plugin.py: session.open(AutoSleepScreen)
      11. /usr/lib/enigma2/python/Plugins/IhadTutorial/lesson_10/plugin.py: print "[AutoSleep] - autostart sleep enabled: ", config.plugins.AutoSleep.enable.getValue()
      12. /usr/lib/enigma2/python/Plugins/IhadTutorial/lesson_10/plugin.py: print "[AutoSleep] - autostop sleep enabled: ", config.plugins.AutoSleep.enable.getValue()
      Display All


      Source Code

      1. grep -r "autostop sleep enabled" /usr/lib/enigma2/*
      2. /usr/lib/enigma2/python/Plugins/IhadTutorial/lesson_10/plugin.py: print "[AutoSleep] - autostop sleep enabled: ", config.plugins.AutoSleep.enable.getValue()

      Könnte das die Ursache für die Abstürze gewesen sein?
    • Vielleicht. Warte halt mal ab, wie es künftig aussieht.

      Das Crashlog sieht für mich gar nicht wie ein Crash aus - im Gegenteil, es scheint alles ordentlich beendet zu werden: EPG wird weggeschrieben, Kanalliste ebenso, Threads werden beendet, ... Alles so, wie wenn du ausgeschaltet hättest.

      Aber ich hab mir jetzt nicht jede einzelne Zeile angesehen.
      Eventuelle Ratschläge gebe ich nach bestem Wissen und Gewissen aber ohne jede Gewähr. Bei Fragen fragen.
      Tipps:
      Screenshots erstellen VU+ Wiki

      The post was edited 1 time, last by Dibagger ().