Transcoding funktioniert nicht auf Ultimo 4k aber auf VU DUO2

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Transcoding funktioniert nicht auf Ultimo 4k aber auf VU DUO2

      Hallo,
      ich habe eine Ultimo 4K und eine VU DUO2. Beide mit aktuellem Image. Streamen funktioniert auf beiden Boxen. Transcoding nur auf der VU DUO2. OpenWebif, Transcoding und Webinterface Parameter sind bei beiden Boxen gleich eingestellt. Beim Transcoding auf der Ultimo 4K bekomme ich kein Bild und die folgende Fehlermeldung mit dem dream Player:

      Screenshot_dream Player.jpg

      Desweiteren gibt der Player mir auch manchmal an, dass das plugin defekt ist. Auch bleibt die Box dann manchmal hängen, was nur mit einem Reboot gelöst werden kann.

      Ich habe das plugin Transcoding deinstalliert/neuinstalliert - kein Effekt.

      Auch DreamDroid zeigt die gleiche Problematik.

      Sonst funktioniert alles!

      Habe ich irgendetwas übersehen? Gibt es noch andere Parameter, die einzustellen sind?
      ich bin jedenfalls mit meinem Latein am Ende.

      Danke und Gruß
      Androfly
    • Wie sieht die Datei /etc/inetd.conf aus ?
      ----------------------------------------------------------------------------------------------------------------------------------------------------------------
      KAPIERVORGANG beendet.

      Zubehör : Philips 46PFL-9705 / 37PFL-9604, Samsung HT-E6759W, Samsung SPF 107H-105P-87H, Qnap TS-251+, Harmony 650, Fritzbox 7490, Cisco WAP4410N, Netgear M4100-D12G, TPLink HS100/HS110/LB110
    • Hochladen klappt nicht, also deshalb Inhalt direkt:

      Display Spoiler
      # /etc/inetd.conf: see inetd(8) for further informations.
      #
      # Internet server configuration database
      #
      # If you want to disable an entry so it isn't touched during
      # package updates just comment it out with a single '#' character.
      #
      # <service_name> <sock_type> <proto> <flags> <user> <server_path> <args>
      #
      #:INTERNAL: Internal services
      #echostream tcp nowait root internal
      #echodgram udp wait root internal
      #chargen stream tcp nowait root internal
      #chargen dgram udp wait root internal
      #discardstream tcp nowait root internal
      #discarddgram udp wait root internal
      #daytimestream tcp nowait root internal
      #daytime dgram udp wait root internal
      #timestream tcp nowait root internal
      #timedgram udp wait root internal
      ftp stream tcp nowait root /usr/sbin/vsftpd vsftpd
      telnet stream tcp nowait root /usr/sbin/telnetd telnetd
      8001 stream tcp nowait root /usr/bin/streamproxy streamproxy
      8002 stream tcp nowait root /usr/bin/transtreamproxy transtreamproxy


      Ich habe diese Datei vom Ultimo mit der von der VU DUO2 verglichen. Sind beide identisch.

      The post was edited 1 time, last by hgdo ().

    • Welches Ergebnis gibts per Telnet mit :

      opkg list-installed *transtream*
      ----------------------------------------------------------------------------------------------------------------------------------------------------------------
      KAPIERVORGANG beendet.

      Zubehör : Philips 46PFL-9705 / 37PFL-9604, Samsung HT-E6759W, Samsung SPF 107H-105P-87H, Qnap TS-251+, Harmony 650, Fritzbox 7490, Cisco WAP4410N, Netgear M4100-D12G, TPLink HS100/HS110/LB110
    • ich bekomme bei der Ultimo:
      root@Ultimo:~# opkg list-installed *transtream*
      enigma2-transtreamproxy - 2.0-r11-vti03+git38+7675a1e-r11-vti03

      und bei der VU DUO2:
      root@vuduo2:~# opkg list-installed *transtream*
      enigma2-transtreamproxy - 2.0-r11-vti03+git38+7675a1e-r11-vti03

      Also auch wieder identisch.

      Ich habe einmal versucht mittels VLC Player die unter der PC Oberfläche VU+ OpenWebif kreierte Streamadresse (stream.m3u8) abzuspielen.
      Es funktioniert - wie gesagt - einwandfrei bei der VU DUO2. Bei der Ultimo gibt mir der transkodierte Stream (Symbol Handy) die folgende Fehlermeldung:

      Ihre Eingabe konnte nicht geöffnet werden:
      VLC kann die Medienadresse 'http://192.168.0.64:8002/1:0:19:2B66:3F3:1:C00000:0:0:0:' nicht öffnen. Für Details bitte im Fehlerprotokoll nachsehen.

      Das VLC Fehlerprotokoll zeigt:
      Display Spoiler
      main debug: processing request item: stream (3).m3u8, node: Wiedergabeliste, skip: 0
      main debug: Creating an input for preparsing 'stream (3).m3u8'
      main debug: rebuilding array of current - root Wiedergabeliste
      main debug: rebuild done - 8 items, index 7
      main debug: starting playback of new item
      main debug: resyncing on stream (3).m3u8
      main debug: stream (3).m3u8 is at 7
      main debug: creating new input thread
      main debug: Creating an input for 'stream (3).m3u8'
      main debug: requesting art for new input thread
      main debug: looking for meta fetcher module matching "any": 1 candidates
      main debug: using timeshift granularity of 50 MiB
      main debug: using timeshift path: C:\Users\Silent\AppData\Local\Temp
      main debug: `file:///D:/stream%20(3).m3u8' gives access `file' demux `any' path `/D:/stream%20(3).m3u8'
      main debug: creating demux: access='file' demux='any' location='/D:/stream%20(3).m3u8' file='D:\stream (3).m3u8'
      main debug: looking for access_demux module matching "file": 15 candidates
      lua debug: Trying Lua scripts in C:\Users\Silent\AppData\Roaming\vlc\lua\meta\fetcher
      lua debug: Trying Lua scripts in C:\Program Files\VideoLAN\VLC\lua\meta\fetcher
      main debug: no access_demux modules matched
      main debug: no meta fetcher modules matched
      main debug: creating access: file:///D:/stream%20(3).m3u8
      main debug: looking for art finder module matching "any": 2 candidates
      main debug: (path: D:\stream (3).m3u8)
      main debug: looking for access module matching "file": 26 candidates
      main debug: using access module "filesystem"
      main debug: looking for stream_filter module matching "prefetch,cache_read": 24 candidates
      cache_read debug: Using stream method for AStream*
      cache_read debug: starting pre-buffering
      cache_read debug: received first data after 0 ms
      main debug: using stream_filter module "cache_read"
      main debug: looking for stream_filter module matching "any": 24 candidates
      playlist debug: found valid M3U playlist
      main debug: using stream_filter module "playlist"
      main debug: stream filter added to 000002988d795f80
      main debug: looking for stream_filter module matching "any": 24 candidates
      main debug: no stream_filter modules matched
      main debug: looking for stream_directory module matching "any": 1 candidates
      main debug: no stream_directory modules matched
      main debug: attachment of directory-extractor failed for file:///D:/stream%20(3).m3u8
      main debug: looking for stream_filter module matching "record": 24 candidates
      main debug: using stream_filter module "record"
      main debug: creating demux: access='file' demux='any' location='/D:/stream%20(3).m3u8' file='D:\stream (3).m3u8'
      main debug: looking for demux module matching "any": 55 candidates
      es debug: cannot peek
      es debug: cannot peek
      es debug: cannot peek
      es debug: cannot peek
      es debug: cannot peek
      mod debug: MOD validation failed (ext=m3u8)
      main debug: using demux module "directory"
      main debug: looking for a subtitle file in D:\
      main debug: looking for meta reader module matching "any": 2 candidates
      lua debug: Trying Lua scripts in C:\Users\Silent\AppData\Roaming\vlc\lua\meta\reader
      lua debug: Trying Lua scripts in C:\Program Files\VideoLAN\VLC\lua\meta\reader
      lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\lua\meta\reader\filename.luac
      lua debug: Trying Lua scripts in C:\Users\Silent\AppData\Roaming\vlc\lua\meta\art
      lua debug: Trying Lua scripts in C:\Program Files\VideoLAN\VLC\lua\meta\art
      lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\lua\meta\art\00_musicbrainz.luac
      main debug: no meta reader modules matched
      main debug: `file:///D:/stream%20(3).m3u8' successfully opened
      main debug: deleting item `stream (3).m3u8'
      main debug: EOF reached
      main debug: incoming request - stopping current input
      main debug: removing module "directory"
      main debug: removing module "record"
      main debug: removing module "playlist"
      main debug: removing module "cache_read"
      main debug: removing module "filesystem"
      lua debug: skipping script (unmatched scope) C:\Program Files\VideoLAN\VLC\lua\meta\art\00_musicbrainz.luac
      main debug: dead input
      lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\lua\meta\art\01_googleimage.luac
      main debug: processing request item: ZDF HD, node: Wiedergabeliste, skip: 0
      main debug: rebuilding array of current - root Wiedergabeliste
      main debug: rebuild done - 8 items, index 7
      main debug: starting playback of new item
      main debug: resyncing on ZDF HD
      main debug: ZDF HD is at 7
      main debug: creating new input thread
      main debug: Creating an input for 'ZDF HD'
      main debug: requesting art for new input thread
      lua debug: skipping script (unmatched scope) C:\Program Files\VideoLAN\VLC\lua\meta\art\01_googleimage.luac
      main debug: using timeshift granularity of 50 MiB
      main debug: using timeshift path: C:\Users\Silent\AppData\Local\Temp
      lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\lua\meta\art\02_frenchtv.luac
      main debug: `1:0:19:2B66:3F3:1:C00000:0:0:0:' gives access `http' demux `any' path `192.168.0.64:8002/1:0:19:2B66:3F3:1:C00000:0:0:0:'
      main debug: creating demux: access='http' demux='any' location='192.168.0.64:8002/1:0:19:2B66:3F3:1:C00000:0:0:0:' file='\\192.168.0.64:8002\1:0:19:2B66:3F3:1:C00000:0:0:0:'
      main debug: looking for access_demux module matching "http": 15 candidates
      main debug: no access_demux modules matched
      main debug: creating access: 1:0:19:2B66:3F3:1:C00000:0:0:0:
      main debug: (path: \\192.168.0.64:8002\1:0:19:2B66:3F3:1:C00000:0:0:0:)
      main debug: looking for access module matching "http": 26 candidates
      http debug: resolving 192.168.0.64 ...
      lua debug: skipping script (unmatched scope) C:\Program Files\VideoLAN\VLC\lua\meta\art\02_frenchtv.luac
      http debug: outgoing request: GET /1:0:19:2B66:3F3:1:C00000:0:0:0: HTTP/1.1 Host: 192.168.0.64:8002 Accept: */* Accept-Language: de User-Agent: VLC/3.0.11 LibVLC/3.0.11 Range: bytes=0-
      lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\lua\meta\art\03_lastfm.luac
      lua debug: skipping script (unmatched scope) C:\Program Files\VideoLAN\VLC\lua\meta\art\03_lastfm.luac
      main debug: no art finder modules matched
      main debug: looking for meta fetcher module matching "any": 1 candidates
      lua debug: Trying Lua scripts in C:\Users\Silent\AppData\Roaming\vlc\lua\meta\fetcher
      lua debug: Trying Lua scripts in C:\Program Files\VideoLAN\VLC\lua\meta\fetcher
      main debug: no meta fetcher modules matched
      main debug: looking for art finder module matching "any": 2 candidates
      lua debug: Trying Lua scripts in C:\Users\Silent\AppData\Roaming\vlc\lua\meta\art
      lua debug: Trying Lua scripts in C:\Program Files\VideoLAN\VLC\lua\meta\art
      lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\lua\meta\art\00_musicbrainz.luac
      lua debug: skipping script (unmatched scope) C:\Program Files\VideoLAN\VLC\lua\meta\art\00_musicbrainz.luac
      lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\lua\meta\art\01_googleimage.luac
      lua debug: skipping script (unmatched scope) C:\Program Files\VideoLAN\VLC\lua\meta\art\01_googleimage.luac
      lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\lua\meta\art\02_frenchtv.luac
      lua debug: skipping script (unmatched scope) C:\Program Files\VideoLAN\VLC\lua\meta\art\02_frenchtv.luac
      lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\lua\meta\art\03_lastfm.luac
      lua debug: skipping script (unmatched scope) C:\Program Files\VideoLAN\VLC\lua\meta\art\03_lastfm.luac
      main debug: no art finder modules matched
      main debug: looking for meta fetcher module matching "any": 1 candidates
      lua debug: Trying Lua scripts in C:\Users\Silent\AppData\Roaming\vlc\lua\meta\fetcher
      lua debug: Trying Lua scripts in C:\Program Files\VideoLAN\VLC\lua\meta\fetcher
      main debug: no meta fetcher modules matched
      main debug: looking for art finder module matching "any": 2 candidates
      qt debug: IM: Setting an input
      lua debug: Trying Lua scripts in C:\Users\Silent\AppData\Roaming\vlc\lua\meta\art
      lua debug: Trying Lua scripts in C:\Program Files\VideoLAN\VLC\lua\meta\art
      lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\lua\meta\art\00_musicbrainz.luac
      lua debug: skipping script (unmatched scope) C:\Program Files\VideoLAN\VLC\lua\meta\art\00_musicbrainz.luac
      lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\lua\meta\art\01_googleimage.luac
      lua debug: skipping script (unmatched scope) C:\Program Files\VideoLAN\VLC\lua\meta\art\01_googleimage.luac
      lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\lua\meta\art\02_frenchtv.luac
      lua debug: skipping script (unmatched scope) C:\Program Files\VideoLAN\VLC\lua\meta\art\02_frenchtv.luac
      lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\lua\meta\art\03_lastfm.luac
      lua debug: skipping script (unmatched scope) C:\Program Files\VideoLAN\VLC\lua\meta\art\03_lastfm.luac
      main debug: no art finder modules matched
      qt debug: IM: Deleting the input
      qt debug: IM: Setting an input
      qt debug: IM: Deleting the input
      qt debug: IM: Setting an input
      http debug: incoming response: HTTP/1.1 503 Service Unavailable Content-Type: text/html Connection: close Accept-Ranges: bytes
      access error: HTTP 503 error
      http debug: querying proxy for 1:0:19:2B66:3F3:1:C00000:0:0:0:
      http debug: no proxy
      http debug: http: server='192.168.0.64' port=8002 file='/1:0:19:2B66:3F3:1:C00000:0:0:0:'
      main debug: net: connecting to 192.168.0.64 port 8002
      main debug: connection succeeded (socket = 3336)
      http debug: sending request: GET /1:0:19:2B66:3F3:1:C00000:0:0:0: HTTP/1.0 Host: 192.168.0.64:8002 User-Agent: VLC/3.0.11 LibVLC/3.0.11 Icy-MetaData: 1
      http debug: HTTP answer code 503
      http error: error: HTTP/1.1 503 Service Unavailable
      main debug: no access modules matched
      main debug: dead input
      qt debug: IM: Deleting the input
      main debug: changing item without a request (current 7/8)
      main debug: nothing to play
      Vielleicht hilft das den Experten weiter.
    • Zeig mal einen Screenshot vom Transcodingplugin der Ultimo - inklusive "Advanced" .
      ----------------------------------------------------------------------------------------------------------------------------------------------------------------
      KAPIERVORGANG beendet.

      Zubehör : Philips 46PFL-9705 / 37PFL-9604, Samsung HT-E6759W, Samsung SPF 107H-105P-87H, Qnap TS-251+, Harmony 650, Fritzbox 7490, Cisco WAP4410N, Netgear M4100-D12G, TPLink HS100/HS110/LB110
    • Eventuell mal zum Test dein Image sichern und anschliessend ein "frisches" VTI flashen (auch nichts mit VTI-Zero entfernen).
      Transcoding dann testen ohne irgendenetwas wiederherzustellen .
      ----------------------------------------------------------------------------------------------------------------------------------------------------------------
      KAPIERVORGANG beendet.

      Zubehör : Philips 46PFL-9705 / 37PFL-9604, Samsung HT-E6759W, Samsung SPF 107H-105P-87H, Qnap TS-251+, Harmony 650, Fritzbox 7490, Cisco WAP4410N, Netgear M4100-D12G, TPLink HS100/HS110/LB110
    • Nach jedem Transkodieren hängt sich die Box auf in dem Masse, dass der aktuelle Kanal zwar weiter aktiv ist und bleibt, aber sobald ich den Kanal wechsel, hängt die Box mit der Info "loading" (aber aktueller Kanal weiter aktiv). Reboot nötig.
      Ich habe das komplette Debugging einmal aktiviert und 2 logs erhalten, die ich angehängt habe.
      Files
    • Ich habe das Basic Image aufgespielt ohne plugins. Damit funktioniert es.
      Ich hatte vorher die plugins und Einstellungen von der VU DUO2 übernommen. Alles hat funktioniert, nur eben das Transkodieren nicht. Wahrscheinlich gibt es damit Inkompatibitäten.
      Danke nochmal für eure Tipps.
    • Die Ursache des Problems wurde gefunden, da nach entsprechender Einstellung der gleiche Fehler auch im Basic Image nachvollziehbar ist.
      Es handelt sich hier wohl um einen "Bug", der bei mir nur auf der Ultimo 4K auftritt, aber nicht auf der VU DUO2.

      Und zwar ist es die Audio Codec Einstellung im Transcoding plugin. Ist "aac" eingestellt funktioniert das Tanscoding. "mpg" oder "mp3" lässt das System wie beschrieben nachvollziehbar abstürzen.

      Mein ursprüngliches Image funktioniert somit einwandfrei mit entsprechender Einstellung.

      Vielleicht kann einer der Experten dies erklären bzw. fixen.

      Gruß
      Androfly
    • New

      Androfly wrote:

      Bin ich der Einzige?
      Nein . ;)

      Aber ein Problem ist es jetzt nicht wirklich !
      AAC ist auch die Standardeinstellung - du hast es aber mit den Einstellungen der Duo2 "überschrieben" .

      Andere Hardware - andere Treiber .
      ----------------------------------------------------------------------------------------------------------------------------------------------------------------
      KAPIERVORGANG beendet.

      Zubehör : Philips 46PFL-9705 / 37PFL-9604, Samsung HT-E6759W, Samsung SPF 107H-105P-87H, Qnap TS-251+, Harmony 650, Fritzbox 7490, Cisco WAP4410N, Netgear M4100-D12G, TPLink HS100/HS110/LB110