Aufnahmen streamen auf iOS / iPadOS inkl. spulen

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Aufnahmen streamen auf iOS / iPadOS inkl. spulen

      Hallo zusammen,

      gibt es eine funktionierende Möglichkeit Aufnahmen von einer VU+-Box auf ein iPad zu streamen inklusive Vorwärts- und Rückwärtsspulen?

      - VU+ ultimo 4k (DVB-S und DVB-T)
      - VTi 14.0.6
      - iPadOS 13.5.1

      Bisherige Versuche:
      - VU+-App: Diese App zu veröffentlichen grenzt an eine Beleidigung des Kunden. Ohne weitere Worte.
      - OpenWebIF per Safari: kein Spulen möglich
      - telly´mode: kein Spulen möglich
      - vuplus TV: kein Spulen möglich
      - e2remotePRO für unsägliche 7,99 Euro: Spuelen funktioniert bei direktem Streaming, aber nicht bei transkodiertem Streaming.
      Tja, leider funktioniert das direkte Streamen aber nicht bei allen Aufnahmen. ALso genauso unbrauchbar.

      Werte Foristen... Ist es tatsächlich so, dass ich inkl. zweitem Tuner fast 600 Euro ausgegeben habe und dafür nichtmal ein Streaming inkl. Spulen möglich ist?

      Vielen Dank für Tipps, wie das doch funzt oder eben danke für die Bestätigung :)
    • Wenn Apps vom IPad nicht deine Zufriedenheit treffen, ist das nicht die Schuld deiner Ultimo, welche lediglich den Stream zur Verfügung stellt.
      Schau dir mal die App VuplusTV an. Die kann auch transcodiert Vorspulen.

      Kannst auch einfach den Link vom Stream kopieren und mit VLC öffnen. Da kannst dann vor und zurück Spulen

      Bei den Aufnahmen, wo das Spulen nicht funktioniert, versuchen, die ap/sc Datei zu rekonstruieren.
      Dazu über Fernbedienung aufrufen
      Menü —> Aufnahmen wiedergeben —> Film auswählen —> Menü —> Reconstruct AP/SC
      Rechtschreibfehler sind beabsichtigt, sie fördern ein genaueres Lesen
      Debug Log aktivieren Putty Telnet Screenshots erstellen
    • Vielen Dank für deine Antwort.
      Naja, wenn der Hersteller eine App ausliefert, sollte diese auch funktionieren...

      hajeku123 wrote:

      Bei den Aufnahmen, wo das Spulen nicht funktioniert, versuchen, die ap/sc Datei zu rekonstruieren.
      Dazu über Fernbedienung aufrufen
      Menü —> Aufnahmen wiedergeben —> Film auswählen —> Menü —> Reconstruct AP/SC
      Ich denke du bist dem Problem auf der Spur. Die Aufnahmen, die nicht zu spulen sind, werden mit einer Größe von 0kb angezeigt. Aufnahmedauer ist hingegen korrekt angezeigt. Bloß, ich scheine zu doof zu sein...

      Mit der Eingabe dieser Tastenreihenfolge lande ich im Menü "Funktion auswählen".
      Ich denke, ich scheitere an "-> Film auswählen ->".
      Wie meinst du das? Cursor auf den Film "legen" und OK-Taste drücken?
      Cursor auf den Film "legen" und "Menü-Taste" drücken?
      Irgendwie sehe ich niergends "Reconstruct AP /SP".

      Edit: Ich nutze das "Enhanced Video Center". Liegt es eventuell daran, dass ich deine Tastenfolge nicht nachvollziehen kann?

      The post was edited 1 time, last by Don Joghurt ().

    • Don Joghurt wrote:

      Cursor auf den Film "legen" und "Menü-Taste"
      genau so.

      Don Joghurt wrote:

      Irgendwie sehe ich niergends "Reconstruct AP/SC“
      Dann fehlt das Plugin, welches über Erweiterungen nachinstallieren kannst
      Rechtschreibfehler sind beabsichtigt, sie fördern ein genaueres Lesen
      Debug Log aktivieren Putty Telnet Screenshots erstellen
    • Don Joghurt wrote:

      Tja, leider funktioniert das direkte Streamen aber nicht bei allen Aufnahmen.
      Das macht mich ein wenig stutzig. Das sollte bei allen funktionieren. Welche Aufnahmen sind davon betroffen?
      Das spulen war und ist auch bei Android ein Problem, da tun sich die ganzen Apps wirklich schwer, wenn es überhaupt funktioniert.
      Gruß

      Jürgen

      _________

      DUO 4K
      DVB-S2x (Seagate ST2000ML015) Fluid Next/Unicable IDLU-32UL40-UNBOO-OPP
      UNO 4K SE
      DVB-S2x (TOSHIBA MQ01ABD1) linearFHD/DUR-Line UK 124
      SOLO 4K DVB-S2 (TOSHIBA MQ01ABD100) Fluid Next/Unicable IDLU-32UL40-UNBOO-OPP

      VTi 14.0.aktuell
      HD02 + V13 (Oscam) im Stinger


    • Beim transcodierten Streamen funktioniert in der Regel das Spulen gar nicht. Das hat etwas damit zu tun, wie das technisch gemacht wird. Es wird von dem abspielenden Client eine neue Streaming-Verbindung aufgemacht mit neuer Startposition, ohne die alte zu schließen was beim direkten Streamen geht, weil die Box einfach einen neuen Stream aufsetzt.
      Beim Transcodieren wird aber eine Hardware in dem Prozessor genutzt, die dann für die erste Verbindung genutzt wird und die dann für eine weitere Verbindung, die der Client an einer neuen Position startet, nicht mehr zur Verfügung steht. Das ist ein prinzipielles Problem.

      Ich habe das mal beim openpli untersucht (ist ja opemnsource ujnd liegt auf github), wie das da geht und habe dann den Prozess für das Transcoding so geändert, dass er erkennt, wann eine neue Verbindung eines Client auf den gleichen Film aufgemacht wird. Damit konnte ich dann die Transcoding-Hardware auf den neuen Stream umsetzen. Bis dann aber die neue Position abgespielt wird, dauert es so 5 Sekunden, weil die Transcoding-Hardware erstmal ihre Puffer füllen muss. Aber besser als dass es gar nicht geht.

      Diese Änderung habe ich auch dem openpli Team bzw dem Author vom Streamproxy (das ist der Serverprozess zum transcodieren Streamen auf der Box bei openpli) über github zur Verfügung gestellt, aber es waren denen glaube ich zu viele Änderungen, weil ich eine Struktur von mehrere Prozessen auf Threads umgestellt habe.

      Diesen Streamproxy wird man aber sicherlich nicht im vti nutzen können.

      Damit konnte ich jedenfalls dieses Problem bei mit lösen . Alo APP nutze ich dafür auf IOS enigmote (weil der das Spulen auch kann) und auf Android dreamplayer oder dreamdroid.
    • bandito1966 wrote:

      Das macht mich ein wenig stutzig. Das sollte bei allen funktionieren. Welche Aufnahmen sind davon betroffen?
      Dass wir nicht aneinander vorbeireden: manche Aufnahmen sind mit e2remotePRO nicht als direkter Stream abspielbar.
      Gleiche Aufnahme transkodiert funzt - aber dann eben ohne spulen.
      Betroffen sind Aufnahmen auf unterschiedlichen Sendern via Sat.

      Meine Frage ist ursprünglich ja die nach Apps, die unter iPadOS spulen können.

      The post was edited 1 time, last by hgdo ().

    • @Don Joghurt

      hajeku123 wrote:

      Schau dir mal die App VuplusTV an. Die kann auch transcodiert Vorspulen.

      Kannst auch einfach den Link vom Stream kopieren und mit VLC öffnen. Da kannst dann vor und zurück Spulen
      Das hast du sicherlich gelesen :)
      Rechtschreibfehler sind beabsichtigt, sie fördern ein genaueres Lesen
      Debug Log aktivieren Putty Telnet Screenshots erstellen

      The post was edited 1 time, last by hajeku123 ().

    • hajeku123 wrote:

      Schau dir mal die App VuplusTV an. Die kann auch transcodiert Vorspulen.


      Kannst auch einfach den Link vom Stream kopieren und mit VLC öffnen. Da kannst dann vor und zurück Spulen

      Bei den Aufnahmen, wo das Spulen nicht funktioniert, versuchen, die ap/sc Datei zu rekonstruieren.
      Dazu über Fernbedienung aufrufen
      Menü —> Aufnahmen wiedergeben —> Film auswählen —> Menü —> Reconstruct AP/SC
      Kann es sein, dass das nur bei Boxen geht, die zwei transcodierte Streams können? Das wäre logisch, weil ja noch ein Transcoder frei ist für die neue Verbindung mit der neuen Position, solange nur ein Client transcodiert streamed. Ich habe das damals so verstanden, dass es bei meiner uno4kse nicht geht, aber bei einer Box mit zwei Transcodern gehen müsste, habe das aber nie probiert, Daher habe ich auch den Streamproxy verändert.
    • Die meisten Boxen haben nur eine Transcoding HW eingebaut haben, uno4k(se), Solo4k, älterer MIPS Boxen,
      Die Duo4k und Ultimo4k haben zwei HW Transcoder.

      Genau diese Boxen mit einer Transcoding HW können nur einen transcodierten Stream bereitstellen und können auch nicht spulen. Wenn dann der zweite transcodierte Stream angefordert wird (das passiert auch beim Spulen aber auf den selben Film), dann geht das nicht.

      Daher vermute ich auch, dass die Duo4k und Ultimo4k bei einem transcodierten Stream spulen können weil die dann immer zwischen den beiden Transcoder HW Einheiten hin und her wechseln. Wenn aber zwei Streams transcodiert laufen, wird es auch dort nicht mehr gehen,
    • aha, wieder was gelernt.
      Muss ich heute Abend mal probieren. Transcodierte Streams nutze ich fast nie.

      Danke

      EDIT
      Demnach sollte die Ultimo4k vom TE das ja können...
      Rechtschreibfehler sind beabsichtigt, sie fördern ein genaueres Lesen
      Debug Log aktivieren Putty Telnet Screenshots erstellen

      The post was edited 2 times, last by hajeku123 ().

    • hajeku123 wrote:

      Schau dir mal die App VuplusTV an. Die kann auch transcodiert Vorspulen.

      Kannst auch einfach den Link vom Stream kopieren und mit VLC öffnen. Da kannst dann vor und zurück Spulen
      VuplusTV spielt die betroffenen Aufnahmen auch nicht ab. Die sind nur am TV und mit e2remote als direkter Stream abspielbar.
      VLC verweigert das Abspielen ohne Meldung.

      What ever - eventuell liegt die Ursache irgendwo am rumspielen am Receiver und experimentieren mit allen möglichen Einstellungen im VTi.
      Aufnahmen der letzten Tage funktionieren ja tadellos.
      Die restlichen Aufnahmen schaue ich halt am TV und gut is :)

      Dankeschön!
    • Moin,

      schau mal nach infusePro. Habe ich an vuduo2 im Einsatz. Nicht zu überbieten bisher....
      Mit Finger im Bild wischen und Vorschau erscheint in kleinem Fenster - für mich genial schnell und sehr gut brauchbar...
      Mit dem schaue ich die *.ts Aufnahmedateien direkt von meinem NAS ab. Dort werden sie direkt als Festplattenersatz in einem Verzeichnis aufgenommen und sind sogar noch während der Aufnahme streambar...
      Grüße

      The post was edited 1 time, last by DiesAS ().