Box schmiert ab wenn Aufnahmen aufgerufen werden sollen

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Box schmiert ab wenn Aufnahmen aufgerufen werden sollen

      Moin liebe Experten.

      Mir ist heute versehentlich die interne Festplatte meiner Uno 4K vollgelaufen. Ich hatte eine Reihe von Aufnahmen im Timer gesetzt und leider vergessen zu schauen, ob noch genug Platz dafür ist. Als ich dann später die Box einschaltete, sagte mir eine Nachricht, dass die Aufnahme abgebrochen wurde, weil vermutlich kein Platz mehr auf der Festplatte sei.

      Ich hab dann übers Netzwerk diverses Zeug auf der Platte entfernt, insbesondere auch die unvollständige Aufnahme. Nun ist wieder ordentlich Platz.

      Doch leider crasht nun die Box jedesmal, wenn ich im Hauptmenü den Punkt "Aufnahmen wiedergeben" anwähle. Ich habe das Crashlog hier angehangen, ich werde leider nicht schlau daraus. Am Ende des Log steht irgendwas von wegen "IndexError: list index out of range", was mir aber leider nichts sagt.

      Hab die Festplatte schon mal aus- und wieder eingehangen und einen Festplattencheck gemacht, der wurde ohne Fehler beendet

      Kann mich jemand auf den richtigen Pfad schubsen? Ich bedanke mich schon mal vorab recht herzlich für eure Tipps!


      Viele Grüße,
      Tom
      Files
    • satt-seher wrote:

      deaktiviere und/oder lösche mal die VTI Datenbank
      Danke für den Tip! Ich hab jetzt erstmal über das Menü "VTI -> Einstellungen - System -> Allgemein (3/5) -> SQL aktivieren" auf "Nein" gesetzt. Und voilá, Ich kann wieder auf die Aufnahmen zugreifen. Danach habe ich die Einstellung wieder auf "Ja" gesetzt. Kann immer noch auf die Aufnahmen zugreifen :huh:

      So weit also nochmal besten Dank für den Tip :thumbsup: Ich hätte aber noch Fragen dazu:

      1. Wird durch das Deaktivieren der SQL-Option wie oben beschrieben die vorhandene SQL-DB gelöscht oder geleert?
      2. Falls Nein: Kann/darf man die vorhandene DB einfach mal löschen? Und wenn ja, wo liegt sie? Oder gibt es zum Löschen ein Plugin?
      3. Oder gibt es sonst ein Tool, mit dem man das System anweisen kann, die DB neu aufzubauen?


      Fragen über Fragen :)


      Viele Grüße, habt einen schönen Vatertag!
      Tom
    • zu 1 nein
      Zu 2 ja, Standard: /media/hdd/vti.db Musst danach aber die Box neu starten
      Zu 3 ja, ist die beste Variante. Menü—> Aufnahmen wiedergeben —nochmal Menü —> Seite2 —> DB löschen und initialisieren
      Danach noch einmal in das Menü gehen und Datenbank aktualisieren komplett ausführen.

      Danach kannst auch in den Einstellungen die SQL Datenbank wieder aktivieren.
      Vorteil: Dann siehst du im EPG, welche Sendungen schon aufgenommen wurden und in den Timer Optionen funktioniert dann auch wieder die Option „nicht aufnehmen, wenn bereits aufgenommen“
      Rechtschreibfehler sind beabsichtigt, sie fördern ein genaueres Lesen
      Debug Log aktivieren Putty Telnet Screenshots erstellen

      The post was edited 1 time, last by hajeku123 ().

    • hajeku123 wrote:

      zu 1 nein
      Zu 2 ja, Standard: /media/hdd/vti.db Musst danach aber die Box neu starten
      Aha, das wusste ich nicht. Und hier habe ich mich auch zu früh gefreut, denn die Box ist beim Neustart wieder abgeschmiert.

      hajeku123 wrote:

      Zu 3 ja, ist die beste Variante. Menü—> Aufnahmen wiedergeben —nochmal Menü —> Seite2 —> DB löschen und initialisieren
      Danach noch einmal in das Menü gehen und Datenbank aktualisieren komplett ausführen.

      Danach kannst auch in den Einstellungen die SQL Datenbank wieder aktivieren.
      Hm, bei mir fehlt im Menü der Punkt "DB löschen und initialisieren". Hab jetzt erstmal "Datenbank aktualisieren - komplett" angestoßen. Kann ich irgendwo sehen, wann dieser Vorgang abgeschlossen ist?
    • kannst ja auch per FTP löschen

      wenn du sie dauerhaft weg haben möchtest, darf übrigens epg share nicht installiert sein, da das die immer wieder erstellt und aktiviert
      Grüße und einen guten Verlauf, der SattSeher

      --------------------------------------------------------------
      Skin: Fluid Next
      Empfang: Astra 19.2

      The post was edited 1 time, last by satt-seher ().

    • :thumbsup: Besten Dank. Die Aufgabe steht bei mir nach 20 Minuten noch bei 0%. Ist das normal? Wie viel Zeit sollte man da veranschlagen? Ich hätte eigentlich gedacht, dass das nach ein paar Minuten erledigt wäre...
    • nein, ist nicht normal. Musst zwingend die DB erst einmal löschen und neu initialisieren.
      Die Komplett Aktualisierung dauert je nach Filmanzahl zwischen 2 und 5 Minuten.
      Wenn du die DB gelöscht, initialisiert hast, und die Komplett Aktualisierung immer noch bei dir nach 5 Minuten bei 0% steht, dann Debug Log aktivieren und nachsehen, bei welcher Aufnahme die Aktualisierung hängen bleibt.

      Ratman wrote:

      Hm, bei mir fehlt im Menü der Punkt "DB löschen und initialisieren".
      Bei mir gibt es den Eintrag.
      screenshot.63.jpg

      kann bei dir auch auf Seite 3 stehen.
      Auch prüfen ob, Menü--> Einstellungen-->System-->Anpassen-->Benutzermodus=Experte eingestellt ist.
      Rechtschreibfehler sind beabsichtigt, sie fördern ein genaueres Lesen
      Debug Log aktivieren Putty Telnet Screenshots erstellen

      The post was edited 1 time, last by hajeku123 ().

    • Nachdem ich die DB manuell gelöscht (da war auch noch so eine mit dem Zusatz "_locked" oder so, ebenfalls gelöscht) und einen Reboot ausgeführt habe, konnte ich zuerst die Filmdatenbank für /media/hdd/ aktualisieren und anschliessend komplett. Hat jeweils unter 2 Minuten gedauert.

      Expertenmodus ist aktiv, habe auch mal testweise wieder auf Standard umgestellt und dann wieder zurück auf Experte, aber der Eintrag zum Löschen der DB fehlt weiterhin:

      Filmlistenmenue.JPG

      Eventuell ist mein Image zu alt?

      Jedenfalls scheint nun wieder alles im Lot zu sein und wenn mir nochmal so ein Fehler begegnet, weiß ich ja dank eurer wie immer kompetenten Hilfe, was zu tun ist :)

      Dank an @hajeku123 @satt-seher und @schmetty2

      The post was edited 2 times, last by hgdo ().

    • Hach ja, ich schiebe sowas immer gerne vor mir her. Eigentlich verwunderlich, denn ich bin beruflich (unter anderem) für die Verteilung der monatlichen Updates für Windows und Adobe auf ca. 16.000 Rechner verantwortlich. Da achte ich immer penibel darauf, dass auch alle Rechner zeitnah brav alles einspielen. Nur bei meinen VU+ Boxen schludere ich damit rum :think1: