[Erledigt] Aufnahmen auf Fileebene mit VLC anschauen

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [Erledigt] Aufnahmen auf Fileebene mit VLC anschauen

    Moin,

    ich würde gerne die Aufnahmen auf Fileebene (FTP) am Win10 1803 mit dem VLC direkt anschauen. Allerdings erhalte ich immer folgende Fehlermeldung:


    VLC wrote:

    Ihre Eingabe konnte nicht geöffnet werden:
    VLC kann die Medienadresse 'ftp://root@192.168.2.6/media/hdd/movie/20190818%202007%20-%20kabel%20eins%20HD%20-%20Mein%20Revier.ts' nicht öffnen. Für Details bitte im Fehlerprotokoll nachsehen.
    und


    VLC wrote:

    ftp error: response failure


    Über WebIF funktioniert es ohne Probleme. Aber über die Explorerebene leider nicht.
    VLC loopt dann immer bei der Usernameabfrage.

    Mache ich etwas falsch?
    Ist das überhaupt unterstützt?
    Sind weitere Portfreigaben notwendig...?

    Danke

    The post was edited 1 time, last by Heba ().

  • Wenn ich dort einen Film doppelt anklicke öffnet sich der VLC und der Film wird abgespielt. Irgendwann Mal in Windows festgelegt, dass ts-Dateien mit VLC abgespielt werden sollen. Kannst aber auch VLC öffnen und den Film im Verzeichnis der Festplatte dann auswählen.
  • Das ist doch nicht das Thema...

    Es kommt ein Fehler, so wie ich das mache. Das ist das Thema.
    Ich weiss nicht was ich gegen den Fehler machen soll.

    Update: Öffne ich den Link oben direkt aber mit Schema: User:password@192.xxxxxx klappts es.
    Das PW wird wohl nicht rausgecached? Oder was kann der Fehler sein?

    The post was edited 1 time, last by hgdo ().

  • Heba wrote:

    Die Platten sind eingebunden. Beim öffnen der .ts (Drag & Drop in VLC) kommt jedoch der Fehler.
    Wie hast Du die Platten denn eingebunden?
    Normalerweise werden die Platten per CIFS/Samba auf dem Windows-PC eingebunden.

    Deine Fehlermeldung kommt ja offensichtlich vom FTP. Bei richtig eingebundenen Platten braucht man das aber nicht.
    Ich würde die Einbindung der Platten auf dem PC auf CIFS umstellen. DAnn funktioniert auch alles.

    Ich hoffe mal, dass dies deiner Definition "deines Themas" entspricht...
  • Hab es als ftp://... eingebunden.
    Will ich es per \\192.168.2.6\ einbinden funktioniert es nicht.
    Muss ich auf der VU eine Freigabe konfigurieren, um von dem Win10 drauf zuzugreifen? Wenn ja, wie? Habe Anleitung immer nur anders herum gefunden :(

    Thx

    The post was edited 1 time, last by Heba ().

  • Gerade am Handy per VPN getestet mit einem Sambaclient.. Funktioniert..
    Ich werde es später zu Hause nochmal durchtesten und die Fehlermeldung posten (falls noch vorhanden :) ).

    Ich melde mich - Danke erstmal.

    Also entweder mach ich es falsch.... oder keine Ahnung!

    Help? Pls :)

    Kann leider nicht editieren:

    Update: Es liegt nicht an der VU. An dem PC meiner Freundin geht´s.
    Weiss trotzdem jemand was ich machen kann?
    Datei und Netzwerkfreigabe ist aktiv.
    SMB ist aktiv.
    Windows FW und Avast testweise deaktiviert...
    Windows 10 N! aber Media Pack installiert..

    Help? :)

    Und kann auf Close.. Windows 10 N! ... NFS Dienste mussten ebenfalls installiert werden :( Nun lüppt es.
    Danke zusammen!
    Files
    • 192.168.2.6.png

      (15.4 kB, downloaded 15 times, last: )
  • versteh ich nicht wirklich, wieso du NFS benötigst
  • Verstehe das wer will.. Bekomme auch nicht die eigentliche Struktur angezeigt sondern nur ein Ordner namens: "\media\hdd"
    Auf das FS der VU habe ich keinen Zugriff.
    Naja, wollte ja nur auf die HDD. Von daher. (Außer jemand hat die spontan die Gesamtlösung?)
  • Du hast jetzt vermutlich eine Verbindung über NFS hergestellt.
    In der /etc/exports ist auf der Box eingetragen, welche Filesysteme per NFS zur freigegeben werden sollen.
    Da ist standardmäßig nur /media/hdd freigegeben.

    Für Windows sollte man nicht NFS verwenden, sondern das Windows-eigene CIFS-Protokoll.
    Dazu macht die Box die Freigaben mit dem Samba-Server.
    Die Samba-Konfiguration steht auf der Box im Verzeichnis /etc/samba.
    In der Datei smb.conf ist konfiguriert, welche Filesysteme für Samba/CIFS freigegeben werden.
    Da sind standardmäßig zwei Einträge enthalten:
    • rootfs - das Flash-Filesystem
    • Harddis - die unter /media/hdd gemountete Platte

    The post was edited 2 times, last by RickX ().

  • Danke für die Erklärung.
    Weisst du wie ich das Problem beheben kann? Bin ein bisschen ratlos gerade.

    Edit: Es ist eine Usersetting. Mit einem Testuser am gleichen PC geht es... Aber welches Setting könnte es sein?

    The post was edited 1 time, last by Heba ().

  • Tja... keine Ahnung... Normalerweise läuft der Samba-Server standardmäßig.

    Du kannst auf Telnet-Ebene mit ps -ef | grep smb nachsehen, ob der Samba-Server überhaupt läuft.
    Die Konfigurationsdateien in /etc/samba müssen auch in Ordnung sein.

    Falls der Samba-Server einfach abgeschaltet wurde, kannst Du ihn im VTI-Panel / VTI Systemwerkzeuge / Systemdienste mal starten...
  • An der VU ist alles ok. Es ist nur der eine Benutzer auf dem einen Windows.
    Es geht sowohl von einem anderen Windows aus, als auch von meinem Windows mit einem anderen Nutzer

    Gelöst:
    Lösung war entweder:
    Netsh Winsock reset

    oder

    Löschen der Anmeldecredentials des Users.

    Ich gehe von den Anmeldecredentials aus, da der Fehler am gleichen Client und einem anderen User nicht aufgetreten ist.
    Vielleicht hilft das mal jemandem weiter :)