oscam per Script starten wird nicht vom VTi erkannt

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • oscam per Script starten wird nicht vom VTi erkannt

      Hallo,
      ich möcte per Script oscam starten (und stoppen), dazu nutze ich das (korrekte?) Script hier:
      /usr/script/OSCam_cam.sh start|stop

      Die Softcam startet bzw. stoppt auch korrekt.

      Aber wenn ich die Softcam so über die Shell (root) starte, kann ich sie nicht über das VTi Panel stoppen, das VTi Panel zeigt auch keinen grünen "haken" an. Erkennt also nicht, das die Softcam läuft.
      Frage ist, wie muss ich die Softcam starten, so das auch das VTi Panel den Start" mitbekommt" ?
      Welche Aktion führt denn VTi Panel aus beim "Softcam starten"? Kann man das irgendwie sehen?

      Die laufenden Prozesse sehen völlig gleich aus (owner, Parameter), egal ob sie über die Shell oder VTi starte.
      VG,
      Martin

      [3x Vu+ Zero, 1x Vu+ Uno SE 4k ]
    • Gefunden ;)

      Evtl. hilfts ja dem/der einen oder anderen ...

      Habe die Prozesse debugged, welche beim start über VTi ausgelöst werden, gestartet wird die Softcam über einen Link /etc/init.d/current_cam.sh der zum (bekannten) Startscript /usr/script/OSCam_cam.sh zeigt!
      Dieser Link wird (erst) angelegt beim starten (über VTi), und beim stoppen (über VTi) wieder entfernt.

      Startet man nun die Softcam direkt über /usr/script/OSCam_cam.sh , wird der Link nicht angelegt!
      Aber das Stop-Script bzw. VTi prüft ob der Link (von /etc/init.d/current_cam.sh nach /usr/script/OSCam_cam.sh) existiert, falls dieser nicht existiert geht VTi davon aus: Nichts zum stoppen vorhanden!

      Also muss beim starten der Softcam über die Shell (mittels: /usr/script/OSCam_cam.sh start) zusätzlich noch folgendes ausgeführt werden:
      ln -s /usr/script/OSCam_cam.sh /etc/init.d/current_cam.sh

      Nur dann kann die so gestartete Softcam auch über VTi gestoppt werden!
      VG,
      Martin

      [3x Vu+ Zero, 1x Vu+ Uno SE 4k ]
    • Sehe ich auch so... bestimmte Sachen mache ich ja ganz gerne über die Kommandozeile. Aber ich wäre nie auf die Idee gekommen, den Oscam-Prozess damit zu starten. Außerdem habe ich Oscam vor Jahren einmal im Cam-Center aktiviert und habe mich danach nie wieder um einen Oscam-Start kümmern müssen...
    • Tja,
      es gibt eben auch andere Anwendungsbereiche ...
      Ich möchte z.B. per ssh (und remote) die Softcam stoppen bzw. restarten können.
      Oder per cron falls er nicht läuft per Script starten lassen etc ...
      VG,
      Martin

      [3x Vu+ Zero, 1x Vu+ Uno SE 4k ]