Festplattenprobleme mit Solo4k

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Festplattenprobleme mit Solo4k

      Hi

      Problem 1:
      Seitdem sich mein NAS auf dem die Solo4k aufnahm, verabschiedet hat kommt immer, wenn ein Aufnahmetimer (Status Warten) ansteht, ein Lilascreen mit Reboot.
      Kann ich alle Timer (Auitotimer) temporär an zentraler Stelle deaktivieren? Es ist zu mühsam, zig Timer ständig einzeln zu deaktivieren...

      Probelm 2:
      Ich habe keine Ahnung von Linux.

      Problem 3:
      Als NAS-Ersatz wollte ich eine neue externe USB3-2TB-HD anschließen.
      Diese wurde auch erkannt, beim Partitionieren (Gerätemanager) als eine Partition gab es aber immer eine Fehlermeldung. Erst bei 2 Partitionen (1%/99%) funktionierte es.
      Die 99% mit ext4 formatiert und als "hdd1" (die Solo4k hat noch eine kleine interne HD als "hdd") eingehängt.
      Jetzt kommt aber nach kurzer Zeit immer ein Dauerspinner. Schalte ich die Stromversorgung der HD ab, kommt der Dauerspinner nicht.
      Woran liegt das, wie kann ich es beheben?

      Problem 4:
      Da ich in letzter Zeit immer die Solo4k Aus- und Einschalten muß und der Powerschalter hinten so ungünstig angebracht ist, gibt es eine Möglichkeit einen Taster für einen Hardwarereset irgendwo anzuschließen?
      bd. Alv
    • Mal lange auf der "Aus-Taste" der Fernbedienung bleiben.
      Ist "gesünder" für das installierte Image. ;)
      Zu Deinen Festplatten & Aufnahmepfaden kann ich leider nichts beitragen.
      Es wäre nett wenn Hilfesuchende die Helfenden dahingehend unterstützen, dass sie das Profil mit den VU-Box-Modell & den aktuell verwendete Image ausfüllen würden. ;)

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Radar ()

    • Festplattenprobleme mit Solo4k

      Da meine Solo4k sich mittlerweile nur noch selten aufhängt und sich auch sonst manches geändert hat, ist für mich am Bequemsten, gleich die Sicherung raus zu nehmen. Keine betroffene Komponente braucht dann ne "Nachbehandlung", weil sie Uhrzeit etc. vergessen hätte, so why not? Ich habe noch nie ausprobiert, ob der Fronttaster hinter der Klappe den 10s Reset beherrscht. Harmony 300/350 brechen den Wiederholvorgang der Powertaste nach 1s ab, ne Harmony 700 wiederholt zwar endlos, wenn man es übers Display macht, nur passiert nix. Die Ori-FB ist verstaut.
      Ich hab ne mit 1 Ext4 Partition versehene Usb3 HD, no problem. Jmd aus dem Forum meinte, bei großen HDs bräuchte man zusätzlich ein kleines Usb-Laufwerk, um keine Probleme zu bekommen, ich habe ja eine 64GB mSD in nem Usb3 Cardreader.

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Corvuscorax ()

    • Da der Lila Screen kommt, sollte auf einer der Festplatten
      im Hauptverzeichnis eine crash.log -Datei sein
      Die mal als Dateianhang hier posten.
      Vermutlich, da es keinen Zugriff mehr auf d. NAS
      gibt, Aufnahmepfade nicht mehr passend.
      Alternativ mal mit "blau->grün->grün" das Image
      auf den aktuellsten Stand bringen.
      Gerätemanager sollte Auskunft geben welche Festplatte
      wie im System eingebunden ist.
      Es wäre nett wenn Hilfesuchende die Helfenden dahingehend unterstützen, dass sie das Profil mit den VU-Box-Modell & den aktuell verwendete Image ausfüllen würden. ;)

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Radar ()

    • Bisherige Ergebnisse:

      Problem 1:
      Der Lilascreen kam vermutlich, weil die Solo4k durch Aufnahmen ihre interne HD vollgemüllt hat.
      Ist das eine Linux-Eigenschaft, daß bei fehlendem Schreibpfad einfach irgendwoandershin gespeichert wird?

      Wieso kommt überhaupt ein Lilascreen bei voller HD? Die interne HD benutze ich nur für Imagebackups.
      Crashlogs gibt es, aber da die Solo4k z.Zt. mein einzig funktionierender "Computer" ist, kann ich sie hier nicht hochladen.

      Problem 2:
      Daran hat sich nichts geändert. :)

      Problem 3:
      Die externe USB-HD habe ich an einem PC in einer 2TB-Partition in NTFS formatiert.
      Die Solo4k hat sie dann ohne Meckern akzeptiert.
      Wieso ging das nicht mit Bordmitteln?

      Problem 4:
      Der Taster hinter der Klappe hat auch nach 30s drücken keinen Effekt auf einen Dauerspinner.
      Überrascht hat mich aber das Ausschalten über die Fernbedienung, wo diese doch ansonsten keine Reaktion mehr hervorrief...
      bd. Alv
    • Alv schrieb:

      in NTFS formatiert.
      Linux-Format (Betriebssystem der Box) wäre eigentlich "ext 3" bzw. aktuell "ext 4".
      NTFS eher nicht optimal.
      Es wäre nett wenn Hilfesuchende die Helfenden dahingehend unterstützen, dass sie das Profil mit den VU-Box-Modell & den aktuell verwendete Image ausfüllen würden. ;)

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Radar ()

    • Alv schrieb:

      Ist das eine Linux-Eigenschaft, daß bei fehlendem Schreibpfad einfach irgendwoandershin gespeichert wird?
      Nein. Linux schreibt da hin, wo es hinschreiben soll. Wenn es also nach /media/hdd1 schreiben soll, dort aber keine Parition gemountet ist, schreibt es einfach in den Mount-Point /media/hdd1.

      Um dies zu vermeiden, wird das wohl im Enigma abgefangen. Wenn ein Netzwerkpfad nicht verfügbar ist, wir stattdessen in das Standardverzeichnis /media/hdd geschrieben. Eine vollgelaufene Festplatte ist außerdem immer noch besser als ein vollgelaufenes Root-Verzeichnis im Flash. Darum ist das das gewünschte und deshalb so programmierte Verhalten.


      Alv schrieb:

      Wieso kommt überhaupt ein Lilascreen bei voller HD? Die interne HD benutze ich nur für Imagebackups.
      Wenn ein Programm richtig programmiert ist, führt ein vollgelaufenes Filesystem nicht zu einem Crash.

      Hier könnte es evtl. die Filmdatenbank sein. Die SQL-Dateien werden standardmäßig in /media/hdd angelegt (vtidb.db, vtidb.db.lock). Wenn die Platte voll ist, kann die Datenbankdatei nicht mehr richtig geschlossen werden und ist dadurch korrupt. Das wird leider im Enigma nicht richtig abgefangen und führt dann zum Crash.

      Du könntest also mal nachsehen, ob das bei dir der Fall ist. Wenn in /media/hdd die Dateien mit dem Namen vtidb... sind, kannst Du die mal löschen und evtl. in den VTI-Systemeinstellung die Verwendung der SQL-Datenbank testweise komplett abschalten.
    • Neu

      Das ist aber jetzt ein ganze anderes Thema und passt nicht zum Thread hier
    • Neu

      @besilaurend
      Hier geht es um Festplatten an einer Solo 4K, nicht um Sticks an einer Zero 4K.
      Bitte such dir einen passenden Thread oder eröffne einen neuen.

      @anudanan
      Ich wäre dir dankbar, wenn du solche moderativen Anmerkungen den Moderatoren überlassen würdest. Du kann OT-Beiträge natürlich gerne melden.

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von hgdo ()

    • Neu

      Sorry, werde mich zurückhalten. Du kannst meine Betrag oben löschen und den hier gern auch
    • Neu

      Radar schrieb:

      Alv schrieb:

      in NTFS formatiert.
      Linux-Format (Betriebssystem der Box) wäre eigentlich "ext 3" bzw. aktuell "ext 4".NTFS eher nicht optimal.
      Mag sein, aber mit der Solo4k ließ die HD sich ja nicht einrichten.

      Außerdem bekomme ich ext-FS am Win-PC nicht problemlos zum Laufen, deshalb ist für alle externen Medien FAT32 oder NTFS ein Muß!
      Andere FS nur, wenn die Speichermedien fest eingebaut sind, und nie an anderen Computern betrieben werden.

      Außerdem versteht die Solo4k NTFS sehr gut.
      bd. Alv
    • Neu

      Alv schrieb:

      Außerdem versteht die Solo4k NTFS sehr gut.
      Das sieht direkt nach dem Formatieren, wenn die Platte noch leer oder fast ist, bei jedem FS so aus. Bei einem Füllstand von beispielsweise 70% sieht das möglicherweise schon ganz anders aus.

      Für eine unserer Archivplatten habe ich allerdings auch NTFS verwendet - ohne Probleme bisher. Für den ständigen Aufnahmeordner würde ich das aber lieber nicht tun.
      Eventuelle Ratschläge gebe ich nach bestem Wissen und Gewissen aber ohne jede Gewähr. Bei Fragen fragen.
    • Neu

      Alv schrieb:

      ist für alle externen Medien FAT32 oder NTFS ein Muß
      FAT32 ist auf 4 GB begrenzt u. deshalb bei Filmaufnahmen
      i. d. R. mehrere Dateien erzeugt werden müssten.
      Wenn Deine Box mit Deiner Festplatte mit NTFS besser
      werkelt, dann kannst ja NTFS benutzen.
      Bei mir sind u. A. die internen Festplatten der Boxen "externe"
      Medien, da ich schon mal über das Netzwerk v. Windows-PC's aus
      darauf zugreife. Bisher, ca. 7 Jahre, noch nie
      ein Problem gehabt. Zugegeben, Aufnahmeorgien finden auf meinen
      Boxen keine statt. Externe Medien würde ich bei mit im Falle eines
      Falles über ein NAS lösen wollen.
      Es wäre nett wenn Hilfesuchende die Helfenden dahingehend unterstützen, dass sie das Profil mit den VU-Box-Modell & den aktuell verwendete Image ausfüllen würden. ;)

      Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von Radar ()

    • Neu

      Unter "externen Speicermedien" verstehe ich SD-Karten, USB-Sticks und USB-HDs, die dazu gedacht sind, zwischen "Computern" ausgetauscht zu werden. Das kompatibelste FS ist dabei FAT32.
      Für eine Backup-HD habe ich eine kleine FAT32-Bootpartition mit dem Backupprogramm und eine NTFS-Partition für die Backup-Images.

      Da fällt mir noch ein:
      Kann ich die externe USB-Festplatte an der Solo4k irgendwie freigeben, daß ich mit dem PC übers Netzwerk darauf zugreifen kann?
      bd. Alv
    • Neu

      Ja, Samba.cfg anpassen.
      Es wäre nett wenn Hilfesuchende die Helfenden dahingehend unterstützen, dass sie das Profil mit den VU-Box-Modell & den aktuell verwendete Image ausfüllen würden. ;)
    • Neu

      Und die "smb.conf" findest unter /etc/samba
      Meine sieht z.B. aktuell so aus:
      Spoiler anzeigen

      [global]
      load printers = no
      guest account = root
      log file = /tmp/smb.log
      log level = 1
      security = share
      server string = Vuplus %h network services
      workgroup = ARBEITSGRUPPE
      netbios name = %h
      case sensitive=yes
      preserve case=yes
      short preserve case=yes
      socket options = TCP_NODELAY
      preferred master = no ;(These stop the machine being master browser, which means that it doesn't waste time there.)
      oplocks = no
      unix extensions = no


      [Configuration]
      comment = Configuration files - take care!
      path = /var
      wide links = yes
      read only = no
      public = yes
      guest ok = yes


      [Harddisk]
      comment = The harddisk
      path = /media/hdd
      wide links = yes
      read only = no
      public = yes
      guest ok = yes


      [Harddisk1]
      comment = The harddisk 1
      path = /media/hdd1
      wide links = yes
      read only = no
      public = yes
      guest ok = yes

      [Harddisk2]
      comment = The harddisk 2
      path = /media/hdd2
      wide links = yes
      read only = no
      public = yes
      guest ok = yes

      [Harddisk3]
      comment = The harddisk 3
      path = /media/hdd3
      wide links = yes
      read only = no
      public = yes
      guest ok = yes

      [USB]
      comment = USB Stick
      path = /media/usb
      wide links = yes
      read only = no
      public = yes
      guest ok = yes

      [Solo2Flash]
      comment = Flash
      path = /
      wide links = yes
      read only = no
      public = yes
      guest ok = yes
    • Neu

      Meine sieht so aus (an einigen Stellen ziemlich anders):

      Spoiler anzeigen
      #config version:3.6.25-vti001

      [global]
      local master = yes
      preferred master = yes
      os level = 65
      guest account = root
      security = user
      map to guest = bad user
      server string = VTi/Vu+ network shares at %h
      workgroup = VuPlus
      socket options = TCP_NODELAY
      smb passwd file = /etc/samba/private/smbpasswd
      encrypt passwords = yes
      passdb backend = smbpasswd
      idmap backend = smbpasswd
      obey pam restrictions = no
      unix extensions = no
      wide links = yes
      unix charset = utf-8
      max stat cache size = 64
      null passwords = yes

      [rootfs]
      comment = Do not touch !
      path = /
      read only = no
      public = yes
      guest ok = yes
      valid users = root
      force create mode = 600
      force directory mode = 700
      force security mode = 600
      force directory security mode = 700

      [Harddisk]
      comment = The harddisk
      path = /media/hdd
      read only = no
      public = yes
      guest ok = yes
      valid users = root
      force create mode = 600
      force directory mode = 700
      force security mode = 600
      force directory security mode = 700




      Würde es ausreichen, den Harddisk-Part zu duplizieren und "path" auf "/media/hdd1" abzuändern?
      bd. Alv