Unterstützt VTI 13 nun SMB Versionen >=2

    • Der Mount ist testweise über den Freigabemanager angelegt per Fernbedienung mit option rw,vers=3.02

      smb1 ist abgedreht am NAS

      das wird dann ausgehandelt:
      Ausgabe von mount auf der console der solo4k:

      //192.168.11.29/movie on /media/net/movie type cifs (rw,relatime,vers=3.02,sec=ntlmssp,cache=strict,username=admin,domain=DISKSTATION,uid=0,noforceuid,gid=0,noforcegid,addr=192.168.11.29,file_mode=0755,dir_mode=0755,iocharset=utf8,nounix,serverino,rsize=8192,wsize=8192,actimeo=1)

      wir reden vom samba-client im Kernel 3.14 des VTi nicht vom samba server auf der solo4k

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von flotzi ()

    • Nur damit ich es nicht (wieder) falsch verstehe:
      • Der Samba-Client auf der VU+-Box kann SMB 3.0.2 ?
      • Der Samba-Server kann dagegen nur 2.0 ?
      Ist das korrekt?

      Wie kann ich auf der VU+-Box überprüfen welche SMB-Version der Client für eine Verbindung zu einem Server nutzt?

      Gruß,
      Stefan

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Teddybär ()

    • jetzt zum samba server 3.6.25 der VU+ (Stand 13.0.1)

      ohne eine Angabe in der smb.conf zu min oder max protocol.
      Hier der mount zur Solo4k vom mac aus gesehen ohne Angabe von Parametern direkt über den Finder:

      auf der mac console: smbutil statshares -a

      rootfs
      SERVER_NAME VUSOLO4K._smb._tcp.local
      USER_ID 501
      SMB_NEGOTIATE SMBV_NEG_SMB1_ENABLED
      SMB_NEGOTIATE SMBV_NEG_SMB2_ENABLED
      SMB_NEGOTIATE SMBV_NEG_SMB3_ENABLED
      SMB_VERSION SMB_2.002
      SMB_SHARE_TYPE DISK
      SIGNING_SUPPORTED TRUE
      EXTENDED_SECURITY_SUPPORTED TRUE
      LARGE_FILE_SUPPORTED TRUE
      FILE_IDS_SUPPORTED TRUE
      DFS_SUPPORTED TRUE


      Also zusammengefasst:
      Der Samba-Client kann sich mit SMB1, 2, 2.1, 3 und 3.02 verbinden. 3.11 geht nicht.

      Aber er kann es nicht aushandeln (anders als dokumentiert), sondern nur stur die per vers= angegebene Version, oder wenn vers= fehlt SMB1.

      Der Samba-Server des VTi (3.6.25) kann nur SMB2 und 1
      erst ab Version 4.1 geht SMB3 siehe hier: Samba (software) - Wikipedia

      Zeigt auch der mac oben sehr schön. Er signalisiert ich kann 1, 2 und 3 und der mount wird dann ein 2.002 mit der Solo4k

      @Teddybär

      auf die console mit telnet oder ssh und mount eingeben dann spuckt er es aus (siehe post oben)

      oder im VTi Panal - Dateisysteme anzeigen
    • Danke für die Antwort. Leider geht das mit dem mount bei mir nicht, da kommt nur folgendes:

      Quellcode

      1. root@vusolo2:~# mount
      2. rootfs on / type rootfs (rw)
      3. ubi0:rootfs on / type ubifs (rw,sync,relatime)
      4. devtmpfs on /dev type devtmpfs (rw,relatime,size=286340k,nr_inodes=71585,mode=755)
      5. proc on /proc type proc (rw,relatime)
      6. sysfs on /sys type sysfs (rw,relatime)
      7. tmpfs on /run type tmpfs (rw,nosuid,nodev,mode=755)
      8. tmpfs on /var/volatile type tmpfs (rw,relatime)
      9. devpts on /dev/pts type devpts (rw,relatime,gid=5,mode=620)
      10. /etc/auto.hotplug on /autofs type autofs (rw,relatime,fd=5,pgrp=455,timeout=5,minproto=5,maxproto=5,indirect)
      11. /etc/auto.network_vti on /media/net/autonet type autofs (rw,relatime,fd=16,pgrp=455,timeout=5,minproto=5,maxproto=5,indirect)
      12. root@vusolo2:~#
      Alles anzeigen
      Gibt es noch eine andere Möglichkeit?

      Danke und Gruß,
      Stefan