Anfängerfragen: Python-Enigma2-Plugin

    • Anfängerfragen: Python-Enigma2-Plugin

      Hallo,
      ich versuche mich aktuell an enigma2 Plugins und habe damit angefangen die Basisdemo (gefunden auf github.com/openatv/enigma2/blob/master/doc/PLUGINS ) zum laufen zu bringen.
      Also folgenden Schnipsel:

      Python-Quellcode: /usr/lib/enigma2/python/Plugins/Extensions/testMe/plugin.py

      1. #/usr/lib/enigma2/python/Plugins/Extensions/PluginName
      2. #"init 4" stopt enigma sauber
      3. #"init 3" startet enigma
      4. #"enigma2" führt enigma mit consolen-ausgaben aus
      5. from Plugins.Plugin import PluginDescriptor
      6. def main(session, **kwargs):
      7. print "[testMe] Hello world!"
      8. def autostartEntry(reason, **kwargs):
      9. if reason == 0: # startup
      10. print "[testMe] startup"
      11. elif reason == 1:
      12. print "[testMe] shutdown"
      13. def Plugins(**kwargs):
      14. return PluginDescriptor(
      15. name="testMe",
      16. description="plugin to test some capabilities",
      17. where = PluginDescriptor.WHERE_PLUGINMENU,
      18. fnc=main)
      19. #where = PluginDescriptor.WHERE_AUTOSTART,
      20. #fnc=autostartEntry)
      Alles anzeigen



      1. Frage
      Wenn ich das nun per FTP auf die box lade finde ich auch das Plugin in den Erweiterungen,
      IMG_20170912_194503.jpg

      aber ich sehe nirgends die Print ausgaben, also kein "[testMe] Hello world!" - nicht einmal wenn ich enigma über die console starte.

      Shell-Script: telnet

      1. root@vuduo2:~# init 4
      2. root@vuduo2:~# ps -ax |grep enigma
      3. 12850 pts/0 S+ 0:00 grep enigma
      4. root@vuduo2:~# enigma2
      5. PYTHONPATH: /usr/lib/enigma2/python
      6. [VTi] change debug mode --> console: 0
      7. [VTi] change debug mode --> file: 0
      8. executing main
      9. Restarting internet superserver: inetd .
      10. hbbtv.app: no process found
      11. unknown client
      12. unknown client
      13. write ret : 192000
      14. write to /dev/lcd2 : 192000
      15. [...]
      Alles anzeigen


      ... Wo finde ich meine 'print' ausgaben ?
      ( Wenn ich "where = PluginDescriptor.WHERE_PLUGINMENU" gegen "where = PluginDescriptor.WHERE_AUTOSTART" tausche, ändert sich auch nix -weiterhin kein Hello World)

      - was müsste ich anstellen um Print-Ausgaben zu sehen
      - was müsste ich anstellen um "Fehlermeldungen" zu sehen ( bei Code-Fehlern im Plugin)

      Vielen Dank für Kommentare, ich hoffe irgendwer erkennt einen offensichtlichen Anfängerfehler :)

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Wooky ()

    • Danke für die schnellen Antworten :)
      Der Vorschlag von rdamas hat es gelöst - Ohne Aktivierung der Debug-Ausgaben im TV-Einstellungs-Menu werden weder logfile noch Consolenausgaben geschrieben.
      ... und nach beheben des typischen windoof-unix line-ending problems sagt mein Plugin jetzt auch "Hallo Welt"