Flashen über Nullmodem- bzw Seriellem Kabel?

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Flashen über Nullmodem- bzw Seriellem Kabel?

      Hallo Leute.
      Vielleicht hab ihr's mitbekommen, vielleicht auch nicht.
      Kurz gesagt: die Duo² lässt sich nicht per USB Stick flashen. Egal welches Image, welchen Stick (von 4GB bis 16GB alle probiert), welches Formatierungstool, Meldung zum Update kommt zwar, aber auf die Power-Taste an der Duo² reagiert die nicht, nicht mal ein bisschen.

      Deshalb der Weg über Nullmodemkabel.
      Das Tool VuUtil 2.0.1 hab ich bereits gefunden.
      Mit fehlt noch ein passendes .nfi Image.

      Und evtl eine Anleitung dazu. Ich hab hier und da mal geguckt und es wird davon gesprochen dem Receiver vorher eine feste IP zuzuweisen. Das klappt bei mir nicht, die Duo² reagiert auf nichts. Höchstens ein- und ausschalten per Kippschalter. Das Tool hat aber einen DHCP Punkt, hat es mal jemand darüber geschafft?

      Über ein passendes Image würd ich mich freuen. Ich hoffe ich bekomm die Duo² damit irgendwie wieder raus ausm Koma.
    • Ich würde das serielle Nullmodemkabel im Vorfeld dazu benutzen,
      den Start der Box mit Hyperterminal (oder Dergleichen) ab stromlos auf einen Windows-PC mit zu loggen.
      Unter Umständen könnte man daraus sehen, wo die Box beim Startversuch hängen bleibt.
      Nur mal so nebenbei, wenn die Box Strom bekommt kommt da noch die
      "Bootloader-Meldung" auf den Display der Box?

      The post was edited 1 time, last by Radar ().

    • Radar wrote:

      Ich würde das serielle Nullmodemkabel im Vorfeld dazu benutzen,
      den Start der Box mit Hyperterminal (oder Dergleichen) ab stromlos auf einen Windows-PC mit zu loggen.
      Wie meinst du das mit dem Nullmodemkabel?
      Wegen Hyperterminal muss ich schauen wo ich das finde und wie ich da vorzugehen habe.


      Radar wrote:

      Nur mal so nebenbei, wenn die Box Strom bekommt kommt da noch die
      "Bootloader-Meldung" auf den Display der Box?
      Welche Bootloader-Meldung genau? Die Duo² erkennt zumindest den Stick bzw. den Inhalt und bittet mich darum die Power-Taste zu drücken, aber weiter komme ich nicht.


      PeEf wrote:

      gibt es für die Duo2 mW nicht
      Das wäre dann sehr unvorteilhaft. Denn über USB bekomme ich das Image nicht rauf.
      Ich hatte da noch was wegen JTAG gehört. Kann man damit die Box noch retten? Falls ja, wie? in den Wiki's finde ich dazu nichts.
    • Cilow wrote:

      Kurz gesagt: die Duo² lässt sich nicht per USB Stick flashen.
      Ich behaupte einfach mal, das das nicht stimmt, ausgenomme, alle USB-Ports sind defekt, was ich ausschlieesse, wenn die "Press Power to Update"-Meldung kommt.
      du drückst schon die Power-Taste am Receiver, NICHT auf der FB (hab meine DUO² schon lang nicht mehr, evtl. ist der Button hinter der Frontklappe)?
      ACHTUNG!!!! Hier folgt eine Signatur:


      Die Benutzung der Suche ist NICHT verboten! D:

      "Hilfe!!!" ist kein sinnvoller Titel für einen neuen Thread, ebensowenig "VU+Zero" oder vergleichbares.

      Keine Hilfe ohne ausgefülltes Profil!
    • Cilow wrote:

      wegen JTAG gehört. Kann man damit die Box noch retten?
      Dazu müsste man erst mal genau schauen, wo die Box beim Booten (ohne Image Stick & sämtliche
      anderen USB-Verbindungen getrennt) stecken bleibt. Bei den Flashversuchen waren die USB's ja schon jetzt alle abgesteckt?
      JTAG wird üblicherweise nur dann gebraucht, wenn z. B. versehentlich ein falscher
      Bootlaoder in der Box gelandet ist. So zu sagen wenn die Box gar nichts mehr tut wenn die frisch Strom bekommt.
      Serielles-Nullmodemkabel = das was Du als serielles Kabel z. Flashen zu Hause hast.
      Hyperterminal kann man in Windows installieren. Bei älteren Windowsversionen ist das schon mit dabei.

      Cilow wrote:

      aber auf die Power-Taste an der Duo² reagiert die nicht
      Da geh ich davon aus dass d. TE bekannt ist wo er die Powertaste der Duo² findet.
      Wobei, erst mal kürzlich gelesen, dass jemand dort erfolglos "gedürckt" hat, wo die LED leuchtet.

      The post was edited 1 time, last by Radar ().

    • läuft die Box denn noch? Wenn ja, kann man doch auch über VTI Software flashen, oder?
    • GaborDenes wrote:

      Ich behaupte einfach mal, das das nicht stimmt, ausgenomme, alle USB-Ports sind defekt, was ich ausschlieesse, wenn die "Press Power to Update"-Meldung kommt.
      Also, ich habe mehrere Sticks ausprobiert, von 4GB bis 16GB. Ich hab noch eine 128GB hier liegen, aber die wird zu 99% nicht funktionieren. Dann habe ich mehrere Tools benutzt um die USB Stick zu formatieren, und zwar nicht im Schnellformat. Ich hab hier auch mehrere Images liegen, die ich probiert habe. Und auch ganz gleich welchen USB Port ich an der Duo2 benutze. Ob vorne, oder die beiden hinteren. Es ist jedesmal das gleiche Spiel: USB Stick ist dran, Kippschalter ein, Meldung erscheint mit der Power-Taster, Power-Taster am Receiver (nicht an der FB) wird gedrückt, auch mehrmals, mal länger mal kürzer. Die weiße LED fängt an zu zucken, aber es tut sich einfach nichts. Die Duo² bootet dann ganz normal weiter. Oben angekommen reagiert die Duo² auch nicht. Dabei spielt es keine Rolle welche Taste ich auf der FB drücke. Selbst mit der Power-Taste kann ich nichts machen. Die ist wie eingefroren.


      Radar wrote:

      Bei den Flashversuchen waren die USB's ja schon jetzt alle abgesteckt?
      Ja, nur der eine USB Stick ist vorne dran. Die beiden hintern sind leer.


      Radar wrote:

      Hyperterminal kann man in Windows installieren
      Nutze aktuell Win10. Die erste Suche ergab HTPE, Hyper Terminal Private Edition 7.0. Ich weiß jetzt ob das richtige Version war, aber zig Meldungen auf einmal. Location eingeben, Registrierung, 29 Tage noch gültig und und und.. ich schau nochmal ob ich eine non Private Edition finde.
      Wo finde ich denn weitere Infos darüber wie ich die zB eine Verbindung zur Duo2 erstellen kann, und die ganzen Logs dann speichere?

      Schnickalot wrote:

      läuft die Box denn noch? Wenn ja, kann man doch auch über VTI Software flashen, oder?
      Bestimmt, aber die Box ist nach dem Booten wie eingefroren. Ich kann nichts machen, höchstens den Kippschalter hinten betätigen.
    • Hast dann noch irgendwie Zugriff auf die Box über das Netzwerk?
      Dazu evtl. die Box mal mit der Fritz direkt verbinden und Dein nicht funktionierendes Subnet aussen vor lassen.
      Wenn ja, versuchen manuell die Box über das Netzwerk auf den neuesten Stand bringen.
      Telnet
      IP der Box
      Anmelden: root
      Passwort leer lassen
      opkg update
      opkg upgrade
      reboot

      The post was edited 1 time, last by Radar ().

    • Hab die Duo² jetzt direkt an der Fritte angeschlossen. Und in der Fritte taucht die Duo² auf, mit der IP 192.168.178.50. Das Web-Interface über die IP geht leider nicht.

      Auch mit Putty klappt es nicht.

      Laut der Fritte ist die Duo² ja scheinbar verbunden. Vielleicht kann ich die Duo² über den seriellen Port ansprechen, zwecks der Logs?



      Volbeat wrote:

      Wenn sie durchbootet, dann stimmt was mit dem Stick oder dem entpackten Image auf dem Stick nicht (zb Ordnerstruktur)
      Das hatte ich auch gedacht, deshalb ja auch einen neuen USB Stick gekauft. Damit klappts aber auch nicht. Die Ordnerstruktur schließe ich aus. Die passt.

      The post was edited 1 time, last by Cilow ().

    • Cilow wrote:

      Das Web-Interface über die IP geht leider nicht.
      Der PC auch an der Fritte oder noch im nicht funktionierenden Subnetz?
      Webinterface brauchst ja auch nicht.
      Mit Telnet oder Dergleichen verbinden und versuchen die Box auf den neuesten Softwarestand zu bringen.
    • Stimmt, der PC hängt noch am Asus.
      Bevor ich mein PC jetzt zur Fritte schleppe, hatte ich mit meinem Tablet (hängt am WLAN der Fritte) via Mobile Telnet zu verbinden...
      Connecting to 192.168.178.50 port 23, please wait...
      Failed to connect to 192.168.178.50: No route to host

      Kann ich die Duo² nicht über die Mac Adresse ansprechen mit dem Nullmodemkabel?

      Trial wrote:

      hast Du vielleicht hinten einen USB-Stick oder USB-Festplatte dran? Nimm die ab.
      Nein, hinten ist nichts dran außer Strom, HDMI und Netzwerkkabel. Intern ist zwar eine HDD drin, die ist aber nicht angeschlossen.


      Nach einer Weile fliegt die Duo² auch raus aus der Fritte.

      The post was edited 2 times, last by Cilow ().

    • Wenn die Update Meldung erscheint funktionieren die Sticks und werden erkannt !

      Es wir der Tastendruck auf der Duo2 nicht erkannt.

      Lege eine leere Datei force.update in den Ordner /vuplus/duo2 am USB Stick und flash
    • Der Powerbutton (hinter der Klappe), NICHT die blaue LED, sollte immer funktionieren, unabhängig davon, ob ein Image auf der Duo² läuft oder nicht, deswegen zur Sicherheit noch einmal:
      Du drückst den Powerbutton (kleiner Plastik-Knubbel) hinter der Frontklappe, über dem USB-Anschluß?

      Was heisst "Putty geht nicht"? Funktioniert ein Ping auf die IP-Adresse?
      ACHTUNG!!!! Hier folgt eine Signatur:


      Die Benutzung der Suche ist NICHT verboten! D:

      "Hilfe!!!" ist kein sinnvoller Titel für einen neuen Thread, ebensowenig "VU+Zero" oder vergleichbares.

      Keine Hilfe ohne ausgefülltes Profil!
    • Das ist doch alles verrückt. Gerade wollte ich mich mit dem WLAN verbinden, da friert mir die Duo² einfach wieder ein. Ich hänge gerade in den Netzwerkeinstellungen drin und kann nichts mehr machen. Hab ich nie erlebt sowas.

      Jetzt, nach ca. 10 Minuten reagiert die Duo² wieder.
      Ich hab die jetzt über WLAN am Asus dran, mit DHCP.
      192.167.1.129.

      GaborDenes wrote:

      Der Powerbutton (hinter der Klappe), NICHT die blaue LED, sollte immer funktionieren, unabhängig davon, ob ein Image auf der Duo² läuft oder nicht, deswegen zur Sicherheit noch einmal:
      Du drückst den Powerbutton (kleiner Plastik-Knubbel) hinter der Frontklappe, über dem USB-Anschluß
      Ja, die einzige Taste hinter der Frontklappe.

      Hab mal eben fix geguckt wie ich ein Log erstellen kann:

      Irgendjemand wrote:

      telnet:
      init 4 && enigma2 > /tmp/e2log.txt 2>&1
      Hab ich dann gemacht, hier das kleine Ergebnis:
      PYTHONPATH: /usr/lib/enigma2/python
      [VTi] change debug mode --> console: 0
      [VTi] change debug mode --> file: 0
      executing main
      Restarting internet superserver: inetd .
      hbbtv.app: no process found
      unknown client
      unknown client

      Könnt ihr da irgendwas herauslesen?

      Und aus dem anderen Thread das hier probiert:
      Blau - Grün - Grün.
      46 Paktete installiert oder aktualisiert.
      Die Kiste fährt gerade neu hoch.
      Mal schauen was nun passiert.
    • Bin immer noch nicht weiter.
      Was ich aber mal gerne wissen würde ist, wie genau soll das mit dem Nullmodemkabel funktionieren?
      Das Nullmodemkabel ist bei mir am PC COM6. Wie soll ich diese Leitung in Putty auswählen, wenn der Log beim booten mitgeschnitten werden soll?