Openvpn 2.4.3 Client (21.6) -> windows admin privileges fixed

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • leider selber fehler

      Source Code

      1. root@vusolo4k:~# opkg print-architecturearch
      2. all 1
      3. arch any 6
      4. arch noarch 11
      5. arch armv7ahf-vfp-neon 16arch
      6. vusolo4k 21
      7. root@vusolo4k:~# opkg install /var/volatile/tmp/openvpn_2.4.6-r0.1_cortexa15hf-nNot selecting openvpn 2.4.6 due to incompatible architecture.Package openvpn (2.3.6-r0) installed in root is up to date.
    • Merci für's Testen. Hast die Datei arch.conf unter /etc/opkg editiert, also folgende Zeile hinzugefügt:

      Source Code

      1. arch cortexa15hf-neon-vfpv4
      und abgespeichert.
      Dann müsste die Zeile auch bei opkg print-architecture erscheinen.
    • ja hab ich schon

      Source Code

      1. root@vusolo4k:~# opkg print-architecture
      2. arch all 1
      3. arch any 6
      4. arch noarch 11
      5. arch armv7ahf-vfp-neon 16
      6. arch cortexa15hf-neon-vfpv4
      7. arch vusolo4k 21
      8. root@vusolo4k:~# opkg install /var/volatile/tmp/openvpn_2.4.6-r0.1_cortexa15hf-neon-vfpv4.ipk
      9. Not selecting openvpn 2.4.6 due to incompatible architecture.
      10. Package openvpn (2.3.6-r0) installed in root is up to date.
      11. root@vusolo4k:~#
      Display All

      The post was edited 1 time, last by ysimmerath ().

    • Falls es jemanden interessiert:

      Source Code

      1. opkg print-architecture
      2. arch all 1
      3. arch any 6
      4. arch noarch 11
      5. arch armv7ahf-vfp-neon 16
      6. arch vusolo4k 21
      ACHTUNG!!!! Hier folgt eine Signatur:


      Die Benutzung der Suche ist NICHT verboten! D:

      "Hilfe!!!" ist kein sinnvoller Titel für einen neuen Thread, ebensowenig "VU+Zero" oder vergleichbares.

      Keine Hilfe ohne ausgefülltes Profil!
    • Ich habe mir mal noch einen Versuch gegeben um ein Ergebnis für die 4k-Boxen zu erstellen.
      Leider kann ich es nicht selbst testen.
      Hier eine ipk zum Testen. Wenn die nicht läuft wird es mir zu anstrengend und es muss jemand anderes ran.
      Files
    • leider hat nix gebracht

      Source Code

      1. root@vusolo4k:/usr/script# opkg print-architecture
      2. arch all 1
      3. arch any 6
      4. arch noarch 11
      5. arch armv7ahf-vfp-neon 16
      6. arch cortexa15hf-neon-vfpv4
      7. arch vusolo4k 21
      8. root@vusolo4k:/usr/script# opkg install /var/volatile/tmp/openssl_1.1.0g-r0_cortexa15hf-vfp-vfpv4-neon.ipk
      9. Not selecting openssl 1.1.0g due to incompatible architecture.
      10. Package openssl (1.0.2a-r0) installed in root is up to date.
    • Einen Versuch habe ich mir noch gegeben. Diesmal erstellt unter openvuplus_3.0.
      Wenn die nicht laufen, dann weiß ich auch nicht mehr.

      Openvpn_2.4.6 und die zugehörige Openssl_1.1.0g für die vuplus 4k Boxen.
      Files
    • sieht besser aus

      Source Code

      1. root@vusolo4k:~# opkg print-architecture
      2. arch all 1
      3. arch any 6
      4. arch noarch 11
      5. arch armv7ahf-vfp-neon 16
      6. arch cortexa15hf-neon-vfpv4
      7. arch vusolo4k 21
      8. root@vusolo4k:~# opkg install /var/volatile/tmp/openssl_1.1.0g-r0_armv7ahf-vfp-n eon.ipk
      9. Upgrading openssl from 1.0.2a-r0 to 1.1.0g-r0 on root.
      10. Removing obsolete file /usr/bin/openssl.
      11. Configuring openssl.
      12. root@vusolo4k:~# opkg install /var/volatile/tmp/openvpn_2.4.6-r0_armv7ahf-vfp-neon.ipk
      13. Upgrading openvpn from 2.3.6-r0 to 2.4.6-r0 on root.
      14. Stopping openvpn:.
      15. update-rc.d: /etc/init.d/openvpn exists during rc.d purge (continuing)
      16. Removing any system startup links for openvpn ...
      17. Configuring openvpn.
      18. Adding system startup for /etc/init.d/openvpn.
      19. Starting openvpn: openvpnvti.
      20. root@vusolo4k:~# openvpn --version
      21. OpenVPN 2.4.6 arm-oe-linux-gnueabi [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD] built on Jan 17 2019
      22. library versions: OpenSSL 1.1.0g 2 Nov 2017, LZO 2.09
      23. Originally developed by James Yonan
      24. Copyright (C) 2002-2018 OpenVPN Inc <sales@openvpn.net>
      25. Compile time defines: enable_async_push=no enable_comp_stub=no enable_crypto=yes enable_crypto_ofb_cfb=yes enable_debug=yes enable_def_auth=yes enable_dependency_tracking=no enable_dlopen=unknown enable_dlopen_self=unknown enable_dlopen_self_static=unknown enable_fast_install=yes enable_fragment=yes enable_iproute2=yes enable_libtool_lock=yes enable_lz4=yes enable_lzo=yes enable_management=yes enable_multihome=yes enable_pam_dlopen=no enable_pedantic=no enable_pf=yes enable_pkcs11=no enable_plugin_auth_pam=no enable_plugin_down_root=yes enable_plugins=yes enable_port_share=yes enable_selinux=no enable_server=yes enable_shared=yes enable_shared_with_static_runtimes=no enable_silent_rules=no enable_small=no enable_static=yes enable_strict=no enable_strict_options=no enable_systemd=no enable_werror=no enable_win32_dll=yes enable_x509_alt_username=no with_aix_soname=aix with_broken_putenv=no with_crypto_library=openssl with_gnu_ld=yes with_libtool_sysroot=/home/matze/openvuplus_3.0/build/vuuno4k/tmp/sysroots/vuuno4k with_mem_check=no
      26. root@vusolo4k:~#
      Display All
    • Vielen Dan für die Mühe! scheint zu funktionieren

      Source Code

      1. root@vusolo4k:~# openvpn --version
      2. OpenVPN 2.4.6 arm-oe-linux-gnueabi [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD] built on Jan 17 2019
      3. library versions: OpenSSL 1.1.0g 2 Nov 2017, LZO 2.09
      4. Originally developed by James Yonan
      5. Copyright (C) 2002-2018 OpenVPN Inc <sales@openvpn.net>
      6. Compile time defines: enable_async_push=no enable_comp_stub=no enable_crypto=yes enable_crypto_ofb_cfb=yes enable_debug=yes enable_def_auth=yes enable_dependency_tracking=no enable_dlopen=unknown enable_dlopen_self=unknown enable_dlopen_self_static=unknown enable_fast_install=yes enable_fragment=yes enable_iproute2=yes enable_libtool_lock=yes enable_lz4=yes enable_lzo=yes enable_management=yes enable_multihome=yes enable_pam_dlopen=no enable_pedantic=no enable_pf=yes enable_pkcs11=no enable_plugin_auth_pam=no enable_plugin_down_root=yes enable_plugins=yes enable_port_share=yes enable_selinux=no enable_server=yes enable_shared=yes enable_shared_with_static_runtimes=no enable_silent_rules=no enable_small=no enable_static=yes enable_strict=no enable_strict_options=no enable_systemd=no enable_werror=no enable_win32_dll=yes enable_x509_alt_username=no with_aix_soname=aix with_broken_putenv=no with_crypto_library=openssl with_gnu_ld=yes with_libtool_sysroot=/home/matze/openvuplus_3.0/build/vuuno4k/tmp/sysroots/vuuno4k with_mem_check=no
      7. root@vusolo4k:~#
    • Flashl wrote:

      Vielen Dank @slaptap
      Jedoch ist da ja die OpenSSL Version wieder ziemlich outdated? Aktuell wäre doch OpenSSL 1.1.1a 20 Nov 2018?
      Sorry, hat man davon, wenn man durchschnittlich nur noch 3 - 4 Stunden pro Tag schläft.
      Mein Dank geht natürlich an DICH, @bartali !

      Ironischerweise wird in diesem Forum in einem anderen Thread gerade über den 'neuen' Datenklau geredet :happy1:
    • Sorry habe dazu nichts gefunden und interessiert vom technischen Aspekt. Openvpn im autostart, fkt. auch super, aber wie sieht das denn aus wenn die Box im Standby ist?
      Webconf etc. ist ja alles abrufbar, aber kann ja so den Status nicht abrufen, oder ?
      Danke fürs feedback
    • Hallo,

      Ich habe eine DM7020HD mit Merlin3.
      Es wurden beim Update von OpenSSL und OpenVPN alle Pakete ausser "libpam..." benötigt.
      Die Installation hat einwandfrei funktioniert, aber jetzt kann ich nicht mehr per FTP auf die Box zugreifen (Name und PW blieben unverändert). Liegt das an meinem FTP-Programm (evtl. Problem mit SSH), oder fehlt noch etwas bei der Installation?

      LG, Heinzi