IPK Creator 5.0 (Java) By Persian Prince

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Hat das Tool in letzter Zeit mal jemand mit Win10 benutzt?
      Ich bekomme mit der x86 als auch mit der x64 -Version jeweils nur den Splashscreen angezeigt und dann beendet sich das Programm?
      - How much for the Ape? -
    • Ok, ich habs, da hat wohl mit der Java - Version auf meinem PC was geklemmt (war abgelaufen!)
      - How much for the Ape? -
    • Hallo zusammen,

      vielen dank erstmal für das super Tool.

      Ich bräuchte etwas Unterstützung bei den Dependencies.
      1. Möchte ein Depend auf das VTI 14 Image setzen, was muss ich denn da genau eintragen - enigma2-python (>= vti???)
      2. Mein skin benötigt das Systemplugin "exteventinfohandler"
        Wie kann ich den Depend auf das Plugin setzen?
        Wenn dieser gesetzt ist, wird dann das Plugin automatisch vom Feed installiert, sobald jemand meinen Skin bei sich installiert und das plugin "exteventinfohandler" nicht auf der Box ist?
    • für die depends hatte ich bei meinem IPK für EPG-Extradaten folgendes definiert in der control:


      Depends: enigma2-python (>=vti-13.0.9-20180410), enigma2-plugin-skin-iflatfhd (>=v5.9), enigma2-plugin-systemplugins-exteventinfohandler, enigma2-plugin-extensions-epgshare

      muss eben der Modulname sein bei depends, wie ihn die Paketverwaltung "opkg" auch kennt.
      die aktuelle Version einen Moduls bekommt man einfach raus, z.B.: opkg info enigma2-python
      Bei den depends eben z.B. die mindest-Version in Klammern, muss auch nicht der komplette Versions-String sein. "(>=vti-14.0)" müßte auch reichen.

      und im IPK-Creator einzeln pre "+" hinzufügen, der baut dann die control automatisch auf.

      The post was edited 1 time, last by gordon55 ().

    • jep, mWn, wird alles das, was in Depends steht und noch nicht auf dem System ist, zuerst installiert, dann erst das eigentliche Paket.
      d.h. aber auch, wenn irgendeines der Depends nicht installiert werden kann / Fehler auftreten, dann wird das Hauptpaket auch nicht installiert.

      und auch zu beachten ist, dass beim Deinstallieren die Depends NICHT automatisch mit deinstalliert werden beim Standard-Befehl : opkg remove ...
      Dazu müsste man nehmen : opkg --autoremove remove ...