Enigmalight / Ambilight für 4K-Boxen (ARM)

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • ich weiß zwar gerade nicht was Arduino ist ( gegoogelt habe ich es aber )
      aber das wichtigste wäre geht damit dann auch 4k wieder? aktuell habe ich meine solo 4k auf 1080p kastriert ;(
    • vuduofan wrote:

      Ich glaube ich bin dir da keine große Hilfe. Deinem Namen nach nämlich aus deinem Github Repo (Fork von enigmalight). Ich dachte das ist markusmainz' Repo ;)
      Ja ok das erklärt dann die Herkunft ;) weil ich hab das zusammen gebastelt aus den anderen quellen.
      Ja Markus hat ne Dream ich hab ne VU ;) wir arbeiten da zusammen dran
    • Ich hab nochmal ne testversion gebastelt die cpu wird von /tmp/cpu abgefragt

      Source Code

      1. FILE *file = fopen("/tmp/cpu", "r");


      hier besteht die möglichkeit alle CPUs mal vorzugauckeln vielleicht haben wir glück und es ist was passendes dabei.

      Einfach eine datei cpu in tmp anlegen und dort rein die 4 stellige zahl vorne eintragen, dann werden die verschiedenen Parameter gesetzt.

      Source Code

      1. 7400
      2. registeroffset = 0x10100000;
      3. chr_luma_stride = 0x40;
      4. chr_luma_register_offset = 0x20;
      5. mem2memdma_register = 0x10c02000;
      6. 7401
      7. registeroffset = 0x10100000;
      8. chr_luma_stride = 0x40;
      9. chr_luma_register_offset = 0x20;
      10. mem2memdma_register = 0;
      11. 7405
      12. registeroffset = 0x10100000;
      13. chr_luma_stride = 0x80;
      14. chr_luma_register_offset = 0x20;
      15. mem2memdma_register = 0;
      16. 7325
      17. registeroffset = 0x10100000;
      18. chr_luma_stride = 0x80;
      19. chr_luma_register_offset = 0x20;
      20. mem2memdma_register = 0;
      21. 7335
      22. registeroffset = 0x10100000;
      23. chr_luma_stride = 0x40;
      24. chr_luma_register_offset = 0x20;
      25. mem2memdma_register = 0x10c01000;
      26. 7358
      27. registeroffset = 0x10600000;
      28. chr_luma_stride = 0x40;
      29. chr_luma_register_offset = 0x34;
      30. mem2memdma_register = 0;
      31. 7444
      32. registeroffset = 0x10600000;
      33. chr_luma_stride = 0x40;
      34. chr_luma_register_offset = 0x34;
      35. mem2memdma_register = 0;
      36. 7435
      37. registeroffset = 0x10600000;
      38. chr_luma_stride = 0x80;
      39. chr_luma_register_offset = 0x34;
      40. mem2memdma_register = 0;
      41. 73625
      42. registeroffset = 0x10600000;
      43. chr_luma_stride = 0x40;
      44. chr_luma_register_offset = 0x3C;
      45. mem2memdma_register = 0;
      46. 7252
      47. registeroffset = 0xf0600000;
      48. chr_luma_stride = 0x80;
      49. chr_luma_register_offset = 0x3C;
      50. mem2memdma_register = 0;
      Display All
      Im ersten lauf mal mit den Parametern für Mips und die Tage dann für ARM falls nichts passendes dabei wäre.
      Files
    • Hard-Software
      2x VU+ Solo4k
      VU+ Zero
      Samsung UE65JU7090 4kUHD
      Teufel Impaq 7300M
      Samsung SPF-107h
      Netatmo
      HD+ HD02
      Hyperion
      -------------------------
      VTi 11.0.x
      Fluid Skin
      VMC
      AutomaticFullBackup
      Serienrecorder
      Netatmo
      LCD4Linux
      MQB
      EMC
      OScam 1.20 rev: 11277
      OscamButler

      Use Filebot!
    • schau mal in den VU patch...
      aio-grab_vuplus_03b822d1c72c30ba2ce55f8b584be419447dca03.patch

      theoretisch muss mach nur das ganze alte imagegrab gedöns weglassen und stattdessen das bild mit der neuen getvideo2 function holen... und dann halt wie gehabt weitermachen... ich hab aber leider grad keine zeit um mir den enigmalight code anzuschauen...
      VMC
      EPG Share
      VU Alexa Skill
      Fluid Next
      Global Search

      Spenden sind immer herzlich willkommen... einfach hier klicken und das ganze an sbeatz76@googlemail.com schicken
    • einmalacht wrote:

      Einfach eine datei cpu in tmp anlegen und dort rein die 4 stellige zahl vorne eintragen, dann werden die verschiedenen Parameter gesetzt.
      Ich würde es gerne testen, verstehe aber nicht so ganz, wie. Kannst Du es bitte nochmal für DAUs erklären? ;rolleyes:

      Edit: im ihad gibt es inzwischen einige Rückmeldungen, dass die Box mit dem neuen Enigmalight zwischendurch mal grundlos neu startet.
      Gruß Christoph :281:

      The post was edited 1 time, last by chrisly ().

    • eine datei anlegen die sich cpu nennt und diese dann in tmp kopieren in dieser datei können dann die 4 stelligen prozessor typen stehen zum testen der offsets
      Nein teile davon sind wohl aus meinem fork .. vielleicht arbeitet Dima73 auch dran ... wäre cool

      The post was edited 1 time, last by hgdo ().

    • Ich habe jetzt die Datei "cpu" wie beschrieben angelegt und "7444" reingeschrieben (für die Ultimo 4K). Das sollte doch so passen!?
      Mit Deiner enigmalight-Datei ist dann die linke Hälfte der LEDs hellblau, die rechte Hälfte aus (moodlight klappt).
      Gruß Christoph :281:
    • einmalacht wrote:


      Nein teile davon sind wohl aus meinem fork .. vielleicht arbeitet Dima73 auch dran ... wäre cool
      Vlt. mal miteinander kommunizieren. ;) Könnte für alle von Vorteil sein ;)
      Hard-Software
      2x VU+ Solo4k
      VU+ Zero
      Samsung UE65JU7090 4kUHD
      Teufel Impaq 7300M
      Samsung SPF-107h
      Netatmo
      HD+ HD02
      Hyperion
      -------------------------
      VTi 11.0.x
      Fluid Skin
      VMC
      AutomaticFullBackup
      Serienrecorder
      Netatmo
      LCD4Linux
      MQB
      EMC
      OScam 1.20 rev: 11277
      OscamButler

      Use Filebot!
    • Stimmt. :)
      @markusmainz hat mir gestern wieder eine Testversion geschickt - klappt leider auch nicht.
      Gruß Christoph :281:
    • hmmmdada wrote:

      schau mal in den VU patch...
      aio-grab_vuplus_03b822d1c72c30ba2ce55f8b584be419447dca03.patch

      theoretisch muss mach nur das ganze alte imagegrab gedöns weglassen und stattdessen das bild mit der neuen getvideo2 function holen... und dann halt wie gehabt weitermachen... ich hab aber leider grad keine zeit um mir den enigmalight code anzuschauen...
      Kann evtl. jemand was mit diesem Hinweis anfangen, der Ahnung und etwas Zeit hat (ich verstehe leider gar nichts davon, sonst würde ich es versuchen)? Es scheint ja ein wertvoller Tipp zu sein.
      Ich hatte diese Info auch an @markusmainz weitergegeben, der einen Teil davon in seine gestrige Testversion einbaute - leider ohne Erfolg.
      Er hat auch geschrieben, dass die Anpassung sehr aufwändig ist. Das wird wohl kaum jemand machen, der mit VU+ eigentlich nichts zu tun hat. Er hat ja trotzdem schon sehr viel Zeit in die Anpassungen investiert.
      Falls sich jemand finden sollte, der sich das mal anschauen möchte, kann ich die letzte Testversion gerne zur Verfügung stellen.
      Gruß Christoph :281:
    • Irgendwie habe ich die Befürchtung, dass die erste Euphorie verflogen ist und sich nichts mehr tut.
      Ich werde wohl nachher mal versuchen, RPi/Hyperion zum laufen zu bekommen. Anscheinend ist das Problem von EL für die Ultimo 4K ja doch nicht so einfach zu lösen.

      Eine Frage an diejenigen, die eine der Versionen auf der Ul4K installiert hatten: musstet Ihr auch die lib-Dateinen (siehe Post 1) nachinstallieren? Reicht es, sie einfach ins Verzeichnis zu kopieren? Nicht, dass ich da einen Fehler gemacht habe ... ?(
      Zur Sicherheit stelle ich hier mal die letzte Testversion von @markusmainz bereit - vielleicht hat ja jemand mehr Glück als ich.
      Files
      • enigmalight.txt

        (5.12 MB, downloaded 35 times, last: )
      Gruß Christoph :281:
    • chrisly wrote:


      Eine Frage an diejenigen, die eine der Versionen auf der Ul4K installiert hatten: musstet Ihr auch die lib-Dateinen (siehe Post 1) nachinstallieren? Reicht es, sie einfach ins Verzeichnis zu kopieren? Nicht, dass ich da einen Fehler gemacht habe ... ?(
      Zur Sicherheit stelle ich hier mal die letzte Testversion von @markusmainz bereit - vielleicht hat ja jemand mehr Glück als ich.
      Wenn das Binary die Libs nicht finden würde, würde es gar nicht erst starten. Passt also schon :)
    • Okay. Schade - war meine letzte Hoffnung. Also dann: ran an RPi ... ;_(
      Rechte hatte ich auch gesetzt - daran lag es nicht. Das Problem liegt also tiefer und wird nicht so einfach zu lösen sein.

      Ich werde das hier sicher weiter verfolgen und Euch auch auf dem Laufenden halten, falls es im ihad was Neues gibt oder markusmainz mir doch noch eine neue Testversion schickt. Und ich werde mich sicher (für mich) ärgern, falls es irgendwann dann doch funktioniert und ich über 200 € in die RPi-Lösung gesteckt habe. Für Euch würde es mich natürlich freuen.
      Ich bin gespannt, ob und was da noch kommt ...
      Gruß Christoph :281:
    • Enigmalight / Ambilight für 4K-Boxen (ARM)

      Ja das nachkaufen ist ärgerlich. Allerdings sind es auch keine 200€. Du besorgst dir ein rasp, grapper und HDMI av Converter.. LEDs usw hast du oder? ;)
    • Ja, hab ich. Aber das ist ein anderes Thema. Es soll ja hier nicht OT werden ... ;)
      Gruß Christoph :281:
    • HDMI AV Converter ist doch eigentlich gar nicht notwendig. Die Ultimo 4k gibt doch parallel zu HDMI via Composite ein Signal aus, oder nicht?