Problem mit kodi auf VU+ Solo SE V2

    • Problem mit kodi auf VU+ Solo SE V2

      Hallo zusammen,

      Bin leider in diesem Segment noch relativ neu aber komme langsam hinter das meiste :)
      Habe es jetzt geschafft erfolgreich VTI11 auf meine Box zu flashen und passe momentan alles an.
      HD+ Sender laufen auch perfekt jetzt ging es mir noch darum dass ich jetzt vielleicht noch meinen
      raspberry Pi3 der nur für Kodi läuft mit ablösen könnte.
      Habe auch das Kodi Plugin installiert und Kodi selbst läuft auch super.
      Habe die Quelle hinzugefügt und sieht alles super aus hat alles gefunden Freigabe wurde erstellt und sieht
      eigentlich aus wie auf dem Pi3 Sobald ich jedoch einen Film starten will kommt nur ein schwarzer Bildschirm
      und es passiert nichts. Sobald ich dann auf zurück gehe bin ich wieder in der Filmeliste und kodi funktioniert
      weiterhin wie es eigentlich soll. ( Also es hat sich nichts aufgehängt )
      Wisst ihr was ich noch machen kann??

      Im Vorraus schon mal vielen Dank.
      Gruß
    • Die Medien sind nur abspielbar, wenn sie im dateisystem lokal erreichbar sind (incl. der Mounts).
      Falls sie via SMB oder NFS in der Datenbank eingetragen sind schau mal hier: Kodi 16.1 auf Duo2 und advancedsettings.xml
      Konfig

      Solo SE V2 und Uno 4k jeweils ohne Festplatte mit 2 Sat-Eingängen an Astra 19.2
      VTI 11.0.x Standardinstallation mit folgenden Änderungen:
      + KravenFHD
      + Picons Transparent.Stefanbenno06.220.132.19
      - Blindscan
      - Renotecontrolcode
      + AutoTimer
      + EPGRefresh
      + EMC
      + CoolTVGuide
      + Multiquickbutton
      + Verkehrsinfo
      - automount.xml
      + auto.network ( STB -fstype=nfs,rw,soft,tcp,nolock 192.168.178.33:/STB )
      + ln -s /media/net/autofs/STB /media/hdd

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Harvey56 ()

    • OK also es ist schon mal so das ich eigentlich über smb auf die Sammlung zugreife.
      Aber wie gesagt in der Hinsicht bin ich noch blutiger Anfänger und bei dem Link den du mir mitgeschickt
      hast versteh ich nur Bahnhof :(
      Welche Datei ändern die denn da? Und wo finde ich diese?
      Sorry für meine dummen Fragen
    • Dass der Bahnhof irgendwann so kommen wird war mir klar (und ist absolut nicht gegen dich gemeint).

      Ich habe stand Heute keine Idee, wie ich meinen Beitrag einfacher gestalten kann ohne einen Grundkurs in Sachen Freigabemanager und FTP abzuhalten.

      Ich versuche es mal, aber bremse mich wenn es wieder nur Bahnhof wird. Wenn wie es gemeinsam schaffen wird das mit dem andren Beitrag auch etwas.

      Bevor wir überhaupt etwas ändern und falls noch nicht geschehen: Lege sowohl eine Image- Sicherung an als auch die Sicherungen der Einstellungen, Plugins und Senderlisten. Hinweis: das sollte man immer mal machen, nicht nur in dieser Baustelle. VTi Software-Werkzeuge – Vu+ WIKI

      Um eine gemeinsame Begrifflichkeit zu schaffen frage ich sicherheitshalber noch einmal nach:
      Mit "über smb auf die Sammlung zugreife" ist gemeint, dass die in Kodi eingerichteten Pfade mit smb:// beginnen. Richtig?

      Eine Voraussetzung ist, daß die Medien überhaupt auf der Box erreichbar sind (übersetzt: man könnte sie auch in der Aufnahmeliste finden; ggf. auch ausserhalb des Standardverzeichnisses).
      Dazu muss das Netzlaufwerk eingebunden sein. Dies bewerkstelligt man mit dem Freigabemanager (die "autofs.network" aus dem Link gilt mittlerweile als veraltet).

      Eh der Roman überflüssig lang wird mache ich an dieser Stelle Pause. Falls nicht schon geschehen, versuche das mit dem Freigabe Manager – Vu+ WIKI. Wenns nicht klappt frage bitte nach.
      Konfig

      Solo SE V2 und Uno 4k jeweils ohne Festplatte mit 2 Sat-Eingängen an Astra 19.2
      VTI 11.0.x Standardinstallation mit folgenden Änderungen:
      + KravenFHD
      + Picons Transparent.Stefanbenno06.220.132.19
      - Blindscan
      - Renotecontrolcode
      + AutoTimer
      + EPGRefresh
      + EMC
      + CoolTVGuide
      + Multiquickbutton
      + Verkehrsinfo
      - automount.xml
      + auto.network ( STB -fstype=nfs,rw,soft,tcp,nolock 192.168.178.33:/STB )
      + ln -s /media/net/autofs/STB /media/hdd

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Harvey56 ()

    • Vorerst mal vielen Dank für die Geduld und ausführliche Erklärung.
      Das ist erst mal eine sehr gute Idee werde heute gleich als erstes mal eine Sicherung erstellen falls ich wirklich
      irgendwie Schrott baue :)
      Richtig ich gehe wenn ich meinen Pfad in Kodi suche auf Windows Netzwerk SMB und dort wähle ich dann mein Nas aus.
      Danach Frägt er mich ja noch nach Zugriffsdaten (Benutzername und Passwort) und danach zeigt er mir dann auch die Inhalte an.
      Leider funktioniert aber eben keine Wiedergabe.
      Wenn ich dass von der richtig verstanden habe muss ich dann über den Freigabe Manager noch eine Freigabe (Verbindung) auf dem VU+ erstellen oder?
      So wie ich das aus dem Wiki Verstanden habe und ein Qnap Nas (Linux) habe muss ich eine NFS-Verbindung laut Anleitung erstellen oder!?

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Progait ()

    • Mir ist nicht ganz klar, worauf die Frage abzielt.

      Da ich den Freigabemanager aus historischen Gründen noch nie gebaucht habe kann ich es nur in der Theorie beschreiben.

      Typ würde ich für den Anfang CIFS vorschlagen (NFS gilt als geringfügig performanter, aber wir wissen, daß dein NAS für CIFS (=samba) richtig eingerichtet ist).

      Lokaler Freigabename kannst du dir ohne Sonderzeichen selbst aussuchen.

      Server IP ist klar. Server freigabe kommt platt gesagt das hin, was bei dir in Kodi hinter {tt]smb://<ip>/[/tt] steht.

      Als Festplattenersatz verwenden tippe ich auf nein. Für Aufnahmen exitiert schon etwas, oder? Das darf gobal nur einmal vergeben sein.

      Freigabeoptionen lies bitte nochmal in Wiki; mit Pech muß man hier experimentieren (bei meinem QNAP braucht es rw,sec=ntlm)

      Benutzer und PWD ist klar.

      Jetzt kommt der für mich ohne Box schwierig zu erkärende Teil. Es muss noch eine brandneue Option geben, die man auf klassisch und autofs oder so ähnlich stellen kann. ich würde autofs nehmen, das gilt als stabiler, wenn das NAS mal ausfällt.


      Edit: deinen Edit habe ich jetzt erst gesehen. NFS kannst du gerne auch probieren. Wenn es suf Anhieb klappt um so besser.
      Bin bis morgen offline, dann schreibe ich den Rest.
      Konfig

      Solo SE V2 und Uno 4k jeweils ohne Festplatte mit 2 Sat-Eingängen an Astra 19.2
      VTI 11.0.x Standardinstallation mit folgenden Änderungen:
      + KravenFHD
      + Picons Transparent.Stefanbenno06.220.132.19
      - Blindscan
      - Renotecontrolcode
      + AutoTimer
      + EPGRefresh
      + EMC
      + CoolTVGuide
      + Multiquickbutton
      + Verkehrsinfo
      - automount.xml
      + auto.network ( STB -fstype=nfs,rw,soft,tcp,nolock 192.168.178.33:/STB )
      + ln -s /media/net/autofs/STB /media/hdd

      Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von Harvey56 ()

    • Habe das jetzt gestern Abend mal alles ausprobiert :)
      Das mit der Freigabe hat alles prima funktioniert laut wiki auch alle Symbole grün alles perfekt.
      Wenn ich auf den Media Player gehe bekomme ich auch das angegeben Verzeichnis und kann ohne
      Probleme alles sofort abspielen.
      Will ich aber mit Kodi abspielen habe ich das gleiche Problem wie davor.
      Er sieht die Daten erstelle auch die Liste mit Infos aber sobald ich einen Film starten will kommt nur ein schwarzer Bildschirm :(
      Muss man Kodi selbst vielleicht auch irgend welche Freigaben geben?
      Oder muss Kodi sogar nach der neuen Freigabe neu installiert werden?
    • Es geht wie bereits angedeutet noch weiter. Ich wollte ja nur sicherstellen, dass bis hier her alles läuft.

      Es muß noch eine Datei auf der Box abgeändert werden.
      Wenn Du noch keinen FTP-Client hast (z.B. FileZilla) würde ich vorschlagen, Du installierst auf deinem PC das hier gerne vorgeschlagene DCC-Dreambox Control Center E2 v1.50
      Hinweis Ich benutze es grade das erste mal und wundere mich, dass das PWD auf "dreambox" bleiben muss, obwohl es auf meine Box leer ist.

      Sodann gehst Du auf FTP. Als keine Fingerübung zwischendurch (hat noch nichts mit dem Problem zu tun) navigierst Du auf der linken Seite zu hdd/vti-image-backup/vti_11.0.1_solose_<datum> und kopierst den Ordner vuplus auf deinen PC oder Stick. Damit kannst Du deinen letzten Stand flashen, wenn die Box mal nicht mehr booten sollte.

      Weiter zum Problem.
      Du navigierst zu /usr/lib/enigma2/python/Plugins/Extensions/Kodi und kopierst die Datei plugins.py auf deinen PC. Mache noch eine Sicherheitskopie davon.

      Auf dem PC öffnest Du die Datei mit einen Unixkonformen Editor, z.B. Notepad++
      Suche nach session, url = _g_launcher_handler.session, packet. Bei mir ist es aktuell Zeile 139, das kann aber je Nach Versionsstand leicht variieren.
      Dahinter füge eine Zeile ein, die in meinem Beispiel lautet:
      url = url.replace("smb://192.168.178.33/Multimedia/", "/media/net/autofs/nas2/", 1)

      Wichtig sind die führenden 8 Leerzeichen (genau so viele wie in der Zeile darüber). Notepad++ nimmt statt dessen gerne 2 Tabstops, die sind falsch.
      Hinweis: Falls Du eine andere Version hast als ich und die Zeile darüber fängt mit Tabstops an, dann gehören die doch in die neue Zeile.
      Statt smb://192.168.178.33/Multimedia/ nimmst Du exakt den Beginn (bis zum Freigabeordner des NAS) dessen, was Du in Kodi als Pfad eingetragen hast (bei Problemen poste es mal)
      Statt /media/net/autofs/nas2/ nimmst Du den Pfad, unter dem Du diesen Teil auf der Box erreichst (kannst Du im noch geöffneten DreamControCener nachschauen; die eintelnen Ordner werden mit "/" getrennt). Wahrscheinlich ist es bei dir /media/net/autonet/<freigabename>/

      Zum Schluss übertragst Du die Datei auf die Box zurück und startest diese neu.


      Zum Schluß noch ein Hinweis: Da der Ersatz nur in eine Richtung funktioniert kannst Du die Mediathek nicht mit dem Kodi auf der Box updaten.


      Wenn alles läuft könntest Du mir im Gegenzug auch was beibringen. Anscheinend liegt deine Mediathek in Kodi auf der Box wie gewünscht vor. Hast Du dazu die Datei advancedsettings.xml auf eine gemeinsame Datenbank angepasst hast (so wie ich), oder gibt es da noch einen eleganteren Weg?
      Konfig

      Solo SE V2 und Uno 4k jeweils ohne Festplatte mit 2 Sat-Eingängen an Astra 19.2
      VTI 11.0.x Standardinstallation mit folgenden Änderungen:
      + KravenFHD
      + Picons Transparent.Stefanbenno06.220.132.19
      - Blindscan
      - Renotecontrolcode
      + AutoTimer
      + EPGRefresh
      + EMC
      + CoolTVGuide
      + Multiquickbutton
      + Verkehrsinfo
      - automount.xml
      + auto.network ( STB -fstype=nfs,rw,soft,tcp,nolock 192.168.178.33:/STB )
      + ln -s /media/net/autofs/STB /media/hdd
    • Bin leider momentan ziemlich viel unterwegs werde aber deine Anleitung gleich übers Wochenende mal ausprobieren.
      Wie aktualisiere ich dann den die Mediathek sonst ? Muss ich dann immer wenn neue Inhalte auf meinem Nas sind über die
      Dreambox Control aktualisieren?
      Ehrlich gesagt habe ich gar keine Datei angepasst :) Hat gleich funktioniert.