Versehentlich Aufnahmen in "aufgenommene Dateien" gelöscht, Rettung möglich?

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Versehentlich Aufnahmen in "aufgenommene Dateien" gelöscht, Rettung möglich?

      moin,

      ich hab' da wohl gerade eine Riesen-Bock geschossen: Beim Versuch, /Media/hdd als Startverzeichnis für die Aufnahmen zu setzen, habe ich einen Link /medie/hdd gesetzt. Da das auch nicht wirklich funktionierte, habe ich den vermeintlichen Link gelöscht und nun ist meine Festplatte wieder leer - 1,8 für mich teils recht wichtige Daten weg. =O
      Klassischer Fall von "lost in configuration" ;(

      Bisher hatte ich unter VTI immer mit EMC gearbeitet - der Papierkorb da wäre wohl meine Rettung, aber ich finde im auellen VTi keinen.

      War's das oder gibt es eine Möglichkeit, die Daten wieder herzustellen?
    • Durch die Löschung eines Links wird die HDD doch nicht gelöscht?
      Schau mal, ob sie noch richtig eingehängt ist.
      ab anno MMXII amatissimus tyrannus cucinae
    • eingehängt ist sie. Es existiert nur noch ein Verzeichnis movie_trash, welches leer ist.

      Ich bin ja nicht wirklich sicher, was ich da gemacht habe. Beim Aufruf der Aufnahmen erschienenen immer nur 3 Verzeichnisse von ca. 10. Erst wenn ich in eines der Verzeichnisse gegangen bin und über .. zurück, waren alle 10 Verzeichnisse sichtbar. Also habe ich an dieser Stelle (zu den 3 sichtbaren Verzeichnissen) einen Link "media/hdd" gesetzt. War auch nicht, was ich wollte, denn nun tauchten einfach 4 Verzeichnisse auf - nicht komfortabel. Also den "Link" Media/hdd wieder glöscht und schon habe ich eine leere Festplatte. Ich spring gleich aus dem Fenster - zum Glück nur Erdgeschoss ;)

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von mikisb ()

    • Geh mal per FTP auf die HDD und schau nach, obs wirklich gelöscht ist.
      Ich glaube eher, bei dir stimmt was mit der Verzeichnisstruktur nicht.
      ab anno MMXII amatissimus tyrannus cucinae
    • gerade Filezilla installiert:
      Unter /media/hdd ebenfalls nur ein leeres Verzeichnis "movie_trash".
      Aushängen der Platte tut nicht, Meldung: Fehler. Das Gerät /dev/sda1 kann nicht ausgehängt werden. Wahrscheinlich sind Dateien des Systems in Verwendung. Dateisystem ist übrigens ext4.

      edit: Nun ging auf einmal das Aushängen, aber auch erneutes Einhängen brachte keine Änderung. Ich habe die Platte jetzt erst mal ausgehängt, um Schreibzugriffe zu verhindern, denn gleich startet eine Aufnahme.

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von mikisb ()

    • Wie schauen die anderen Verzeichnisse auf der Platte aus?
      Hast du Tmeshift an?
      ab anno MMXII amatissimus tyrannus cucinae
    • Timeshift ist deaktiviert, außer movie_trash gibt es kein Verzeichnis mehr auf der Platte. ist ratzeputz leer.

      Habe die Platte nun ausgehängt, Kaltstart der Box gemacht. Der Assi meldete sich zum Einhängen der Platte. Platte wieder eingehängt - immer noch leer.
      Lasse gerade mal die Plattenprüfung laufen - Ergebnis: "Fehler - ´Fehler bei der Überprüfung der Partition. Die Partition oder das Dateisystem könnten beschädigt sein"

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von mikisb ()

    • Na gut, dann fällt mir auch nichts ein. Aber wenn sie wirklich leer ist, kann man meiner Erfahrung nach so gut wie nichts mehr machen. Vielleicht habe die Experten hier ja andere Vorschläge.
      Tut mir leid :(
      ab anno MMXII amatissimus tyrannus cucinae

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von slandy ()

    • @slandy: Trotzdem vielen Dank für den Versuch!!!
      @duc: ftp sagt das gleiche, ebenso wie Netzwerkzugriff über Win10: Platte leer bis auf dieses ominöse Verzeichnis, welches aber auch leer ist. "movie_trash" gab es vor der Aktion nicht, keine Ahnung, wo das herkommt.

      Bei ausgehängter Platte meldet die Überprüfung keine Fehler, bei eingehängter Platte schon. In welchem Zustand muss eigentlich die Prüfung erfolgen?

      edit: Nochmal Kaltstart - ftp zeigt 4 Einträge:

      lost+found
      movie
      movie_trash
      epg.dat

      Die 3 Verzeichnisse sind komplett leer.

      Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von mikisb ()

    • Auch wenns dir nicht hilft: Das Verzeichnis wird automatisch erstellt. Ist wohl eine Art Papierkorb, ähnlich wie bei Windows.
      ab anno MMXII amatissimus tyrannus cucinae
    • der aber blöderweise nicht benutzt wird, sonst wär's ja gut. Ich bin aber sicher, daß der Ordner vor dem Malheur nicht vorhanden war.
      Mir aber auch immer noch ein Rätsel, wie durch das Löschen eines Links die ganze Platte geputzt wird.
      Gleich kommt die Frau nach Hause - die wird sich freuen wenn alles weg ist (duckundwech...)

      Formatieren kommt erst wenn ich sicher bin, daß wirklich nichts mehr zu retten ist ...

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von mikisb ()

    • Vermutlich hast du nicht den Link gelöscht, sondern das Verzeichnis. Ich weis ja nicht genaut, was du getan hast.

      Wenn die Platte so leer ist, wie du sagst, hast du meines Wissens kaum eine Chance sie wiederherzustellen.

      Ich hatte auch ein ähnliches Problem mit versehentlich gelöschten Dateien und hab mir im Net den Wolf gesucht und nichts produktives gefunden.
      ab anno MMXII amatissimus tyrannus cucinae

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von slandy ()

    • wie geschrieben - folgendes hatte ich gemacht:

      Beim Aufruf der Aufnahmen erschienenen immer nur 3 Verzeichnisse von ca. 10. Erst wenn ich in eines der Verzeichnisse gegangen bin und über .. zurück, waren alle 10 Verzeichnisse sichtbar. Also habe ich an dieser Stelle (zu den 3 sichtbaren Verzeichnissen) über das Kontexttmenü einen Link "media/hdd" gesetzt. War auch nicht, was ich wollte, denn nun tauchten einfach 4 Verzeichnisse auf - nicht komfortabel. Also den "Link" Media/hdd wieder gelöscht und schon habe ich eine leere Festplatte.

      Wenn ich es richtig verstehe, habe ich in einem Unterverzeichnis einen Verweis auf das Oberverzeichnis gesetzt und diesen wieder gelöscht - das darf und kann doch keinen Einfluss auf die Daten haben. Wobei wie gesagt das Verhalten vorher schon merkwürdig war, mit nur zum Teil sichtbaren Aufnahme-Unterverzeichnissen.
      Ich hätte ja auch gerne /media/hdd als Startverzeichnis für die Filmliste eingstellt (hatte ich im EMC so), aber diese Option wurde nicht angeboten.

      Was mich auch wundert: Normalerweise dauert das Löschen von Daten unter ext3/4 ewig, und plötzlich sind 1,8 TB innerhalb von Sekunden weg?????

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von mikisb ()

    • Hab grad nochmal Oberflächlich gesucht und dabei das Programm "ext3rminator" gefunden.
      Google doch einfach mal: ext4 Dateirettung/wiederherstellung
      Und viel Glück mit deiner Frau ;)

      Ich bearbeite meine Verzeichnise normalerweise nicht direkt an der Box, sondern übern PC und Samba, deswegen, weis ich nicht mehr so genau, wie das geht und wo dein Fehler gelegen haben könnte.

      Was zeigt den VTI Speicherplatzauslastung?
      ab anno MMXII amatissimus tyrannus cucinae

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von slandy ()